diff mbox series

[bug#58764] gnu: Add python-rollbar.

Message ID BY5PR07MB7029E1009053588362E62F2F992E9@BY5PR07MB7029.namprd07.prod.outlook.com
State New
Headers show
Series [bug#58764] gnu: Add python-rollbar. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Jaft Oct. 24, 2022, 4:46 p.m. UTC
* gnu/packages/python-xyz.scm (python-rollbar): Add new Python SDK
---
 gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Christopher Baines March 16, 2023, 6:41 p.m. UTC | #1
"Wamm K. D" <jaft.r@outlook.com> writes:

> * gnu/packages/python-xyz.scm (python-rollbar): Add new Python SDK
> ---
>  gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
>  1 file changed, 31 insertions(+)

Thanks for the patch. As the comment at the bottom of the file suggests,
I've moved this up and pushed it to master as
e97ab7fff7f3c9c4833272602951883bfeddba62.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 51136d8e6e..e8ad49ecb2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31233,6 +31233,37 @@  (define-public python-pymonad
 @end itemize")
     (license license:bsd-3)))
 
+(define-public python-rollbar
+  (package
+    (name "python-rollbar")
+    (version "0.16.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "rollbar" version))
+              (sha256
+               (base32
+                "1qpd0j50wqli3867xmhwk65pm1cxjs60yg83mcvcf3kic3y3sc82"))))
+    (build-system python-build-system)
+    (native-inputs (list python-pytest-runner python-unittest2))
+    (inputs (list python-requests
+                  python-six
+                  python-httpx
+                  python-blinker
+                  python-webob))
+    (home-page "https://github.com/rollbar/pyrollbar")
+    (synopsis "Notifier for exceptions, errors, and log messages to Rollbar")
+    (description "Python SDK for reporting exceptions, errors, and log messages
+to @url{https://rollbar.com/, Rollbar}.
+
+Capabilities include:
+
+@itemize @bullet
+@item Sending messages and exceptions with arbitrary context
+@item Getting back aggregates
+@item Debugging production issues
+@end itemize")
+    (license license:expat)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar