diff mbox series

[bug#62105,v2] gnu: zig: Build against a baseline CPU.

Message ID d2a102e6f684c168fe60d4311efb938579e1c156.camel@elenq.tech
State New
Headers show
Series [bug#62105,v2] gnu: zig: Build against a baseline CPU. | expand

Commit Message

Liliana Marie Prikler March 10, 2023, 9:52 p.m. UTC
* gnu/packages/zig.scm (zig-0.10)[#:configure-flags]: Add
“-DZIG_TARGET_MCPU=baseline”.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
---
Hi Ekaitz,

Since this patch didn't cleanly apply with ‘git am’, I ran it through
format-patch once again and also edited the commit message.
If CI succeeds, I'll push it as-is on the 19th.

Cheers,
Liliana

 gnu/packages/zig.scm | 1 +
 1 file changed, 1 insertion(+)

Comments

Ekaitz Zarraga March 12, 2023, 10:01 a.m. UTC | #1
Thank you Liliana, and sorry for the inconvenience.



------- Original Message -------
On Friday, March 10th, 2023 at 9:52 PM, Ekaitz Zarraga <liliana.prikler@gmail.com> wrote:


> * gnu/packages/zig.scm (zig-0.10)[#:configure-flags]: Add
> “-DZIG_TARGET_MCPU=baseline”.
> 
> Signed-off-by: Liliana Marie Prikler liliana.prikler@gmail.com
> 
> ---
> Hi Ekaitz,
> 
> Since this patch didn't cleanly apply with ‘git am’, I ran it through
> format-patch once again and also edited the commit message.
> If CI succeeds, I'll push it as-is on the 19th.
> 
> Cheers,
> Liliana
> 
> gnu/packages/zig.scm | 1 +
> 1 file changed, 1 insertion(+)
> 
> diff --git a/gnu/packages/zig.scm b/gnu/packages/zig.scm
> index 5414b5ba6e..2c89343cb1 100644
> --- a/gnu/packages/zig.scm
> +++ b/gnu/packages/zig.scm
> @@ -56,6 +56,7 @@ (define-public zig-0.10
> '(string-append "-DZIG_TARGET_TRIPLE="
> (%current-target-system))
> '())
> + (string-append "-DZIG_TARGET_MCPU=baseline")
> (string-append "-DZIG_LIB_DIR=" (assoc-ref %outputs "out")
> "/lib/zig"))
> #:validate-runpath? #f ; TODO: zig binary can't find ld-linux.
> --
> 2.39.1
Liliana Marie Prikler March 19, 2023, 8:28 a.m. UTC | #2
Am Sonntag, dem 12.03.2023 um 10:01 +0000 schrieb Ekaitz Zarraga:
> Thank you Liliana, and sorry for the inconvenience.
No problem.

Pushed.
diff mbox series

Patch

diff --git a/gnu/packages/zig.scm b/gnu/packages/zig.scm
index 5414b5ba6e..2c89343cb1 100644
--- a/gnu/packages/zig.scm
+++ b/gnu/packages/zig.scm
@@ -56,6 +56,7 @@  (define-public zig-0.10
                    '(string-append "-DZIG_TARGET_TRIPLE="
                                    (%current-target-system))
                    '())
+             (string-append "-DZIG_TARGET_MCPU=baseline")
              (string-append "-DZIG_LIB_DIR=" (assoc-ref %outputs "out")
                             "/lib/zig"))
        #:validate-runpath? #f       ; TODO: zig binary can't find ld-linux.