@@ -371,3 +371,31 @@ (define-public perl-alien-wxwidgets
(description "Alien::wxWidgets is a Perl module for detecting and
getting configuration settings from an installed wxWidgets package.")
(license l:perl-license)))
+
+(define-public perl-wx
+ (package
+ (name "perl-wx")
+ (version "0.9932")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/M/MD/MDOOTSON/Wx-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0w0vcpk8bmklh16c0z1vxgipnmvdw7cckcmay7k7cihgb99vdz8w"))))
+ (build-system perl-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; Tests require a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1"))))))
+ (native-inputs (list perl-alien-wxwidgets perl-extutils-xspp
+ xorg-server-for-tests wxwidgets))
+ (propagated-inputs (list perl-alien-wxwidgets))
+ (home-page "https://metacpan.org/release/Wx")
+ (synopsis "Perl interface to the wxWidgets cross-platform GUI toolkit")
+ (description "The Wx module is a Perl wrapper for the wxWidgets
+cross-platform GUI toolkit.")
+ (license l:perl-license)))
Hello, in the meantime, perl-data-uuid had already been added to Guix. I have reimported perl-net-bonjour and perl-growl-gntp and pushed them. Then I have adapted your perl-alien-wxwidgets to modern conventions and pushed it. perl-wx as attached fails with the following message, so I did not test perl-wx-glcanvas: No such 'link' library: 'adv' at /tmp/guix-build-perl-wx-0.9932.drv-0/Wx-0.9932/build/Wx/build/MakeMaker.pm line 212. It looks as if the wxwidgets are not found, which makes me wonder if the perl-alien-wxwidgets package is correct... Is there still interest in slic3r? Wikipedia claims that prusa-slicer (which we have) is an improved fork, but maybe it work only with Prusa printers? If there is no interest, I am going to close the bug. Andreas From f12b8bd68c62c48a5655cda36b38ee7e13a5aa00 Mon Sep 17 00:00:00 2001 Message-Id: <f12b8bd68c62c48a5655cda36b38ee7e13a5aa00.1675975292.git.andreas@enge.fr> From: Andreas Enge <andreas@enge.fr> Date: Thu, 9 Feb 2023 21:40:09 +0100 Subject: [PATCH] gnu: Add perl-wx. * gnu/packages/wxwidgets.scm (perl-wx): New variable. --- gnu/packages/wxwidgets.scm | 28 ++++++++++++++++++++++++++++ 1 file changed, 28 insertions(+)