diff mbox series

[bug#60179] gnu: Add d-spy.

Message ID 3a6ad45cf33fc140dc34e8f116b49207c59a9062.camel@gmail.com
State New
Headers show
Series [bug#60179] gnu: Add d-spy. | expand

Commit Message

Liliana Marie Prikler Dec. 18, 2022, 3:29 p.m. UTC
* gnu/packages/gnome.scm (d-spy): New variable.
---
 gnu/packages/gnome.scm | 41 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

Comments

Ludovic Courtès Jan. 17, 2023, 2:56 p.m. UTC | #1
Liliana Marie Prikler <liliana.prikler@gmail.com> skribis:

> * gnu/packages/gnome.scm (d-spy): New variable.

LGTM, thanks!
Liliana Marie Prikler Feb. 5, 2023, 6:18 a.m. UTC | #2
Am Dienstag, dem 17.01.2023 um 15:56 +0100 schrieb Ludovic Courtès:
> Liliana Marie Prikler <liliana.prikler@gmail.com> skribis:
> 
> > * gnu/packages/gnome.scm (d-spy): New variable.
> 
> LGTM, thanks!
Forgot to mark as done.

Thanks
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b6ff8d4fe7..d584d42829 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7429,6 +7429,47 @@  (define-public d-feet
 of running programs and invoke methods on those interfaces.")
     (license license:gpl2+)))
 
+(define-public d-spy
+  (package
+    (name "d-spy")
+    (version "1.4.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/" name "/"
+                                  (version-major+minor version) "/"
+                                  name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0wk7i3vyq4a98g29ms7vz3wy8xkk3pgw48g0fm65qk32xa679s7a"))))
+    (build-system meson-build-system)
+    (arguments
+     (list
+      #:glib-or-gtk? #t
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'skip-gtk-update-icon-cache
+            ;; Don't create 'icon-theme.cache'.
+            (lambda _
+              (substitute* "meson.build"
+                (("gtk_update_icon_cache: true")
+                 "gtk_update_icon_cache: false")))))))
+    (native-inputs
+     (list desktop-file-utils           ; for update-desktop-database
+           `(,glib "bin")
+           gettext-minimal
+           pkg-config))
+    (inputs
+     (list gobject-introspection
+           gtk
+           libadwaita))
+    (home-page "https://gitlab.gnome.org/GNOME/d-spy")
+    (synopsis "D-Bus debugger")
+    (description
+     "D-Spy is a tool to explore and test end-points and interfaces of running
+programs via D-Bus.  It also ships a library for integration into development
+environments.")
+    (license license:gpl2+)))
+
 (define-public yelp-xsl
   (package
     (name "yelp-xsl")