diff mbox series

[bug#60864,v2] gnu: Unify webkitgtk and webkitgtk-next.

Message ID b6193c7288d3818eb678f68194f8a1252b29401c.camel@gmail.com
State New
Headers show
Series [bug#60864,v2] gnu: Unify webkitgtk and webkitgtk-next. | expand

Commit Message

Liliana Marie Prikler Jan. 16, 2023, 5:02 p.m. UTC
* gnu/packages/webkit.scm (%webkit-version): Update to 2.38.3.
(webkitgtk)[source]: Update hash.
[arguments]<#:phases>: Add ‘set-CC’.  Remove ‘patch-gtk-doc-scan’.
[native-inputs]: Remove gtk-doc/stable and docbook-xml.  Add gi-docgen.
(webkitgtk-next)[name]: Rename to ‘webkitgtk-next’.
[source, native-inputs]: Inherit fully.
[arguments]<#:phases>: Inherit fully.
(wpewebkit)[source]: Update hash.
---
In the previous version, I forgot to update teh hash of WPEWebkit.
This is now done.

Sadly, I've already had two builds failing due to the compiler getting
killed near the end.  I hope this is just a limitation on my end and not
a general feature.

Cheers

 gnu/packages/webkit.scm | 47 +++++++++++------------------------------
 1 file changed, 12 insertions(+), 35 deletions(-)

Comments

Maxim Cournoyer Jan. 23, 2023, 1:44 p.m. UTC | #1
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> * gnu/packages/webkit.scm (%webkit-version): Update to 2.38.3.
> (webkitgtk)[source]: Update hash.
> [arguments]<#:phases>: Add ‘set-CC’.  Remove ‘patch-gtk-doc-scan’.
> [native-inputs]: Remove gtk-doc/stable and docbook-xml.  Add gi-docgen.
> (webkitgtk-next)[name]: Rename to ‘webkitgtk-next’.
> [source, native-inputs]: Inherit fully.
> [arguments]<#:phases>: Inherit fully.
> (wpewebkit)[source]: Update hash.
> ---
> In the previous version, I forgot to update teh hash of WPEWebkit.
> This is now done.
>
> Sadly, I've already had two builds failing due to the compiler getting
> killed near the end.  I hope this is just a limitation on my end and not
> a general feature.

I just built both successfully here (x86_64); LGTM.
Liliana Marie Prikler Jan. 29, 2023, 7:27 a.m. UTC | #2
Am Montag, dem 23.01.2023 um 08:44 -0500 schrieb Maxim Cournoyer:
> Hi Liliana,
> 
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> 
> > * gnu/packages/webkit.scm (%webkit-version): Update to 2.38.3.
> > (webkitgtk)[source]: Update hash.
> > [arguments]<#:phases>: Add ‘set-CC’.  Remove ‘patch-gtk-doc-scan’.
> > [native-inputs]: Remove gtk-doc/stable and docbook-xml.  Add gi-
> > docgen.
> > (webkitgtk-next)[name]: Rename to ‘webkitgtk-next’.
> > [source, native-inputs]: Inherit fully.
> > [arguments]<#:phases>: Inherit fully.
> > (wpewebkit)[source]: Update hash.
> > ---
> > In the previous version, I forgot to update teh hash of WPEWebkit.
> > This is now done.
> > 
> > Sadly, I've already had two builds failing due to the compiler
> > getting killed near the end.  I hope this is just a limitation on
> > my end and not a general feature.
> 
> I just built both successfully here (x86_64); LGTM.
Thanks for the review.  Pushed now.
diff mbox series

Patch

diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 29f89721b7..35fb5926a3 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -124,18 +124,18 @@  (define-public wpebackend-fdo
 engine that uses Wayland for graphics output.")
     (license license:bsd-2)))
 
-(define %webkit-version "2.36.8")       ;webkit2gtk4
+(define %webkit-version "2.38.3")
 
 (define-public webkitgtk
   (package
-    (name "webkitgtk")
+    (name "webkitgtk")                  ; webkit2gtk4
     (version %webkit-version)
     (source (origin
               (method url-fetch)
               (uri (string-append "https://www.webkitgtk.org/releases/"
                                   name "-" version ".tar.xz"))
               (sha256
-               (base32 "0dq4s0rw3cmsxlv22pc38qdsq4wx2yyq9wgsi4wgw243y9mzpn8a"))
+               (base32 "0njac0878ksh53gn50phly1vzvj08q7g5aclncv6k324xp8h3w21"))
               (patches (search-patches
                         "webkitgtk-adjust-bubblewrap-paths.patch"))))
     (build-system cmake-build-system)
@@ -166,6 +166,11 @@  (define-public webkitgtk
       #:make-flags #~(list "-j" (number->string (max 2 (parallel-job-count))))
       #:phases
       #~(modify-phases %standard-phases
+          (add-before 'build 'set-CC
+            (lambda _
+              ;; Some Perl scripts check for the CC environment variable, else
+              ;; use /usr/bin/gcc.
+              (setenv "CC" #$(cc-for-target))))
           (add-after 'unpack 'configure-bubblewrap-store-directory
             (lambda _
               ;; This phase works in tandem with
@@ -189,12 +194,6 @@  (define-public webkitgtk
                 ;; the pkg-config search to locate headers.
                 (("pkg_check_modules\\(PC_SYSTEMD QUIET libsystemd")
                  "pkg_check_modules(PC_SYSTEMD QUIET libelogind"))))
-          (add-after 'unpack 'patch-gtk-doc-scan
-            (lambda* (#:key native-inputs inputs #:allow-other-keys)
-              (substitute* (find-files "Source" "\\.sgml$")
-                (("http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd")
-                 (search-input-file (or native-inputs inputs)
-                                    "xml/dtd/docbook/docbookx.dtd")))))
           (add-after 'unpack 'embed-absolute-wpebackend-reference
             (lambda* (#:key inputs #:allow-other-keys)
               (let ((wpebackend-fdo (assoc-ref inputs "wpebackend-fdo")))
@@ -223,9 +222,7 @@  (define-public webkitgtk
            perl
            pkg-config
            python-wrapper
-           ;; These are required to build the documentation.
-           gtk-doc/stable
-           docbook-xml
+           gi-docgen
            ruby))
     (propagated-inputs
      (list gtk+ libsoup))
@@ -282,33 +279,13 @@  (define-public webkitgtk
 (define-public webkitgtk-next
   (package
     (inherit webkitgtk)
-    (name "webkitgtk")
-    (version "2.38.3")                  ;webkit2gtk5
-    (source (origin
-              (inherit (package-source webkitgtk))
-              (method url-fetch)
-              (uri (string-append "https://www.webkitgtk.org/releases/"
-                                  name "-" version ".tar.xz"))
-              (sha256
-               (base32 "0njac0878ksh53gn50phly1vzvj08q7g5aclncv6k324xp8h3w21"))))
-    (build-system cmake-build-system)
+    (name "webkitgtk-next")             ; webkit2gtk5
     (arguments
      (substitute-keyword-arguments (package-arguments webkitgtk)
        ((#:configure-flags flags)
         #~(cons* "-DENABLE_INTROSPECTION=ON"
                  "-DUSE_GTK4=ON"
-                 (delete "-DENABLE_GTKDOC=ON" #$flags)))
-       ((#:phases phases)
-        #~(modify-phases #$phases
-            (add-before 'build 'set-CC
-              (lambda _
-                ;; Some Perl scripts check for the CC environment variable, else
-                ;; use /usr/bin/gcc.
-                (setenv "CC" "gcc")))))))
-    (native-inputs
-     (modify-inputs (package-native-inputs webkitgtk)
-       (delete "docbook-xml" "gtk-doc")
-       (append gi-docgen)))
+                 (delete "-DENABLE_GTKDOC=ON" #$flags)))))
     (propagated-inputs
      (modify-inputs (package-propagated-inputs webkitgtk)
        (replace "gtk+" gtk)))
@@ -340,7 +317,7 @@  (define-public wpewebkit
               (uri (string-append "https://wpewebkit.org/releases/"
                                   name "-" version ".tar.xz"))
               (sha256
-               (base32 "1svmvj96c0lhdhs7fndgwchkvv4wyb7gwd4d3fbd1chhr54s6hld"))))
+               (base32 "160456k4yiml0zn2fxba9qwp94dvvn93z9rqs2qa2lvjxig0gn8x"))))
     (arguments
      (substitute-keyword-arguments (package-arguments webkitgtk)
        ((#:configure-flags flags)