diff mbox series

[bug#60789,v2] gnu: moreutils: Fix missing library.

Message ID 20230113212426.1195945-1-code@greghogan.com
State New
Headers show
Series [bug#60789,v2] gnu: moreutils: Fix missing library. | expand

Commit Message

Greg Hogan Jan. 13, 2023, 9:24 p.m. UTC
Same patch as before with a more proper log message.

* gnu/packages/moreutils.scm (moreutils): Fix missing library.
[arguments]<#:phases>{wrap-program}: Set Perl library path for all
scripts.
[inputs]: Add perl-ipc-run.
---
 gnu/packages/moreutils.scm | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)

Comments

宋文武 Jan. 28, 2023, 2:38 a.m. UTC | #1
Greg Hogan <code@greghogan.com> writes:

> Same patch as before with a more proper log message.
>
> * gnu/packages/moreutils.scm (moreutils): Fix missing library.
> [arguments]<#:phases>{wrap-program}: Set Perl library path for all
> scripts.
> [inputs]: Add perl-ipc-run.

Applied, thank you!  Though I think only perl scripts needed to to
wrapped, but it's no harm for ELF executables too...
diff mbox series

Patch

diff --git a/gnu/packages/moreutils.scm b/gnu/packages/moreutils.scm
index 5c9560530b..4b0b617bde 100644
--- a/gnu/packages/moreutils.scm
+++ b/gnu/packages/moreutils.scm
@@ -49,9 +49,11 @@  (define-public moreutils
            #~(modify-phases %standard-phases
                (add-after 'install 'wrap-program
                  (lambda _
-                   (wrap-program
-                       (string-append #$output "/bin/ts")
-                     `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB"))))))
+                   (for-each
+                     (lambda (script)
+                       (wrap-program script
+                         `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB")))))
+                     (find-files (string-append #$output "/bin")))))
                (delete 'configure))     ; no configure script
            #:make-flags
            #~(list (string-append "PREFIX=" #$output)
@@ -63,6 +65,7 @@  (define-public moreutils
                    (string-append "CC=" #$(cc-for-target)))))
     (inputs
      (list perl
+           perl-ipc-run
            perl-timedate
            perl-time-duration))
     ;; For building the manual pages.