diff mbox series

[bug#60997,4/4] gnu: Add python-metaphlan.

Message ID 20230122004951.119277-4-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#60997,1/4] gnu: Add python-cmseq. | expand

Commit Message

Mădălin Ionel Patrașcu Jan. 22, 2023, 12:49 a.m. UTC
* gnu/packages/bioinformatics.scm (python-metaphlan): New variable.
---
 gnu/packages/bioinformatics.scm | 37 +++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

Comments

Ricardo Wurmus Jan. 24, 2023, 9:11 a.m. UTC | #1
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

> * gnu/packages/bioinformatics.scm (python-metaphlan): New variable.

Unfortunately, this one is also incomplete.

The package includes R code that needs to have its dependencies
satisfied.  It also calls out to bowtie2, and needs raxml, muscle,
blast, etc.

The clash of biopython versions will also need to be addressed.

I’ll push as much as is feasible, but I’d like to ask you to rework this
package definition in particular.

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 5c9c222d59..884e5aa1e5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11234,6 +11234,43 @@  (define-public python-biothings-client
 API services.")
     (license license:bsd-3)))
 
+(define-public python-metaphlan
+  (package
+    (name "python-metaphlan")
+    (version "4.0.4")
+    (source
+     (origin
+     (method url-fetch)
+              (uri (pypi-uri "MetaPhlAn" version))
+              (sha256
+               (base32
+                "1jw29m8p8bcwn4q5qvh8s96qlgqv1kaizbmm87jk55f34k1y3y8a"))))
+    (build-system python-build-system)
+    (arguments
+     (list
+      #:tests? #f)) ;pypi no tests
+    (propagated-inputs
+     (list python-biom-format
+           python-biopython
+           python-cmseq
+           python-dendropy
+           python-h5py
+           python-hclust2
+           python-numpy
+           python-pandas
+           python-phylophlan
+           python-pysam
+           python-requests
+           python-scipy))
+    (home-page "http://github.com/biobakery/MetaPhlAn/")
+    (synopsis "Metagenomic phylogenetic analysis")
+    (description
+     "MetaPhlAn is a computational tool for profiling the composition of microbial
+communities (Bacteria, Archaea and Eukaryotes) from metagenomic shotgun sequencing
+data (i.e.  not 16S) with species-level.  With the newly added StrainPhlAn module,
+it is now possible to perform accurate strain-level microbial profiling.")
+    (license license:expat)))
+
 (define-public python-multivelo
   (package
     (name "python-multivelo")