diff mbox series

[bug#60997,3/4] gnu: Add python-phylophlan.

Message ID 20230122004951.119277-3-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#60997,1/4] gnu: Add python-cmseq. | expand

Commit Message

Mădălin Ionel Patrașcu Jan. 22, 2023, 12:49 a.m. UTC
* gnu/packages/bioinformatics.scm (python-phylophlan): New variable.
---
 gnu/packages/bioinformatics.scm | 43 +++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)

Comments

Ricardo Wurmus Jan. 24, 2023, 9:10 a.m. UTC | #1
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

> +    (build-system python-build-system)

Please use pyproject-build-system where possible.

> +    (arguments
> +     (list
> +      #:tests? #f ;pypi no tests

There are no tests, nothing to do with pypi.

> +      #:phases
> +      #~(modify-phases %standard-phases
> +          ;;pypi does not provide the readme.md file
> +          (add-before 'build 'loose-readme-file-requirement
> +           (lambda _
> +              (substitute* "setup.py"
> +                (("long_description")
> +                  "#long_description")))))))

I changed this to just fetch the source from git.

> +    (propagated-inputs
> +     (list python-biopython

This will become a problem down the line when combined with cmseq.
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index bf01c9c7e4..5c9c222d59 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1089,6 +1089,49 @@  (define-public python-htsget
 servers supporting the protocol.")
    (license license:asl2.0)))
 
+(define-public python-phylophlan
+  (package
+    (name "python-phylophlan")
+    (version "3.0.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "PhyloPhlAn" version))
+              (sha256
+               (base32
+                "1r1bnnh4d38l410hfzf882y43ln8fd2lcsqbralqshxqw2hzc7x7"))))
+    (build-system python-build-system)
+    (arguments
+     (list
+      #:tests? #f ;pypi no tests
+      #:phases
+      #~(modify-phases %standard-phases
+          ;;pypi does not provide the readme.md file
+          (add-before 'build 'loose-readme-file-requirement
+           (lambda _
+              (substitute* "setup.py"
+                (("long_description")
+                  "#long_description")))))))
+    (propagated-inputs
+     (list python-biopython
+           python-dendropy
+           python-matplotlib
+           python-numpy
+           python-pandas
+           python-seaborn))
+    (home-page "https://github.com/biobakery/phylophlan")
+    (synopsis
+     "Phylogenetic analysis of microbial isolates and genomes from metagenomes")
+    (description
+     "This package is an integrated pipeline for large-scale phylogenetic profiling
+of genomes and metagenomes.  PhyloPhlAn is an accurate, rapid, and easy-to-use
+method for large-scale microbial genome characterization and phylogenetic analysis
+at multiple levels of resolution.  This software package can assign both genomes
+and @acronym{MAGs, metagenome-assembled genomes} to @acronym{SGBs, species-level
+genome bins}.  PhyloPhlAn can reconstruct strain-level phylogenies using clade-
+specific maximally informative phylogenetic markers, and can also scale to very
+large phylogenies comprising >17,000 microbial species.")
+    (license license:expat)))
+
 (define-public python-pybedtools
   (package
     (name "python-pybedtools")