diff mbox series

[bug#61010] gnu: Add icewm

Message ID CAJsg1E_sqTdfO7aFTfD3MGLv2RqiYs=m2YhjgHOUD8jx=C2OMg@mail.gmail.com
State New
Headers show
Series [bug#61010] gnu: Add icewm | expand

Commit Message

Andy Tai Jan. 22, 2023, 8:37 p.m. UTC

Comments

Andy Tai Jan. 23, 2023, 5:33 p.m. UTC | #1
patch based on email discussions between

白い熊@相撲道 <help-guix_gnu.org@sumou.com>
and
zimoun

in the thread https://mail.gnu.org/archive/html/help-guix/2022-05/msg00098.html
Simon Tournier Jan. 24, 2023, 12:26 p.m. UTC | #2
Hi,

Thanks for the follow up. :-)

The patch builds fine and it LTGM except one minor point.


On dim., 22 janv. 2023 at 12:37, Andy Tai <atai@atai.org> wrote:

> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append
> +                    "https://github.com/ice-wm/icewm/releases/download/"
> +                    version "/icewm-" version ".tar.lz"))

This archive contains generated .gmo which are not in the source code
[1] and I do not know what is the usual Guix policy about that.  Do we
re-generate them?

Other said, these files are in the archive tar.gz [2].

1: <https://github.com/ice-wm/icewm/tree/3.3.1/po>
2: <https://github.com/ice-wm/icewm/archive/refs/tags/3.3.1.tar.gz>


> \ No newline at end of file

This patch does not apply to current master.  From my point of view, it
is worth to provide the base-commit (see --base option of
git-format-patch or git-send-email).

And it helps if the new package is not added to the end of the file.
For instance, I would put it between i3lock-fancy and xmonad-next.


Cheers,
simon
Feng Shu Feb. 6, 2023, 11:43 a.m. UTC | #3
I think we shoud add gtk to input, so icewm-menu-fdo can be build.
宋文武 Feb. 10, 2023, 5:48 a.m. UTC | #4
> I think we shoud add gtk to input, so icewm-menu-fdo can be build.

Done, and add GLIB is enough.

Thank you!
diff mbox series

Patch

From bd669eb4d0d7fc3b79adf8b90f04e9cfee8b0906 Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Sun, 22 Jan 2023 12:35:32 -0800
Subject: [PATCH] gnu: Add icewm

* gnu/packages/wm.scm (icewm): New variable
---
 gnu/packages/wm.scm | 58 +++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 58 insertions(+)

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index b93c57b888..a65b53f8f2 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -97,6 +97,7 @@  (define-module (gnu packages wm)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages build-tools)
   #:use-module (gnu packages calendar)
+  #:use-module (gnu packages compression)
   #:use-module (gnu packages check)
   #:use-module (gnu packages datastructures)
   #:use-module (gnu packages docbook)
@@ -2918,3 +2919,60 @@  (define-public grimshot
 an interface over @code{grim}, @code{slurp} and @code{jq}, and supports storing
 the screenshot either directly to the clipboard using @code{wl-copy} or to a
 file.")))
+
+
+(define-public icewm
+  (package
+    (name "icewm")
+    (version "3.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/ice-wm/icewm/releases/download/"
+                    version "/icewm-" version ".tar.lz"))
+              (sha256
+               (base32
+                "14vkv5r9rvwfj8gmdsrkkq7vxvk2j7z7wfybzc8ywj469yya5ppq"))))
+    (build-system gnu-build-system)
+    (native-inputs (list pkg-config))
+    (inputs (list fontconfig
+                  fribidi
+                  imlib2
+                  libice
+                  libjpeg-turbo
+                  libsm
+                  libxcomposite
+                  libxdamage
+                  libxext
+                  libxfixes
+                  libxft
+                  libxinerama
+                  libxpm
+                  libxrandr
+                  libxrender
+                  libx11
+                  lzip
+                  perl))
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'skip-failing-test
+                    ;; strtest.cc tests failing due to $HOME and /etc setup difference under guix
+                    (lambda _
+                      (substitute* "src/Makefile.in"
+                        (("TESTS = strtest\\$\\(EXEEXT\\)")
+                         "TESTS = ")) #t)))))
+    (home-page "https://ice-wm.org/")
+    (synopsis "Window manager for the X Window System")
+    (description
+     "IceWM is a window manager for the X Window System.  The goal of
+IceWM is speed, simplicity, and not getting in the user’s way.  It comes with a
+taskbar with pager, global and per-window keybindings and a dynamic menu system.
+Application windows can be managed by keyboard and mouse.  Windows
+can be iconified to the taskbar, to the tray, to the desktop or be made
+hidden.  They are controllable by a quick switch window (Alt+Tab) and in a
+window list.  A handful of configurable focus models are
+menu-selectable.  Setups with multiple monitors are supported by RandR and
+Xinerama.  IceWM is very configurable, themeable and well documented.  It
+includes an optional external background wallpaper manager with transparency
+support, a simple session manager and a system tray.")
+    (license license:gpl2)))
\ No newline at end of file
-- 
2.39.1