diff mbox series

[bug#61008] gnu: emacs-smartparens: Fix package cl deprecation.

Message ID 20230122162913.25140-1-ngraves@ngraves.fr
State New
Headers show
Series [bug#61008] gnu: emacs-smartparens: Fix package cl deprecation. | expand

Commit Message

Nicolas Graves Jan. 22, 2023, 4:29 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-smartparens):
[arguments] Fix package cl deprecation.
---
 gnu/packages/emacs-xyz.scm | 11 +++++++++++
 1 file changed, 11 insertions(+)

Comments

Nicolas Goaziou Jan. 22, 2023, 4:34 p.m. UTC | #1
Hello,

Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-smartparens):
> [arguments] Fix package cl deprecation.
> ---
>  gnu/packages/emacs-xyz.scm | 11 +++++++++++
>  1 file changed, 11 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index ed5c3bd71d..8bde2825f1 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -10575,6 +10575,17 @@ (define-public emacs-smartparens
>         (sha256
>          (base32 "0zij2f2rjjym98w68jkp10n1ckpfprlkk217c3fg16hz5nq4vnm6"))))
>      (build-system emacs-build-system)
> +    (arguments
> +     (list
> +      #:phases
> +      #~(modify-phases %standard-phases
> +          (add-after 'unpack 'fix-deprecated-cl-warning
> +            (lambda _
> +              (substitute* "smartparens.el"
> +                ((string-append
> +                  "\\(eval-when-compile \\(require 'cl\\)\\) "
> +                  " ; for `lexical-let'")
> +                 "")))))))

AFAIU, we're fixing a mere warning. Why do you think it is worth
a patch?

Regards,
Nicolas Graves Jan. 22, 2023, 7:19 p.m. UTC | #2
> AFAIU, we're fixing a mere warning.
Indeed, it's the case for both patches.

> Why do you think it is worth a patch?

I was just curious about the warning and looked for packages trigerring
it in my config, which are the two packages I sent.

Smartparens is regularly updated but doesn't make new releases, I
hesitated upadting it based on a commit, or use this patch.

Origami's original repo hasn't changed in 5 years, but it had a pull
request waiting for it.

Both are quite used, but still trigger the warning since their codebase
age. Their guix users have the warning and might enquire "for nothing
serious". But all-in-all, it is neither urgent nor important, you can
close both patches if you feel it's better without ;)
Nicolas Goaziou Jan. 22, 2023, 10:09 p.m. UTC | #3
Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:

> Smartparens is regularly updated but doesn't make new releases, I
> hesitated upadting it based on a commit, or use this patch.

Note that emacs-smartparens doesn't build with your patch
<https://qa.guix.gnu.org/issue/61008>.

It may be worth updating it to latest commit in that case.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ed5c3bd71d..8bde2825f1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10575,6 +10575,17 @@  (define-public emacs-smartparens
        (sha256
         (base32 "0zij2f2rjjym98w68jkp10n1ckpfprlkk217c3fg16hz5nq4vnm6"))))
     (build-system emacs-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'fix-deprecated-cl-warning
+            (lambda _
+              (substitute* "smartparens.el"
+                ((string-append
+                  "\\(eval-when-compile \\(require 'cl\\)\\) "
+                  " ; for `lexical-let'")
+                 "")))))))
     (propagated-inputs
      (list emacs-dash emacs-markdown-mode))
     (home-page "https://github.com/Fuco1/smartparens")