diff mbox series

[bug#60957,1/2] gnu: Add r-doubletcollection.

Message ID 20230120085800.47650-1-navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#60957,1/2] gnu: Add r-doubletcollection. | expand

Commit Message

nafkhamdc Jan. 20, 2023, 8:57 a.m. UTC
* gnu/packages/bioinformatics.scm (r-doubletcollection): New variable.
---
 gnu/packages/bioinformatics.scm | 40 +++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)

Comments

Ricardo Wurmus Jan. 20, 2023, 10:07 a.m. UTC | #1
Thanks for the patch.  Applied!
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 36c9db90bd..86d65d2031 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7986,6 +7986,46 @@  (define-public r-chromunity
 Pore-C concatemers.")
       (license license:gpl3))))
 
+(define-public r-doubletcollection
+  (let ((commit "c0d62f1853942ee6a087eaf7b000d9e4261e2dfd")
+        (revision "1"))
+    (package
+      (name "r-doubletcollection")
+      (version (git-version "1.1.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/xnnba1984/DoubletCollection")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "02cvibyc2nwc4037ramm5cskjwyrb9ib9hkrfhmvhbslkn5ixz1v"))))
+      (properties `((upstream-name . "DoubletCollection")))
+      (build-system r-build-system)
+      (propagated-inputs (list r-biocgenerics
+                               r-doubletfinder
+                               r-gam
+                               r-ggplot2
+                               r-ggthemes
+                               r-mast
+                               r-mclust
+                               r-prroc
+                               r-reticulate
+                               r-scales
+                               r-scdblfinder
+                               r-scds
+                               r-seurat
+                               r-singlecellexperiment
+                               r-slingshot
+                               r-summarizedexperiment))
+      (home-page "https://github.com/xnnba1984/DoubletCollection")
+      (synopsis "Tool for finding doublets in scRNA-seq data")
+      (description
+       "This is an R package that integrates the installation of doublet-detection methods.  
+In addition, this tool is used for execution and benchmark of those eight mentioned methods.")
+      (license license:gpl3+))))
+
 (define-public r-pando
   (package
     (name "r-pando")