diff mbox series

[bug#43236,emacs-guix] elisp: guix-set-emacs-environment: Also update Emacs' path.

Message ID 20200906084646.28115-1-janneke@gnu.org
State New
Headers show
Series [bug#43236,emacs-guix] elisp: guix-set-emacs-environment: Also update Emacs' path. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Janneke Nieuwenhuizen Sept. 6, 2020, 8:46 a.m. UTC
This helps Geiser find the correct (environment's) Guile.

* elisp/guix-misc.el (guix-set-emacs-environment): Set "exec-path"
when setting "PATH" variable.
---
 elisp/guix-misc.el | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

Comments

Maxim Cournoyer Jan. 16, 2023, 6:03 p.m. UTC | #1
Hi Janneke,

"Jan (janneke) Nieuwenhuizen" <janneke@gnu.org> writes:

> This helps Geiser find the correct (environment's) Guile.
>
> * elisp/guix-misc.el (guix-set-emacs-environment): Set "exec-path"
> when setting "PATH" variable.
> ---
>  elisp/guix-misc.el | 6 ++++--
>  1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/elisp/guix-misc.el b/elisp/guix-misc.el
> index 6f79fe6..7e9c068 100644
> --- a/elisp/guix-misc.el
> +++ b/elisp/guix-misc.el
> @@ -1,7 +1,7 @@
>  ;;; guix-misc.el --- Miscellaneous definitions  -*- lexical-binding: t -*-
>  
>  ;; Copyright © 2014–2018 Alex Kost <alezost@gmail.com>
> -;; Copyright © 2018 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
> +;; Copyright © 2018,2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>

There's no use for a copyright line here as the change is not
substantial enough (< 10 lines).

>  ;; This file is part of Emacs-Guix.
>  
> @@ -242,7 +242,9 @@ If PROFILE is nil, use `guix-current-profile'."
>                (value (if (and separator current-value)
>                           (concat path separator current-value)
>                         path)))
> -        (setenv variable value)))))
> +        (setenv variable value)
> +        (when (equalp variable "PATH")
> +          (setq exec-path (split-string value ":")))))))

That's still useful with Emacs 28, right?  If you can confirm it, LGTM.
Janneke Nieuwenhuizen Jan. 16, 2023, 9:33 p.m. UTC | #2
Maxim Cournoyer writes:

Hi Maxim,

> "Jan (janneke) Nieuwenhuizen" <janneke@gnu.org> writes:
>
>> This helps Geiser find the correct (environment's) Guile.
>> -;; Copyright © 2018 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
>> +;; Copyright © 2018,2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
>
> There's no use for a copyright line here as the change is not
> substantial enough (< 10 lines).

Ah...I guess I figured that we need copyright years to be updated in all
years the program is "released".  Oh well...

>> +        (when (equalp variable "PATH")
>> +          (setq exec-path (split-string value ":")))))))
>
> That's still useful with Emacs 28, right?  If you can confirm it, LGTM.

It's still useful...but also...I found this has already been installed
as

    commit d246b2c443bbb9d49575b63bb78c14699c4448cf
    elisp/misc: Update Emacs path if needed

and

    41fba4eec845e050be92bfe76c0f7980bbe821bd
    Fix the previous commit

Sorry for the noise...Closing.

Greetings,
Janneke
Maxim Cournoyer Jan. 17, 2023, 1:46 a.m. UTC | #3
Hi Janneke,

Janneke Nieuwenhuizen <janneke@gnu.org> writes:

[...]

> It's still useful...but also...I found this has already been installed
> as
>
>     commit d246b2c443bbb9d49575b63bb78c14699c4448cf
>     elisp/misc: Update Emacs path if needed
>
> and
>
>     41fba4eec845e050be92bfe76c0f7980bbe821bd
>     Fix the previous commit
>
> Sorry for the noise...Closing.

I see!  Thanks for your reply and closing it!
diff mbox series

Patch

diff --git a/elisp/guix-misc.el b/elisp/guix-misc.el
index 6f79fe6..7e9c068 100644
--- a/elisp/guix-misc.el
+++ b/elisp/guix-misc.el
@@ -1,7 +1,7 @@ 
 ;;; guix-misc.el --- Miscellaneous definitions  -*- lexical-binding: t -*-
 
 ;; Copyright © 2014–2018 Alex Kost <alezost@gmail.com>
-;; Copyright © 2018 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;; Copyright © 2018,2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
 
 ;; This file is part of Emacs-Guix.
 
@@ -242,7 +242,9 @@  If PROFILE is nil, use `guix-current-profile'."
               (value (if (and separator current-value)
                          (concat path separator current-value)
                        path)))
-        (setenv variable value)))))
+        (setenv variable value)
+        (when (equalp variable "PATH")
+          (setq exec-path (split-string value ":")))))))
 
 
 ;;; Executing guix commands