diff mbox series

[bug#59093] gnu: Add xnedit

Message ID CAJsg1E-xRPCdq-fAP7Bz0Q0W4mtuFpg9TxrXGn-ZRKc4FSAcGQ@mail.gmail.com
State New
Headers show
Series [bug#59093] gnu: Add xnedit | expand

Commit Message

Andy Tai Jan. 11, 2023, 2:44 a.m. UTC
I tried to use the new "G-exp" style but that would not build, so I
keep the old style.

Other comment addressed.

Updated patch attached

On Sat, Jan 7, 2023 at 7:14 AM Andy Tai <atai@atai.org> wrote:
>
> Hi, I guess I will need to update the patch to fit the new style.
>

Comments

Simon Tournier Jan. 11, 2023, 3:02 p.m. UTC | #1
Hi,

On mer., 11 janv. 2023 at 02:44, Andy Tai <atai@atai.org> wrote:

> I tried to use the new "G-exp" style but that would not build, so I
> keep the old style.

Done with patch subject [PATCH v2].

Cheers,
simon

PS: Please consider sending as a same patch set related patches.  For
instance, this addition of xnedit requires the addition of motif so they
should be part of the same series.

Easing the reviewer’s job eases the merge, IMHO. :-)

For example, it is easier to apply the two patches, then “./pre-inst-env
guix build xnedit“; than dig the bug tracker in order to find, maybe,
the other submission.  Moreover, being part of the same submission eases
the QA, again IMHO.

Anyway, thanks for the patches. :-)
Andy Tai Jan. 12, 2023, 3:25 a.m. UTC | #2
Simon, thanks.  So what is remaining to be addressed as I see it is
still pending or the issue is still open

On Wed, Jan 11, 2023 at 7:03 AM Simon Tournier <zimon.toutoune@gmail.com> wrote:
>
> Done with patch subject [PATCH v2].
>
> Cheers,
> simon
>
> PS: Please consider sending as a same patch set related patches.  For
> instance, this addition of xnedit requires the addition of motif so they
> should be part of the same series.
>
> Easing the reviewer’s job eases the merge, IMHO. :-)
>
> For example, it is easier to apply the two patches, then “./pre-inst-env
> guix build xnedit“; than dig the bug tracker in order to find, maybe,
> the other submission.  Moreover, being part of the same submission eases
> the QA, again IMHO.
>
> Anyway, thanks for the patches. :-)
>
Simon Tournier Jan. 12, 2023, 10:03 a.m. UTC | #3
Hi,

On Thu, 12 Jan 2023 at 04:26, Andy Tai <atai@atai.org> wrote:

> Simon, thanks.  So what is remaining to be addressed as I see it is
> still pending or the issue is still open

The patch v2 is ready to be merged; all is addressed from my eyes.
But I have not have commit access so I cannot push and close this
submission. :-)

Cheers,
simon
Andy Tai Jan. 12, 2023, 10:08 a.m. UTC | #4
Thanks... I cannot tell who has the commit access... I assume you do as you
review patches :-)

On Thu, Jan 12, 2023 at 2:03 AM Simon Tournier <zimon.toutoune@gmail.com>
wrote:

> Hi,
>
> On Thu, 12 Jan 2023 at 04:26, Andy Tai <atai@atai.org> wrote:
>
> > Simon, thanks.  So what is remaining to be addressed as I see it is
> > still pending or the issue is still open
>
> The patch v2 is ready to be merged; all is addressed from my eyes.
> But I have not have commit access so I cannot push and close this
> submission. :-)
>
> Cheers,
> simon
>
Simon Tournier Jan. 12, 2023, 10:26 a.m. UTC | #5
Re,

On Thu, 12 Jan 2023 at 11:08, Andy Tai <atai@atai.org> wrote:
>
> Thanks... I cannot tell who has the commit access... I assume you do as you review patches :-)

These people: <https://savannah.gnu.org/project/memberlist.php?group=guix>.

Review is a collective task and comment patches for improving their
quality is not reserved to people with commit access. :-)  The number
of people with commit access is limited and so if a first pass of
review is done then it eases and saves them some time. :-)

Cheers,
simon
diff mbox series

Patch

From 65a07b13cb90101c5fbfefc508da4ec41623684d Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Wed, 11 Jan 2023 02:40:26 +0000
Subject: [PATCH] gnu: Add xnedit

* gnu/packages/text-editors.scm (xnedit): New variable
---
 gnu/packages/text-editors.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 9dd5d7793f..1eea322f1c 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -21,6 +21,7 @@ 
 ;;; Copyright © 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
 ;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Andy Tai <atai@atai.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -75,6 +76,7 @@  (define-module (gnu packages text-editors)
   #:use-module (gnu packages hunspell)
   #:use-module (gnu packages icu4c)
   #:use-module (gnu packages image)
+  #:use-module (gnu packages lesstif)
   #:use-module (gnu packages libbsd)
   #:use-module (gnu packages llvm)
   #:use-module (gnu packages lua)
@@ -1391,3 +1393,34 @@  (define-public lite-xl
 The aim of Lite XL compared to lite is to be more user-friendly, improve the
 quality of font rendering, and reduce CPU usage.")
     (license license:expat)))
+    
+(define-public xnedit
+  (package
+    (name "xnedit")
+    (version "1.4.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/xnedit/" name "-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "0fw3li7hr47hckm9pl1njx30lfr6cx2p094ir8zmgr91hyxidgld"))))
+
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+                          (string-append "CC=" ,(cc-for-target)))
+       #:tests? #f ;no tests
+       #:phases (modify-phases %standard-phases
+                  (delete 'configure)
+                  (replace 'build
+                    (lambda* (#:key make-flags #:allow-other-keys)
+                      (apply invoke "make" "linux" make-flags))))))
+    (inputs (list motif pcre))
+    (native-inputs (list pkg-config))
+    (home-page "https://sourceforge.net/projects/xnedit/")
+    (synopsis "Fast and classic X11 text editor")
+    (description
+     "XNEdit is a fast and classic X11 text editor, based on NEdit,
+with full unicode support and antialiased text rendering.")
+    (license license:gpl2+)))
-- 
2.34.1