Message ID | 20220313223533.9632-1-kevinboulain@gmail.com |
---|---|
State | New |
Headers | show |
Series | [bug#54379] gnu: linux: update PipeWire & WirePlumber | expand |
Context | Check | Description |
---|---|---|
cbaines/comparison | success | View comparision |
cbaines/git branch | success | View Git branch |
cbaines/applying patch | success | View Laminar job |
cbaines/issue | success | View issue |
Same as v3 but uses PREFIX instead of DESTDIR for libfreeaptx.
Hi Brendan and Kevin,
'Brendan Tildesley <mail@brendan.scot> writes:
> Same as v3 but uses PREFIX instead of DESTDIR for libfreeaptx.
This patch totally flew under my radar before, but now that I wanted to
add aptX support I finally found it (after writing the libfreeaptx
definition myself first :p).
Looks good overall, I'm using it without any issues, but I have a couple
of very small nitpicks:
* First of all, patch 1 doesn't cleanly apply on master anymore (which
is normal). To make it easier for maintainers to merge your patches,
you should specify base-commit in your patches using the --base
option, so that they know what patch this was supposed to cleanly
apply on;
* in patch 5, you apparently left an entry in the commit message about
the `/etc` change, even though you separated it into its own commit;
* while we're at it, there's a small typo in patch 1's commit message,
`theinput` -> `the input`;
* if you're inheriting patches from someone else, you should consider
either leaving them as the primary author if you're keeping their
changes as-is, or putting them in the commit message as
Co-authored-by:. It's not really an issue here I think, but something
to remember.
Best,
Hi again both of you, To avoid letting this patch rot in the MLs for too long, I can pick it up, rebase it and fix up the commit messages, unless you plan to work further on it. I can also update the programs to latest while I'm at it. Unless there are objections, I'll try doing that in the upcoming week(s). Best,
Hi, Josselin Poiret <dev@jpoiret.xyz> writes: > To avoid letting this patch rot in the MLs for too long, I can pick it > up, rebase it and fix up the commit messages, unless you plan to work > further on it. I can also update the programs to latest while I'm at > it. I've done the above, here's an updated and cleaned patchset. Best,
Hello,
> I've done the above, here's an updated and cleaned patchset.
I just pushed the latest patchset.
Thanks everyone,
Mathieu
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm index d7ebf54c18..1d1429cdbd 100644 --- a/gnu/packages/linux.scm +++ b/gnu/packages/linux.scm @@ -8280,7 +8280,7 @@ (define-public pipewire-0.3 (package (inherit pipewire) (name "pipewire") - (version "0.3.43") + (version "0.3.48") (source (origin (method git-fetch) (uri (git-reference @@ -8289,7 +8289,7 @@ (define-public pipewire-0.3 (file-name (git-file-name name version)) (sha256 (base32 - "0gp2h0sidapcqmnifl0iipdmbzb18bdh8zdi7pfywr9gsksh0cxy")))) + "0abi8z7rfzspsiydc5j5l0x3dqizs5hf726xq30n32jqkwq3y2gs")))) (arguments '(#:configure-flags (list (string-append "-Dudevrulesdir=" (assoc-ref %outputs "out") @@ -8305,6 +8305,8 @@ (define-public pipewire-0.3 bluez jack-2 ldacbt + libfdk + libsndfile pulseaudio vulkan-loader vulkan-headers))))) @@ -8312,7 +8314,7 @@ (define-public pipewire-0.3 (define-public wireplumber (package (name "wireplumber") - (version "0.4.6") + (version "0.4.8") (source (origin (method git-fetch) @@ -8322,7 +8324,7 @@ (define-public wireplumber (commit version))) (file-name (git-file-name name version)) (sha256 - (base32 "0g7xkgkjlxrhs49hqkwrjk2hb478gq55wwydafvvbsv78vsa7qfb")))) + (base32 "1xhbymfml6k6l1iqgfbibgbai3j2mb9fkiyvcmk1w7nap21f01y7")))) (build-system meson-build-system) (arguments `(#:configure-flags '("-Dsystemd=disabled"