diff mbox series

[bug#59093] gnu: Add xnedit

Message ID CAJsg1E9or6WBS-BnwBV_PEqOOpyniZeLVFfuhGoB9V5fa9paKg@mail.gmail.com
State New
Headers show
Series [bug#59093] gnu: Add xnedit | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Andy Tai Nov. 7, 2022, 5:12 a.m. UTC

Comments

Simon Tournier Jan. 6, 2023, 11:50 a.m. UTC | #1
Hi,

On Sun, 06 Nov 2022 at 21:12, Andy Tai <atai@atai.org> wrote:

> +      (arguments
> +       `(#:make-flags (list (string-append "PREFIX="
> +                                         (assoc-ref %outputs "out"))
                                                      --^
                                                   this

This pattern is now deprecated, if I understand correctly.

    https://guix.gnu.org/en/blog/2021/the-big-change/

Instead, something like,

      (arguments
       (list
       #:make-flags #~(list (string-append "PREFIX=" #$output)
                            (string-append "CC=" #$(cc-for-target)))
         #:tests? #f                  ; no tests
         #:phases #~(modify-phases %standard-phases
                        (delete 'configure)
                        (replace 'build
                            (lambda* (#:key make-flags #:allow-other-keys)
                                (apply invoke "make" "linux" make-flags)))))))

seems more compliant with the “new” style.



> +      (inputs (list
> +              motif
> +              pcre))

Incorrect indentation or just (inputs (list motif pcre))


Cheers,
simon
Andy Tai Jan. 7, 2023, 7:14 a.m. UTC | #2
Hi, I guess I will need to update the patch to fit the new style.

On Fri, Jan 6, 2023 at 4:15 PM zimoun <zimon.toutoune@gmail.com> wrote:

> Hi,
>
> On Sun, 06 Nov 2022 at 21:12, Andy Tai <atai@atai.org> wrote:
>
> > +      (arguments
> > +       `(#:make-flags (list (string-append "PREFIX="
> > +                                         (assoc-ref %outputs "out"))
>                                                       --^
>                                                    this
>
> This pattern is now deprecated, if I understand correctly.
>
>     https://guix.gnu.org/en/blog/2021/the-big-change/
>
> Instead, something like,
>
>       (arguments
>        (list
>        #:make-flags #~(list (string-append "PREFIX=" #$output)
>                             (string-append "CC=" #$(cc-for-target)))
>          #:tests? #f                  ; no tests
>          #:phases #~(modify-phases %standard-phases
>                         (delete 'configure)
>                         (replace 'build
>                             (lambda* (#:key make-flags #:allow-other-keys)
>                                 (apply invoke "make" "linux"
> make-flags)))))))
>
> seems more compliant with the “new” style.
>
>
>
> > +      (inputs (list
> > +              motif
> > +              pcre))
>
> Incorrect indentation or just (inputs (list motif pcre))
>
>
> Cheers,
> simon
>
diff mbox series

Patch

From 31c34b0ebdaf6712213646b993b53a47416b9282 Mon Sep 17 00:00:00 2001
From: Andy Tai <atai@atai.org>
Date: Sun, 6 Nov 2022 21:09:28 -0800
Subject: [PATCH] gnu: Add xnedit

* gnu/packages/text-editors.scm (xnedit): New variable
---
 gnu/packages/text-editors.scm | 36 +++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index a16ce8a117..40a2106e6b 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -21,6 +21,7 @@ 
 ;;; Copyright © 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
 ;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Andy Tai <atai@atai.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -72,6 +73,7 @@  (define-module (gnu packages text-editors)
   #:use-module (gnu packages haskell-xyz)
   #:use-module (gnu packages icu4c)
   #:use-module (gnu packages image)
+  #:use-module (gnu packages lesstif)
   #:use-module (gnu packages libbsd)
   #:use-module (gnu packages libreoffice)
   #:use-module (gnu packages llvm)
@@ -1355,3 +1357,37 @@  (define-public lite-xl
 The aim of Lite XL compared to lite is to be more user-friendly, improve the
 quality of font rendering, and reduce CPU usage.")
     (license license:expat)))
+
+(define-public xnedit
+  (package
+      (name "xnedit")
+      (version "1.4.1")
+      (source
+       (origin
+         (method url-fetch)
+           (uri (string-append "mirror://sourceforge/xnedit/"
+                               name "-" version ".tar.gz"))
+           (sha256
+            (base32 "0fw3li7hr47hckm9pl1njx30lfr6cx2p094ir8zmgr91hyxidgld"))))
+
+      (build-system gnu-build-system)
+      (arguments
+       `(#:make-flags (list (string-append "PREFIX="
+                                         (assoc-ref %outputs "out"))
+                            (string-append "CC="
+                                         ,(cc-for-target)))
+         #:tests? #f                  ; no tests
+         #:phases (modify-phases %standard-phases
+                        (delete 'configure)
+                        (replace 'build
+                            (lambda* (#:key make-flags #:allow-other-keys)
+                                (apply invoke "make" "linux" make-flags))))))
+      (inputs (list
+              motif
+              pcre))
+      (native-inputs (list pkg-config))
+      (home-page "https://sourceforge.net/projects/xnedit/")
+      (synopsis  "Fast and classic X11 text editor")
+      (description "XNEdit is a fast and classic X11 text editor, based on NEdit,
+with full unicode support and antialiased text rendering.")
+      (license license:gpl2+)))
-- 
2.38.0