diff mbox series

[bug#59417] gnu: Add emacs-on.

Message ID 20221120183931.14423-1-jgart@dismail.de
State New
Headers show
Series [bug#59417] gnu: Add emacs-on. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

jgart Nov. 20, 2022, 6:39 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-on): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Christopher Baines Nov. 21, 2022, 2:40 p.m. UTC | #1
jgart via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-on): New variable.
> ---
>  gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
>  1 file changed, 22 insertions(+)

Thanks, I've pushed this to master as
f0cc7542f535cd0ccb75352cabc465a8dc1b1551.

Note that I did move the package definition to not be so close to the
bottom of the module. Thanks for following the comment and not putting
it right at the bottom, but the other important bit is "place them above
by existing packages with similar functionality or similar names".

The intent with that is to avoid Git conflicts when several packages are
added in the same place. For example, you also sent this patch
https://issues.guix.gnu.org/59429 that adds emacs-ukrainian-holidays in
the same place. That's just asking for Git trouble!

I normally just search for the start of the package name, e.g. emacs-o
and then find a similarly named package to place the new one by,
e.g. emacs-on-screen in this case.

Chris
jgart Nov. 27, 2022, 6:23 p.m. UTC | #2
On Mon, 21 Nov 2022 14:40:58 +0000 Christopher Baines <mail@cbaines.net> wrote:
> Thanks, I've pushed this to master as
> f0cc7542f535cd0ccb75352cabc465a8dc1b1551.

Thanks!

> Note that I did move the package definition to not be so close to the
> bottom of the module. Thanks for following the comment and not putting
> it right at the bottom, but the other important bit is "place them above
> by existing packages with similar functionality or similar names".
> 
> The intent with that is to avoid Git conflicts when several packages are
> added in the same place. For example, you also sent this patch
> https://issues.guix.gnu.org/59429 that adds emacs-ukrainian-holidays in
> the same place. That's just asking for Git trouble!

Sorry about that! I'll keep it in mind for future patch sets. I think I'll
just start putting stuff in alphabetical order to avoid this altogether.

all best,

jgart
\( Nov. 27, 2022, 6:26 p.m. UTC | #3
On Sun Nov 27, 2022 at 6:23 PM GMT, jgart via Guix-patches via wrote:
> Sorry about that! I'll keep it in mind for future patch sets. I think I'll
> just start putting stuff in alphabetical order to avoid this altogether.

It doesn't mean alphabetical order by "similar names", so I'm pretty sure that
would still be an incorrect ordering.

    -- (
jgart Nov. 27, 2022, 6:32 p.m. UTC | #4
On Sun, 27 Nov 2022 18:26:10 +0000 "(" <paren@disroot.org> wrote:
> On Sun Nov 27, 2022 at 6:23 PM GMT, jgart via Guix-patches via wrote:
> > Sorry about that! I'll keep it in mind for future patch sets. I think I'll
> > just start putting stuff in alphabetical order to avoid this altogether.
> 
> It doesn't mean alphabetical order by "similar names", so I'm pretty sure that
> would still be an incorrect ordering.

I was thinking strict alphabetical ordering of packages like crates-io.scm

But I realize now that a given module that is not crates-io.scm might
have packages in random order...
\( Nov. 27, 2022, 6:51 p.m. UTC | #5
On Sun Nov 27, 2022 at 6:32 PM GMT, jgart wrote:
> On Sun, 27 Nov 2022 18:26:10 +0000 "(" <paren@disroot.org> wrote:
> I was thinking strict alphabetical ordering of packages like crates-io.scm
>
> But I realize now that a given module that is not crates-io.scm might
> have packages in random order...

Yup, it's only the crates-*.scm files that should be alphabetically ordered, I think.

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5c1138e954..232a547fb0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -33845,6 +33845,28 @@  (define-public emacs-mpv
 process via its IPC interface.")
       (license license:gpl3+))))
 
+(define-public emacs-on
+  (let ((commit "83baed07a105c135190d49d7ec77f95e8f38fa54")
+        (revision "0"))
+    (package
+      (name "emacs-on")
+      (version (git-version "0.1.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/ajgrf/on.el")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "14ly3w89hf4jgd8wacirxgd8vrgj7vc0hpfn911w5wa4k2a6nzpp"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/ajgrf/on.el")
+      (synopsis "Hooks for faster Emacs startup")
+      (description
+"This package exposes a number of utility hooks and functions ported from Doom Emacs.")
+      (license license:expat))))
+
 (define-public emacs-waveform
   ;; XXX: Upstream provides no Version keyword.  Using 0 as base version.
   (let ((commit "ee52c6a72b3e9890743e3a6e2fc1f3195f5687b2")