diff mbox series

[bug#59323] gnu: Add alfa

Message ID 20221116225035.12435-1-sharlatanus@gmail.com
State New
Headers show
Series [bug#59323] gnu: Add alfa | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Sharlatan Hellseher Nov. 16, 2022, 10:50 p.m. UTC
* gnu/packages/astronomy.scm (alfa): New variable.
---
 gnu/packages/astronomy.scm | 53 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 53 insertions(+)

Comments

Sharlatan Hellseher Nov. 26, 2022, 8:22 p.m. UTC | #1
Hi,

I see the QA is marked as failed but build statuses passed for 4/6 architectures
Is there anything I need to  fix in the package?

Regards,
Oleg


-- 
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
\( Nov. 26, 2022, 8:29 p.m. UTC | #2
On Sat Nov 26, 2022 at 8:22 PM GMT, Sharlatan Hellseher wrote:
> I see the QA is marked as failed but build statuses passed for 4/6 architectures
> Is there anything I need to  fix in the package?

If it's not *supposed* to build on those architectures, you can add a
``supported-systems'' field to the package, which will block the builds
for those archs on the CI, I think.

    -- (
Ludovic Courtès Dec. 1, 2022, 9:21 p.m. UTC | #3
Hi,

Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

> * gnu/packages/astronomy.scm (alfa): New variable.

I passed it through ‘guix style’ and changed the license to ‘gpl3’
because source headers specify “v3”, without the “or any later version”
wording.

According to <https://qa.guix.gnu.org/issue/59323> it’s failing on
aarch64-linux and succeeds everywhere else; could you investigate why as
the next step and report it upstream?

Applied, thanks!

Ludo’.
Ludovic Courtès Dec. 1, 2022, 9:27 p.m. UTC | #4
BTW, you might want to consider officially adding an “astronomy” team in
etc/teams.scm.in, with you as its first honorable member.  WDYT?

Ludo’.
Sharlatan Hellseher Dec. 1, 2022, 11:37 p.m. UTC | #5
Hi Ludo,

It's a great proposal :)!

I try my best too promote Guix in astronomy software communities by
mentioning in
issues, but I'm not an Astronomer or related to any research...

SunPy project will mention Guix in next documentation update
https://github.com/sunpy/sunpy/issues/6634

My aim to migrate Debian Astro package stack to Guix and start packaging
journey for Julia packages as Julia become very popular in big data researches.

Regards,
Oleg

On Thu, 1 Dec 2022 at 21:27, Ludovic Courtès <ludo@gnu.org> wrote:
>
> BTW, you might want to consider officially adding an “astronomy” team in
> etc/teams.scm.in, with you as its first honorable member.  WDYT?
>
> Ludo’.



-- 

… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Ludovic Courtès Dec. 2, 2022, 2:05 p.m. UTC | #6
Hi,

Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

> It's a great proposal :)!
>
> I try my best too promote Guix in astronomy software communities by
> mentioning in
> issues, but I'm not an Astronomer or related to any research...

Note that being on a team means you’re knowledgeable about packages that
fall in the team’s scope, that you’re interested in contributing to
their maintenance, and that you’re willing to help other contributors in
this area.  You don’t have to be a professional astronomer to do that.  :-)

> SunPy project will mention Guix in next documentation update
> https://github.com/sunpy/sunpy/issues/6634
>
> My aim to migrate Debian Astro package stack to Guix and start packaging
> journey for Julia packages as Julia become very popular in big data researches.

Nice!

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index bc31a12594..c5f0944219 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -86,6 +86,59 @@  (define-module (gnu packages astronomy)
   #:use-module (ice-9 match)
   #:use-module (srfi srfi-1))
 
+(define-public alfa
+  (package
+    (name "alfa")
+    (version "2.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/rwesson/ALFA")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "0aqxqar36822mh373awsl79j7zn8vik4yddyydsxv0c76gn4i2k3"))
+       (file-name (git-file-name name version))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:parallel-build? #f
+      #:make-flags
+      #~(list (string-append "PREFIX=" #$output)
+              (string-append "VERSION=" #$version))
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure)
+          (delete 'check)
+          (add-after 'install 'post-install-check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (invoke "make" "fittest")))))))
+    (inputs (list cfitsio gfortran))
+    (home-page "https://nebulousresearch.org/codes/alfa/")
+    (synopsis "Automated Line Fitting Algorithm")
+    (description
+     "This package provides @acronym{ALFA, Automatic line fitting algorithm}
+which can identify and fit hundreds of lines in emission line spectra in just a
+few seconds with following features:
+@itemize
+
+@item A population of synthetic spectra is generated using a reference line
+catalogue.
+
+@item The goodness of fit for each synthetic spectrum is calculated.  The best
+sets of parameters are retained and the rest discarded.
+
+@item A new population of synthetic spectra is obtained by averaging pairs of
+the best performers.
+
+@item A small fraction of the parameters of the lines in the new generation are
+randomly altered.
+
+@item The process repeats until a good fit is obtained.
+@end itemize")
+    (license license:gpl3+)))
+
 (define-public aocommon
   (let ((commit "7329a075271edab8f6264db649e81e62b2b6ae5e")
         (revision "1"))