diff mbox series

[bug#59536] gnu: Add kvantum.

Message ID 2a24602de5005d98057016dcf28ca07f676952f7.1669270666.git.yasht@mailbox.org
State New
Headers show
Series [bug#59536] gnu: Add kvantum. | expand

Commit Message

Yash Tiwari Nov. 24, 2022, 6:17 a.m. UTC
* gnu/packages/qt.scm (kvantum): New variable.
---
 gnu/packages/qt.scm | 40 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)


base-commit: 22d44f87763f86a05e9679d9ad2c99e17f4c79be

Comments

Christopher Baines Nov. 25, 2022, 10:39 a.m. UTC | #1
Yash Tiwari via Guix-patches via <guix-patches@gnu.org> writes:

> +    (arguments
> +     (list #:tests? #f

How come the tests are disabled?

Thanks,

Chris
Yash Tiwari Nov. 25, 2022, 1:48 p.m. UTC | #2
With tests enabled, the build generates the same error as qt5ct i.e. "make: *** No rule to make target 'test'. Stop." From what I understand, there are no tests in the kvantum src.


On November 25, 2022 4:09:37 PM GMT+05:30, Christopher Baines <mail@cbaines.net> wrote:
>
>Yash Tiwari via Guix-patches via <guix-patches@gnu.org> writes:
>
>> +    (arguments
>> +     (list #:tests? #f
>
>How come the tests are disabled?
>
>Thanks,
>
>Chris
宋文武 Jan. 30, 2023, 3:23 a.m. UTC | #3
Yash Tiwari <yasht@mailbox.org> writes:

> * gnu/packages/qt.scm (kvantum): New variable.

Hello, I have applied this patch with version update to 1.0.7, and
license to GPL3+ since the sources have "any later version" in it.

Close now, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 30bf429897..bc380c68ba 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -26,6 +26,7 @@ 
 ;;; Copyright © 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
 ;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
 ;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2022 Yash Tiwari <yasht@mailbox.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -185,6 +186,45 @@  (define-public qt5ct
     (home-page "https://qt5ct.sourceforge.io/")
     (license license:bsd-2)))
 
+(define-public kvantum
+  (package
+    (name "kvantum")
+    (version "1.0.6")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/tsujan/Kvantum/releases/download/V"
+                    version "/Kvantum-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1vmnb6hxy6nwjjm2asrq9av7rbrrs2rllzq7iwmsm9nidy7i7qxg"))))
+    (build-system qt-build-system)
+    (arguments
+     (list #:tests? #f
+           #:phases #~(modify-phases %standard-phases
+                        (add-after 'unpack 'chdir
+                          (lambda _
+                            (chdir "Kvantum") #t))
+                        (add-after 'chdir 'patch-style-dir
+                          (lambda _
+                            (substitute* "style/CMakeLists.txt"
+                              (("\\$\\{KVANTUM_STYLE_DIR\\}")
+                               (string-append #$output
+                                              "/lib/qt5/plugins/styles"))))))))
+    (native-inputs (list qttools-5))
+    (inputs (list libx11
+                  libxext
+                  qtbase-5
+                  qtsvg-5
+                  qtx11extras
+                  kwindowsystem))
+    (synopsis "SVG-based theme engine for Qt")
+    (description
+     "Kvantum is an SVG-based theme engine for Qt,
+tuned to KDE and LXQt, with an emphasis on elegance, usability and practicality.")
+    (home-page "https://github.com/tsujan/Kvantum")
+    (license license:gpl3)))
+
 (define-public materialdecoration
   (let ((commit "6a5de23f2e5162fbee39d16f938473ff970a2ec0")
         (revision "9"))