diff mbox series

[bug#59563] gnu: Add cl-file-notify.

Message ID 20221125072947.144356-1-paul@apatience.com
State New
Headers show
Series [bug#59563] gnu: Add cl-file-notify. | expand

Commit Message

Paul A. Patience Nov. 25, 2022, 7:29 a.m. UTC
* gnu/packages/lisp-xyz.scm (sbcl-file-notify, cl-file-notify,
ecl-file-notify): New variables.
---
 gnu/packages/lisp-xyz.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

--
2.38.0

Comments

Guillaume Le Vaillant Nov. 25, 2022, 9:36 a.m. UTC | #1
Patch pushed as 13eafd67301b37b6490d666c4f78d6c26337c052.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 2a0822380c..0416fc61ea 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -489,6 +489,39 @@  (define-public cl-inotify
 (define-public ecl-cl-inotify
   (sbcl-package->ecl-package sbcl-cl-inotify))

+(define-public sbcl-file-notify
+  (let ((commit "f12dc2f2aae5fee13355cd93a8cae0c4c412b76d")
+        (revision "0"))
+    (package
+      (name "sbcl-file-notify")
+      (version (git-version "1.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/Shinmera/file-notify")
+               (commit commit)))
+         (file-name (git-file-name "cl-file-notify" version))
+         (sha256
+          (base32 "0788d98rqm1krl8nbfh8qshvyf6g336i9bqrdhkx06cfvbh0wcny"))))
+      (build-system asdf-build-system/sbcl)
+      (inputs
+       (list sbcl-cffi
+             sbcl-documentation-utils
+             sbcl-trivial-features))
+      (home-page "https://github.com/Shinmera/file-notify")
+      (synopsis "Get notifications for file accesses and changes")
+      (description
+       "File-Notify is a Common Lisp library for getting notifications for file
+accesses and changes.")
+      (license license:zlib))))
+
+(define-public cl-file-notify
+  (sbcl-package->cl-source-package sbcl-file-notify))
+
+(define-public ecl-file-notify
+  (sbcl-package->ecl-package sbcl-file-notify))
+
 (define-public sbcl-bodge-queue
   (let ((commit "948c9a501dcd412689952d09eb7453ec2722336a")
         (revision "0"))