diff mbox series

[bug#59523] doc: contributing: Note '-v REVISION' bug in 'git send-email'.

Message ID 20221123190710.26517-1-paren@disroot.org
State New
Headers show
Series [bug#59523] doc: contributing: Note '-v REVISION' bug in 'git send-email'. | expand

Commit Message

\( Nov. 23, 2022, 7:07 p.m. UTC
* doc/contributing.texi ("Submitting Patches")["Sending a Patch Series"]:
Note that a bug in 'git send-email' means '-v REVISION' (with a
space) will not work.
---
Heya Guix,

Turns out that due to a bug in ``git send-email'', using ``-v 2'' with
a space between the flag and the argument won't work. If you try it, it'll
print a confusing error message, so this patch updates the manual to note
this and remove the space in an example that uses it.

  -- (

 doc/contributing.texi | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)


base-commit: d33ed58169edc027cfb6c256ecabde87e59918ed

Comments

Tobias Geerinckx-Rice Nov. 23, 2022, 7:30 p.m. UTC | #1
"( via Guix-patches" via 写道:
> Turns out that due to a bug in ``git send-email'', using ``-v 
> 2''

Has this been reported upstream?

Kind regards,

T G-R
Simon Tournier Nov. 23, 2022, 8:47 p.m. UTC | #2
Hi,

On Wed, 23 Nov 2022 at 19:07, "\( via Guix-patches" via <guix-patches@gnu.org> wrote:

> Turns out that due to a bug in ``git send-email'', using ``-v 2'' with
> a space between the flag and the argument won't work. If you try it, it'll
> print a confusing error message, so this patch updates the manual to note
> this and remove the space in an example that uses it.

Arf clunky Git CLI. :-)  The git-format-patch manual says:

       -v <n>, --reroll-count=<n>

so the space is allowed and it seems to work.  The git-send-email
manual says,

       git send-email [<options>] <format-patch options>

and indeed,

--8<---------------cut here---------------start------------->8---
$ git send-email -1 -v 2 --to=trash@trash.com
fatal: ambiguous argument '2': unknown revision or path not in the working tree.
Use '--' to separate paths from revisions, like this:
'git <command> [<revision>...] -- [<file>...]'
format-patch -o /tmp/bin67IOTaX -1 2: command returned error: 128
--8<---------------cut here---------------end--------------->8---

But it works without the space.  Arf, Git CLI…


Cheers,
simon
\( Nov. 23, 2022, 10:31 p.m. UTC | #3
On Wed Nov 23, 2022 at 7:30 PM GMT, Tobias Geerinckx-Rice wrote:
> Has this been reported upstream?

Not afaik. The person who originally noticed this said they had
considered reporting it but it looked like a pain to report. I'll
have a look myself in a moment.

    -- (
Kyle Meyer Nov. 24, 2022, 2:04 a.m. UTC | #4
"\( via Guix-patches" via writes:

> On Wed Nov 23, 2022 at 7:30 PM GMT, Tobias Geerinckx-Rice wrote:
>> Has this been reported upstream?
>
> Not afaik. The person who originally noticed this said they had
> considered reporting it but it looked like a pain to report. I'll
> have a look myself in a moment.

I've just sent a patch:

  https://lore.kernel.org/git/20221124020056.242185-1-kyle@kyleam.com
Kyle Meyer March 13, 2023, 11:43 p.m. UTC | #5
Kyle Meyer writes:

> I've just sent a patch:
>
>   https://lore.kernel.org/git/20221124020056.242185-1-kyle@kyleam.com

Just to close the loop here: that landed in Git v2.40.0.
Maxim Cournoyer March 21, 2023, 12:34 p.m. UTC | #6
Hi,

Kyle Meyer <kyle@kyleam.com> writes:

> Kyle Meyer writes:
>
>> I've just sent a patch:
>>
>>   https://lore.kernel.org/git/20221124020056.242185-1-kyle@kyleam.com
>
> Just to close the loop here: that landed in Git v2.40.0.

Awesome.  We're now at 2.39, so it seems we can just wait a bit to get
2.40 and then close this issue.
diff mbox series

Patch

diff --git a/doc/contributing.texi b/doc/contributing.texi
index 40ae33ecac..913c7cf436 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -1462,10 +1462,16 @@  address and the @option{-v} flag with @command{git send-email}.
 
 @example
 $ git commit -a
-$ git send-email -1 -a --base=auto -v @var{REVISION} \
+$ git send-email -1 -a --base=auto -v@var{REVISION} \
       --to=@var{ISSUE_NUMBER}@@debbugs.gnu.org
 @end example
 
+@quotation Note
+Due to an apparent bug in @command{git send-email},
+@option{-v @var{REVISION}} (with the space) will not work; you
+@emph{must} use @option{-v@var{REVISION}}.
+@end quotation
+
 You can find out @var{ISSUE_NUMBER} either by searching on the mumi
 interface at @url{issues.guix.gnu.org} for the name of your patch or
 reading the acknowledgement email sent automatically by Debbugs in