diff mbox series

[bug#59342,2/3] gnu: lldb: Update to 15.0.5.

Message ID f9add8538ba8507141ab5861f9f266439a5f1cfc.1668714905.git.code@greghogan.com
State New
Headers show
Series Update lldb. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Greg Hogan Nov. 17, 2022, 8:06 p.m. UTC
* gnu/packages/llvm.scm (lldb): Update to 15.0.5.
[version]: Use version from LLVM-15.
[inputs]: Change from LLVM-14 and CLANG-14 to LLVM-15 and CLANG-15.
---
 gnu/packages/llvm.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Christopher Baines Nov. 19, 2022, 1:34 p.m. UTC | #1
Greg Hogan <code@greghogan.com> writes:

> * gnu/packages/llvm.scm (lldb): Update to 15.0.5.
> [version]: Use version from LLVM-15.
> [inputs]: Change from LLVM-14 and CLANG-14 to LLVM-15 and CLANG-15.
> ---
>  gnu/packages/llvm.scm | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
> index 020c9bb302..d9bbe9c078 100644
> --- a/gnu/packages/llvm.scm
> +++ b/gnu/packages/llvm.scm
> @@ -1631,7 +1631,7 @@ (define-public lld-as-ld-wrapper
>  (define-public lldb
>    (package
>      (name "lldb")
> -    (version "14.0.6")
> +    (version (package-version llvm-15))

Hi Greg, thanks for the patches.

Looking at https://qa.guix.gnu.org/issue/59342 it seems that this
updated lldb@15.0.5 fails to build.

Do you see the same failure locally?

Thanks,

Chris
Greg Hogan Nov. 21, 2022, 2:35 p.m. UTC | #2
On Sat, Nov 19, 2022 at 8:35 AM Christopher Baines <mail@cbaines.net> wrote:
>
> Greg Hogan <code@greghogan.com> writes:
>
> > * gnu/packages/llvm.scm (lldb): Update to 15.0.5.
> > [version]: Use version from LLVM-15.
> > [inputs]: Change from LLVM-14 and CLANG-14 to LLVM-15 and CLANG-15.
> > ---
> >  gnu/packages/llvm.scm | 6 +++---
> >  1 file changed, 3 insertions(+), 3 deletions(-)
> >
> > diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
> > index 020c9bb302..d9bbe9c078 100644
> > --- a/gnu/packages/llvm.scm
> > +++ b/gnu/packages/llvm.scm
> > @@ -1631,7 +1631,7 @@ (define-public lld-as-ld-wrapper
> >  (define-public lldb
> >    (package
> >      (name "lldb")
> > -    (version "14.0.6")
> > +    (version (package-version llvm-15))
>
> Hi Greg, thanks for the patches.
>
> Looking at https://qa.guix.gnu.org/issue/59342 it seems that this
> updated lldb@15.0.5 fails to build.
>
> Do you see the same failure locally?
>
> Thanks,
>
> Chris

From my three patches I build
patch 1/3: /gnu/store/zi7pyql63j15m2ap0pf1xq4nly58pw7s-lldb-14.0.6
patch 2/3: /gnu/store/chrwzab8icp9p3mswkr6glbxba89pm6s-lldb-15.0.5
patch 3/3: /gnu/store/chrwzab8icp9p3mswkr6glbxba89pm6s-lldb-15.0.5

The data service builds lldb-15.0.4 (which errors on the missing
cmake_push_check_state fixed in 15.0.5).

Following the link from the data service, revision 7ab0095a [1] is
missing the first patch from this patchset [2]. Ideas?

[1] https://git.guix-patches.cbaines.net/guix-patches/commit/?id=7ab0095ab6f958c1c5224e8cb2155672dcea44bc
[2] https://git.guix-patches.cbaines.net/guix-patches/log/?h=issue-59342

Greg Hogan
Christopher Baines Nov. 22, 2022, 9:39 a.m. UTC | #3
Greg Hogan <code@greghogan.com> writes:

> On Sat, Nov 19, 2022 at 8:35 AM Christopher Baines <mail@cbaines.net> wrote:
>>
>> Greg Hogan <code@greghogan.com> writes:
>>
>> > * gnu/packages/llvm.scm (lldb): Update to 15.0.5.
>> > [version]: Use version from LLVM-15.
>> > [inputs]: Change from LLVM-14 and CLANG-14 to LLVM-15 and CLANG-15.
>> > ---
>> >  gnu/packages/llvm.scm | 6 +++---
>> >  1 file changed, 3 insertions(+), 3 deletions(-)
>> >
>> > diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
>> > index 020c9bb302..d9bbe9c078 100644
>> > --- a/gnu/packages/llvm.scm
>> > +++ b/gnu/packages/llvm.scm
>> > @@ -1631,7 +1631,7 @@ (define-public lld-as-ld-wrapper
>> >  (define-public lldb
>> >    (package
>> >      (name "lldb")
>> > -    (version "14.0.6")
>> > +    (version (package-version llvm-15))
>>
>> Hi Greg, thanks for the patches.
>>
>> Looking at https://qa.guix.gnu.org/issue/59342 it seems that this
>> updated lldb@15.0.5 fails to build.
>>
>> Do you see the same failure locally?
>>
>> Thanks,
>>
>> Chris
>
> From my three patches I build
> patch 1/3: /gnu/store/zi7pyql63j15m2ap0pf1xq4nly58pw7s-lldb-14.0.6
> patch 2/3: /gnu/store/chrwzab8icp9p3mswkr6glbxba89pm6s-lldb-15.0.5
> patch 3/3: /gnu/store/chrwzab8icp9p3mswkr6glbxba89pm6s-lldb-15.0.5
>
> The data service builds lldb-15.0.4 (which errors on the missing
> cmake_push_check_state fixed in 15.0.5).
>
> Following the link from the data service, revision 7ab0095a [1] is
> missing the first patch from this patchset [2]. Ideas?

Thanks for looking in to this Greg, something must have gone wrong with
the applying of the patches! I deleted the branch and it's been
re-created now, with all patches present.

Now I'm not seeing any failures, so I've gone ahead and pushed this to
master as 07746c2b153dfeacf714261f330c04d42e570f3c.

Sorry for the initial confusion!

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 020c9bb302..d9bbe9c078 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -1631,7 +1631,7 @@  (define-public lld-as-ld-wrapper
 (define-public lldb
   (package
     (name "lldb")
-    (version "14.0.6")
+    (version (package-version llvm-15))
     (source (llvm-monorepo version))
     (build-system cmake-build-system)
     (arguments
@@ -1645,8 +1645,8 @@  (define-public lldb
     (native-inputs
      (list pkg-config swig))
     (inputs
-     (list clang-14
-           llvm-14
+     (list clang-15
+           llvm-15
            ;; Optional (but recommended) inputs.
            ncurses
            libedit