diff mbox series

[bug#59354] gnu: Add texlive-mathdots.

Message ID 20221121141627.27355-1-yarl-baudig@mailoo.org
State New
Headers show
Series [bug#59354] gnu: Add texlive-mathdots. | expand

Commit Message

yarl baudig Nov. 21, 2022, 2:16 p.m. UTC
* gnu/packages/tex.scm (texlive-mathdots): New variable.
---
 gnu/packages/tex.scm | 41 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)


base-commit: 1bea5d38a26755b84437623c0f48915a77899b57

Comments

Nicolas Goaziou Nov. 21, 2022, 10:21 p.m. UTC | #1
Hello,

Yarl Baudig <yarl-baudig@mailoo.org> writes:

> * gnu/packages/tex.scm (texlive-mathdots): New variable.

Perfect. Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 81f74f17df..a600bcae58 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3993,6 +3993,47 @@  (define-public texlive-amsmath
 
 (define-deprecated-package texlive-latex-amsmath texlive-amsmath)
 
+(define-public texlive-mathdots
+  (let ((template
+         (simple-texlive-package
+          "texlive-mathdots"
+          (list "doc/generic/mathdots/"
+                "source/generic/mathdots/"
+                "tex/generic/mathdots/")
+          (base32"1jaffj343p1chdxs2g7s6lpckvihk0jfw22nw0vmijyjxfiy9yg0"))))
+    (package
+      (inherit template)
+      (outputs '("out" "doc"))
+      (arguments
+       (substitute-keyword-arguments (package-arguments template)
+         ((#:tex-directory _ '())
+          "generic/mathdots")
+         ((#:build-targets _ '())
+          '(list "mathdots.ins"))
+         ((#:phases phases)
+          #~(modify-phases #$phases
+              (add-after 'unpack 'chdir
+                (lambda _
+                  (chdir "source/generic/mathdots")))
+              (replace 'copy-files
+                (lambda* (#:key inputs outputs #:allow-other-keys)
+                  (let ((origin (assoc-ref inputs "source"))
+                        (source (string-append (assoc-ref outputs "out")
+                                               "/share/texmf-dist/source"))
+                        (doc (string-append (assoc-ref outputs "doc")
+                                            "/share/texmf-dist/doc")))
+                    (copy-recursively (string-append origin "/source") source)
+                    (copy-recursively (string-append origin "/doc") doc))))))))
+      (home-page "https://ctan.org/macros/generic/mathdots")
+      (synopsis "Commands to produce dots in math that respect font size")
+      (description
+       "Mathdots redefines @code{\\ddots} and @code{\\vdots}, and defines
+@code{\\iddots}.  The dots produced by @code{\\iddots} slant in the opposite
+direction to @code{\\ddots}.  All the commands are designed to change size
+appropriately in scripts, as well as in response to LaTeX size changing
+commands.  The commands may also be used in plain TeX.")
+      (license license:lppl))))
+
 (define-public texlive-amscls
   (let ((template (simple-texlive-package
                    "texlive-amscls"