diff mbox series

[bug#59399,3/4] gnu: Add go-github-com-hebcal-hebcal-go.

Message ID 20221120134802.19051-3-felix.lechner@lease-up.com
State New
Headers show
Series [bug#59399,1/4] gnu: Add go-github-com-nathan-osman-go-sunrise. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Felix Lechner Nov. 20, 2022, 1:48 p.m. UTC
* gnu/packages/golang.scm
  (go-github-com-hebcal-hebcal-go): New variable.
---
 gnu/packages/golang.scm | 42 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)

Comments

\( Nov. 20, 2022, 2:02 p.m. UTC | #1
On Sun Nov 20, 2022 at 1:48 PM GMT, Felix Lechner wrote:
> * gnu/packages/golang.scm
>   (go-github-com-hebcal-hebcal-go): New variable.

> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -2538,6 +2538,48 @@ (define-public go-github-com-hebcal-gematriya

> +      (arguments
> +       (list
> +        #:import-path "github.com/hebcal/hebcal-go"
> +        ;; Source-only package
> +        #:tests? #f
> +        #:phases
> +        #~(modify-phases %standard-phases
> +            ;; Source-only package
> +            (delete 'build))))

Indent it like this:

  (list #:import-path "githu.com/hebcal/hebcal-go"
        #:tests? #f ;source-only package
        #:phases
        #~(modify-phases %standard-phases
            ;; Source-only package.
            (delete 'build)))

> +      (propagated-inputs
> +       (list go-github-com-hebcal-gematriya
> +             go-github-com-nathan-osman-go-sunrise
> +             go-github-com-stretchr-testify))

``go-github-com-stretchr-testify'' should probably be in native-inputs,
since it's used only in tests.

> +      (synopsis "Library module for Hebcal, a perpetual Jewish Calendar")

  (synopsis "Go library for the Hebcal perpetual Jewish calendar")

> +      (description
> +       "This library converts between Hebrew and Gregorian dates, and generates lists
> +of Jewish holidays for any year (past, present or future).  Shabbat and holiday candle
> +lighting and havdalah times are approximated based on location.
> +
> +Torah readings (Parashat HaShavua), Daf Yomi, and counting of the Omer can also be
> +specified.  Hebcal also includes algorithms to calculate yahrzeits, birthdays and
> +anniversaries.")

  (description
   "This package provides a library for conversion between Hebrew
and Georgian dates, and generation of lists of Jewish holidays for
a given year.  Shabbat and holiday candle lighting and havdalah times
are approximated based on location.

Torah readings, Daf Yomi, and counting of the Omer can also be
specified.  Algorithms are included to calculate yahrzeits, birthdays,
and anniversaries.")

    -- (
\( Nov. 20, 2022, 2:04 p.m. UTC | #2
On Sun Nov 20, 2022 at 2:02 PM GMT, ( via Guix-patches via wrote:
>   (description
>    "This package provides a library for conversion between Hebrew
> and Georgian dates, and generation of lists of Jewish holidays for
> a given year.  Shabbat and holiday candle lighting and havdalah times
> are approximated based on location.
>
> Torah readings, Daf Yomi, and counting of the Omer can also be
> specified.  Algorithms are included to calculate yahrzeits, birthdays,
> and anniversaries.")

s/Georgian/Gregorian/ (I misread that in the original description :))

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4e0f62906a..1d5493ad40 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2538,6 +2538,48 @@  (define-public go-github-com-hebcal-gematriya
 letters of the Hebrew alef-bet (alphabet).")
       (license license:bsd-2))))
 
+(define-public go-github-com-hebcal-hebcal-go
+  (let ((commit "d42e881860cfc9e8249fc79f268091c3c4d36b0d")
+        (revision "0"))
+    (package
+      (name "go-github-com-hebcal-hebcal-go")
+      (version (git-version "0.9.11" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/hebcal/hebcal-go")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1m9akb8pwxchpaci05gambshrzw626gsrfhl25f36vjl7mq5292n"))))
+      (build-system go-build-system)
+      (arguments
+       (list
+        #:import-path "github.com/hebcal/hebcal-go"
+        ;; Source-only package
+        #:tests? #f
+        #:phases
+        #~(modify-phases %standard-phases
+            ;; Source-only package
+            (delete 'build))))
+      (propagated-inputs
+       (list go-github-com-hebcal-gematriya
+             go-github-com-nathan-osman-go-sunrise
+             go-github-com-stretchr-testify))
+      (home-page "https://github.com/hebcal/hebcal-go")
+      (synopsis "Library module for Hebcal, a perpetual Jewish Calendar")
+      (description
+       "This library converts between Hebrew and Gregorian dates, and generates lists
+of Jewish holidays for any year (past, present or future).  Shabbat and holiday candle
+lighting and havdalah times are approximated based on location.
+
+Torah readings (Parashat HaShavua), Daf Yomi, and counting of the Omer can also be
+specified.  Hebcal also includes algorithms to calculate yahrzeits, birthdays and
+anniversaries.")
+      (license license:gpl2+))))
+
 (define-public go-github-com-aws-sdk
   (package
     (name "go-github-com-aws-sdk")