diff mbox series

[bug#59399,2/4] gnu: Add go-github-com-hebcal-gematriya.

Message ID 20221120134802.19051-2-felix.lechner@lease-up.com
State New
Headers show
Series [bug#59399,1/4] gnu: Add go-github-com-nathan-osman-go-sunrise. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Felix Lechner Nov. 20, 2022, 1:47 p.m. UTC
* gnu/packages/golang.scm
  (go-github-com-hebcal-gematriya): New variable.
---
 gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

\( Nov. 20, 2022, 1:55 p.m. UTC | #1
Heya,

On Sun Nov 20, 2022 at 1:47 PM GMT, Felix Lechner wrote:
> * gnu/packages/golang.scm
>   (go-github-com-hebcal-gematriya): New variable.

> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm

> @@ -2512,6 +2512,32 @@ (define-public go-github-com-nathan-osman-go-sunrise

> +      (arguments
> +       '(#:import-path "github.com/hebcal/gematriya"))

  (list ...)

> +      (synopsis "Provides a system of writing numbers as Hebrew letters")

  (synopsis "Print numbers as Hebrew letters in Go")

> +      (description
> +       "Prints numbers as Hebrew letters.  Numerical values are represented using
> +letters of the Hebrew alef-bet (alphabet).")

  (description
   "This package provides a Go library for printing numbers as
Hebrew letters.")

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e697cd4af6..4e0f62906a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2512,6 +2512,32 @@  (define-public go-github-com-nathan-osman-go-sunrise
 location.")
       (license license:expat))))
 
+(define-public go-github-com-hebcal-gematriya
+  (let ((commit "fe3043f73e415eb82727701d10f2fb40f87675e9")
+        (revision "0"))
+    (package
+      (name "go-github-com-hebcal-gematriya")
+      (version (git-version "1.0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/hebcal/gematriya")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0xmnb2i80dy380yv8c4pd04bbyqgbc7c40p8hz1vqj2lhbm6jabf"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path "github.com/hebcal/gematriya"))
+      (home-page "https://github.com/hebcal/gematriya")
+      (synopsis "Provides a system of writing numbers as Hebrew letters")
+      (description
+       "Prints numbers as Hebrew letters.  Numerical values are represented using
+letters of the Hebrew alef-bet (alphabet).")
+      (license license:bsd-2))))
+
 (define-public go-github-com-aws-sdk
   (package
     (name "go-github-com-aws-sdk")