diff mbox series

[bug#59294,2/2] gnu: httpie: Use G-expressions.

Message ID 20221116020018.22337-2-kiasoc5@disroot.org
State New
Headers show
Series Update httpie to 3.2.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

kiasoc5 Nov. 16, 2022, 2 a.m. UTC
* gnu/packages/python-web.scm (httpie)[arguments]: Use G-expressions.
---
 gnu/packages/python-web.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Christopher Baines Nov. 17, 2022, 12:08 p.m. UTC | #1
kiasoc5 via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/python-web.scm (httpie)[arguments]: Use G-expressions.
> ---
>  gnu/packages/python-web.scm | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
> index 00a848610e..6d9ebd928e 100644
> --- a/gnu/packages/python-web.scm
> +++ b/gnu/packages/python-web.scm
> @@ -964,7 +964,7 @@ (define-public httpie
>      (build-system python-build-system)
>      (arguments
>       ;; The tests attempt to access external web servers, so we cannot run them.
> -     '(#:tests? #f))
> +     (list #:tests? #f))
>      (propagated-inputs
>       (list python-colorama
>             python-pygments

I skipped pushing this patch as while I think I get what you're doing,
this change doesn't involve using G-expressions. At least with my
understanding of Guile, nothing is really changing here.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 00a848610e..6d9ebd928e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -964,7 +964,7 @@  (define-public httpie
     (build-system python-build-system)
     (arguments
      ;; The tests attempt to access external web servers, so we cannot run them.
-     '(#:tests? #f))
+     (list #:tests? #f))
     (propagated-inputs
      (list python-colorama
            python-pygments