diff mbox series

[bug#59294,1/2] gnu: httpie: Update to 3.2.1.

Message ID 20221116020018.22337-1-kiasoc5@disroot.org
State New
Headers show
Series Update httpie to 3.2.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

kiasoc5 Nov. 16, 2022, 2 a.m. UTC
* gnu/packages/python-web.scm (httpie): Update to 3.2.1.
[propagated-inputs]: Add python-rich.
---
 gnu/packages/python-web.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Christopher Baines Nov. 17, 2022, 12:08 p.m. UTC | #1
kiasoc5 via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/python-web.scm (httpie): Update to 3.2.1.
> [propagated-inputs]: Add python-rich.
> ---
>  gnu/packages/python-web.scm | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)

Looks good to me, I've pushed to master as
ce4896e85dfc667959b46c29191961f8280a364b.

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f6b4faf692..00a848610e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -953,14 +953,14 @@  (define-public python-httplib2
 (define-public httpie
   (package
     (name "httpie")
-    (version "3.1.0")
+    (version "3.2.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "httpie" version))
        (sha256
         (base32
-         "1npyfvrq0l56bil8rnpj78mav378mxx4zcqzq1jjx4aap1020jif"))))
+         "1v736y2h7lcyrnxs9y5sf4xwzgll7pc2s6r3ny929mm8lcn07h69"))))
     (build-system python-build-system)
     (arguments
      ;; The tests attempt to access external web servers, so we cannot run them.
@@ -973,6 +973,7 @@  (define-public httpie
            python-pysocks
            python-charset-normalizer
            python-defusedxml
+           python-rich
            python-multidict))
     (home-page "https://httpie.io")
     (synopsis "cURL-like tool for humans")