Message ID | 20221105034438.23962-1-kiasoc5@disroot.org |
---|---|
State | New |
Headers | show |
Series | [bug#59039] gnu: Add fuzzel. | expand |
Context | Check | Description |
---|---|---|
cbaines/comparison | success | View comparision |
cbaines/git-branch | success | View Git branch |
cbaines/applying patch | success | |
cbaines/issue | success | View issue |
On 11/4/22 23:44, kiasoc5 wrote:
> This patch avoids building fuzzel with bundled nanosvg and uses librsvg instead.
It turns out some other projects by dnkl in Guix (such as fnott) do not
unbundle nanosvg.
In that case it may be better to use the bundled nanosvg for fuzzel too.
WDYT?
Hi, kiasoc5 <kiasoc5@disroot.org> skribis: > On 11/4/22 23:44, kiasoc5 wrote: >> This patch avoids building fuzzel with bundled nanosvg and uses librsvg instead. > It turns out some other projects by dnkl in Guix (such as fnott) do > not unbundle nanosvg. > > In that case it may be better to use the bundled nanosvg for fuzzel too. Unless it causes technical problems, for instance because the bundled version is patched and somewhat specific, the policy in Guix is to always unbundle. Ludo’.
Hi, kiasoc5 <kiasoc5@disroot.org> skribis: > This patch avoids building fuzzel with bundled nanosvg and uses librsvg instead. > > * gnu/packages/xdisorg.scm (fuzzel): New variable. Passed through ‘guix style’ and applied. At some point we should prolly move Wayland things to their own file; I don’t see how we ended up putting it all in xdisorg.scm. :-) Ludo’.
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm index 8e70050850..8c33b70fcb 100644 --- a/gnu/packages/xdisorg.scm +++ b/gnu/packages/xdisorg.scm @@ -2919,6 +2919,46 @@ (define-public j4-dmenu-desktop (home-page "https://github.com/enkore/j4-dmenu-desktop") (license license:gpl3+))) +(define-public fuzzel + (package + (name "fuzzel") + (version "1.8.2") + (home-page "https://codeberg.org/dnkl/fuzzel") + (source (origin + (method git-fetch) + (uri (git-reference (url home-page) (commit version))) + (file-name (git-file-name name version)) + (sha256 + (base32 + "1d6xy4q5s8p5ckvd9wy3zzj9gh7nh9v1qhn3938b1wfhfzjdzrg6")))) + (build-system meson-build-system) + (arguments + (list + #:build-type "release" + #:configure-flags + #~(list "-Denable-cairo=enabled" + "-Dpng-backend=libpng" + "-Dsvg-backend=librsvg"))) + (native-inputs + (list pkg-config scdoc tllist)) + (inputs + (list cairo + fcft + fontconfig + libpng + libxkbcommon + librsvg ;; if librsvg is not used, bundled nanosvg is used + pixman + wayland + wayland-protocols)) + (synopsis "Wayland-native application launcher") + (description + "@command{foot} is a Wayland-native application launcher, similar to +rofi's drun mode. It has Emacs key bindings and remembers frequently launched +applications. The font and colors can be configured.") + (license (list license:expat ;; fuzzel + license:zlib)))) ;; bundled nanosvg + (define-public wofi (package (name "wofi")