diff mbox series

[bug#58829,v2] gnu: mosh: Update to 1.4.0.

Message ID y76sfj6pw1k.wl-hako@ultrarare.space
State New
Headers show
Series [bug#58829,v2] gnu: mosh: Update to 1.4.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Hilton Chain Oct. 29, 2022, 2:02 p.m. UTC
* gnu/packages/ssh.scm (mosh): Update to 1.4.0.
[source]: Switch to GitHub source.
---
 gnu/packages/ssh.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)


base-commit: 7d9243432613a9574599cd41bcbefa5819e30e3f

Comments

Ludovic Courtès Nov. 14, 2022, 11:26 a.m. UTC | #1
Hi,

Hilton Chain <hako@ultrarare.space> skribis:

> * gnu/packages/ssh.scm (mosh): Update to 1.4.0.
> [source]: Switch to GitHub source.

Both patches yield a hash mismatch; this is what I get for the second
one:

--8<---------------cut here---------------start------------->8---
building /gnu/store/p4wnyqwpxfhvnarl6jd9ca3yp0dz6sx8-mosh-1.4.0.tar.gz.drv...

Starting download of /gnu/store/80q7zppywz2xbbc7hznbqp5vh0bgbbvz-mosh-1.4.0.tar.gz
From https://github.com/mobile-shell/mosh/releases/download/mosh-1.4.0/mosh-1.4.0.tar.gz...
following redirection to `https://objects.githubusercontent.com/github-production-release-asset-2e65be/1234783/ab5510da-ce1d-4a49-ba34-0eee2f83eb39?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20221114%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20221114T112245Z&X-Amz-Expires=300&X-Amz-Signature=4e8538a1e72f39d1619cea472a3d528007608b655ec356df5243e2e300302c69&X-Amz-SignedHeaders=host&actor_id=0&key_id=0&repo_id=1234783&response-content-disposition=attachment%3B%20filename%3Dmosh-1.4.0.tar.gz&response-content-type=application%2Foctet-stream'...
downloading from https://github.com/mobile-shell/mosh/releases/download/mosh-1.4.0/mosh-1.4.0.tar.gz ...
 mosh-1.4.0.tar.gz  384KiB                              7.2MiB/s 00:00 [##################] 100.0%
sha256 hash mismatch for /gnu/store/80q7zppywz2xbbc7hznbqp5vh0bgbbvz-mosh-1.4.0.tar.gz:
  expected hash: 0pxrpg74xn5cwpviwz1cwc0xni8blyw04ncd9ffga4m0n2rcjgnr
  actual hash:   1pax8sqlvcc7ammsxd9r53yx4m2hg1827wfz6f4rrwjx9q9lnbl7
hash mismatch for store item '/gnu/store/80q7zppywz2xbbc7hznbqp5vh0bgbbvz-mosh-1.4.0.tar.gz'
--8<---------------cut here---------------end--------------->8---

and for the first one:

--8<---------------cut here---------------start------------->8---
downloading from https://mosh.org/mosh-1.4.0.tar.gz ...
 mosh-1.4.0.tar.gz  384KiB                                                                           2.2MiB/s 00:00 [##################] 100.0%
sha256 hash mismatch for /gnu/store/80q7zppywz2xbbc7hznbqp5vh0bgbbvz-mosh-1.4.0.tar.gz:
  expected hash: 0pxrpg74xn5cwpviwz1cwc0xni8blyw04ncd9ffga4m0n2rcjgnr
  actual hash:   1pax8sqlvcc7ammsxd9r53yx4m2hg1827wfz6f4rrwjx9q9lnbl7
hash mismatch for store item '/gnu/store/80q7zppywz2xbbc7hznbqp5vh0bgbbvz-mosh-1.4.0.tar.gz'
--8<---------------cut here---------------end--------------->8---

So it looks like they’ve been updated in place.

Could you check what happened and submit an updated patch?

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 6a3779ee55..a7014d38b9 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -461,13 +461,15 @@  (define-public corkscrew
 (define-public mosh
   (package
     (name "mosh")
-    (version "1.3.2")
+    (version "1.4.0")
     (source (origin
               (method url-fetch)
-              (uri (string-append "https://mosh.org/mosh-" version ".tar.gz"))
+              (uri (string-append "https://github.com/mobile-shell/mosh"
+                                  "/releases/download/mosh-" version
+                                  "/mosh-" version ".tar.gz"))
               (sha256
                (base32
-                "05hjhlp6lk8yjcy59zywpf0r6s0h0b9zxq0lw66dh9x8vxrhaq6s"))))
+                "0pxrpg74xn5cwpviwz1cwc0xni8blyw04ncd9ffga4m0n2rcjgnr"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases