diff mbox series

[bug#58156] gnu: Add emacs-circadian.

Message ID 95dbafb1ebd166bb70758e94285a966e66d43caa.1664425321.git.kiasoc5@disroot.org
State New
Headers show
Series [bug#58156] gnu: Add emacs-circadian. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

kiasoc5 Sept. 29, 2022, 4:22 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-circadian): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 45eac6cdf5c8d9d7b0c564b105c790d2d2007799

Comments

Nicolas Goaziou Sept. 29, 2022, 9:48 a.m. UTC | #1
Hello,

kiasoc5 via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-circadian): New variable.

Thank you.

> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "https://stable.melpa.org/packages/circadian-"
> +                           version ".el"))

Tarballs from Stable MELPA are not considered stable (!). Could you use
GitHub as upstream?

> +       (sha256
> +        (base32
> +         "1pypy9bhg4lmmjjj0yqvlqs478i84x3awgzzjzdmrj1jlqbbvdj7"))))
> +    (build-system emacs-build-system)
> +    (home-page "https://github.com/guidoschmidt/circadian.el")
> +    (synopsis "Theme-switching for Emacs based on daytime")
> +    (description "emacs-circadian tries to help reduce eye strain that

Circadian reduces eye strain…

or

Circadian may reduce…

In any case the project is named Circadian, "emacs-circadian" being the
name of the Guix variable bound to the package.

> +may arise from the difference of the display brightness and surrounding
> +light by automatically switching between light and dark themes.  It is
> +inspired by color temperature shifting tools and brightness adaption
> +software.")
> +    (license license:expat)))

Licensing is ambiguous. The LICENSE file is expat, but the sole ".el"
file is explicitly GPL3+. So I guess this would be (list gpl3+ expat).

Could you also activate tests for this package? See for example
"emacs-go-mode" for an example. You will need to add emacs-el-mock
and emacs-ert-runner to the list of native inputs.

Could you send an updated patch?

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c5d49c2925..c8bd2e9aa0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19526,6 +19526,28 @@  (define-public emacs-ts
 timestamps by providing a @code{ts} struct.")
     (license license:gpl3+)))
 
+(define-public emacs-circadian
+  (package
+    (name "emacs-circadian")
+    (version "0.3.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://stable.melpa.org/packages/circadian-"
+                           version ".el"))
+       (sha256
+        (base32
+         "1pypy9bhg4lmmjjj0yqvlqs478i84x3awgzzjzdmrj1jlqbbvdj7"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/guidoschmidt/circadian.el")
+    (synopsis "Theme-switching for Emacs based on daytime")
+    (description "emacs-circadian tries to help reduce eye strain that
+may arise from the difference of the display brightness and surrounding
+light by automatically switching between light and dark themes.  It is
+inspired by color temperature shifting tools and brightness adaption
+software.")
+    (license license:expat)))
+
 (define-public emacs-peg
   (package
     (name "emacs-peg")