diff mbox series

[bug#57945] gnu: wpa-supplicant: enable OWE support

Message ID 20220919235956.1074718-1-andreas@rammhold.de
State Accepted
Headers show
Series [bug#57945] gnu: wpa-supplicant: enable OWE support | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Andreas Rammhold Sept. 19, 2022, 11:59 p.m. UTC
With OWE support users are enable to connect to "Opportunistic Wireless
Encryption" networks. This means users are able to have an encrypted
data channel in an otherwise open wireless network.

* gnu/packages/admin.scm (wpa-supplicant): Enable OWE support.

Signed-off-by: Andreas Rammhold <andreas@rammhold.de>
---
 gnu/packages/admin.scm | 7 +++++++
 1 file changed, 7 insertions(+)


base-commit: d845326b5cb33453a50b9c8fd8f21dfd8198a158
prerequisite-patch-id: b830a1b0573b55d8a8378338862dc5bfaac53117
prerequisite-patch-id: 59289da7b58eb3a1ea1f3b531261d0785b58dd36
prerequisite-patch-id: a761f12c1d69204330e6215a26ea110c281ea834
prerequisite-patch-id: fcc87d0b44e2c3597e9270e6d96c8f1e4beddcf6

Comments

M Sept. 22, 2022, 7:14 p.m. UTC | #1
On 20-09-2022 01:59, Andreas Rammhold wrote:
> +           (add-after 'configure 'enable-owe
> +             (lambda _
> +               (let ((port (open-file ".config" "al")))
> +                 (display "CONFIG_OWE=y\n" port)
> +                 (close-port port))
> +               #t))


(1) Why not do this in the 'configure' phase instead?
(2) Trailing #t in phases aren't required anymore since a long time, you 
can remove them.
(3) You are not a committer (and you are the author), so you can't 'push 
the commit on behalf on somebody else'.  From (guix)Commit Access:

    When pushing a commit on behalf of somebody else, please add a
‘Signed-off-by’ line at the end of the commit log message—e.g., with
‘git am --signoff’.  This improves tracking of who did what.

The other meaning of 'Signed-off-by' I'm aware of, is for 'Developer 
Certificate of Origin', but we don't do DCO in Guix (and if we did, it 
would be mentioned in the contributing guidelines somewhere).

Greetings,
Maxime.
M Sept. 22, 2022, 7:32 p.m. UTC | #2
On 22-09-2022 21:14, Maxime Devos wrote:
> (3) You are not a committer (and you are the author), so you can't 'push 
> the commit on behalf on somebody else'.  From (guix)Commit Access:

(At least, AFAIK, .guix-authorizations doesn't mention names or e-mails 
except for nicks)
Ludovic Courtès Sept. 28, 2022, 8:41 p.m. UTC | #3
Hi,

Maxime Devos <maximedevos@telenet.be> skribis:

> On 20-09-2022 01:59, Andreas Rammhold wrote:
>> +           (add-after 'configure 'enable-owe
>> +             (lambda _
>> +               (let ((port (open-file ".config" "al")))
>> +                 (display "CONFIG_OWE=y\n" port)
>> +                 (close-port port))
>> +               #t))
>
>
> (1) Why not do this in the 'configure' phase instead?
> (2) Trailing #t in phases aren't required anymore since a long time,
> you can remove them.
> (3) You are not a committer (and you are the author), so you can't
> 'push the commit on behalf on somebody else'.  From (guix)Commit

Good points (perhaps somewhat intimidating for a newcomer).

Andreas, I applied a variant of the patch that accounts for the comments
Maxime made.

Thank you!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 5fb621e027..84819992c4 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -51,6 +51,7 @@ 
 ;;; Copyright © 2021 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
 ;;; Copyright © 2022 Roman Riabenko <roman@riabenko.com>
+;;; Copyright © 2022 Andreas Rammhold <andreas@rammhold.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2133,6 +2134,12 @@  (define-public wpa-supplicant
       CONFIG_CTRL_IFACE_DBUS_INTRO=y\n" port)
                  (close-port port))
                #t))
+           (add-after 'configure 'enable-owe
+             (lambda _
+               (let ((port (open-file ".config" "al")))
+                 (display "CONFIG_OWE=y\n" port)
+                 (close-port port))
+               #t))
           (add-after 'install-documentation 'install-dbus-conf
             (lambda* (#:key outputs #:allow-other-keys)
               (let* ((out (assoc-ref outputs "out"))