diff mbox series

[bug#57954] gnu: clapack: Use position-independent code for use as a library.

Message ID 20220920124010.21646-1-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#57954] gnu: clapack: Use position-independent code for use as a library. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves Sept. 20, 2022, 12:40 p.m. UTC
* gnu/packages/maths.scm (clapack): Use position-independent code for use as a library.
---
 gnu/packages/maths.scm | 1 +
 1 file changed, 1 insertion(+)

Comments

Nicolas Graves Sept. 20, 2022, 12:58 p.m. UTC | #1
I am trying to get a vosk package to work for guix.
The build process is a bit tricky with replaced dependencies etc.

The team from vosk uses a version where they replace fortran by having
both openblas and clapack in libraries (which is incompatible in the
base kaldi configuration, so they have their own fork).

I don't know why exactly the library should be called from another
place, but when compiling kaldi with clapack, I get the following
message (and siblings):

ld: /gnu/store/yvc2w9mg554y6i4frvahjhacj0np9c7s-clapack-3.2.1/lib/liblapack.a(ssptrf.c.o): relocation R_X86_64_32 against `.rodata.str1.1' can not be used when making a shared object; recompile with -fPIC

I actually does work when recompiling with this flag, but I've also read
that it might make the package a bit slower.

In case it might help to answer, here's where I am for this package,
although not done yet (I still do have to untangle some ffi segmentation
fault issue) :
https://git.sr.ht/~ngraves/dotfiles/tree/main/item/packages/vosk.scm

What is the best option / course of action ?
M Sept. 22, 2022, 3:48 p.m. UTC | #2
On 20-09-2022 14:58, Nicolas Graves via Guix-patches via wrote:
> 
> I am trying to get a vosk package to work for guix.
> The build process is a bit tricky with replaced dependencies etc.
> 
> The team from vosk uses a version where they replace fortran by having
> both openblas and clapack in libraries (which is incompatible in the
> base kaldi configuration, so they have their own fork).
> 
> I don't know why exactly the library should be called from another
> place, but when compiling kaldi with clapack, I get the following
> message (and siblings):
> 
> ld: /gnu/store/yvc2w9mg554y6i4frvahjhacj0np9c7s-clapack-3.2.1/lib/liblapack.a(ssptrf.c.o): relocation R_X86_64_32 against `.rodata.str1.1' can not be used when making a shared object; recompile with -fPIC
> 
> I actually does work when recompiling with this flag, but I've also read
> that it might make the package a bit slower.
> 
> In case it might help to answer, here's where I am for this package,
> although not done yet (I still do have to untangle some ffi segmentation
> fault issue) :
> https://git.sr.ht/~ngraves/dotfiles/tree/main/item/packages/vosk.scm
> 
> What is the best option / course of action ?

'kaldi' is compiled as a shared library.  However, going by the error 
message, it is linked to the (static!) clapack.  IIUC, this is not a 
problem per se (the static library would be embedded into the shared 
library IIUC) -- however, shared libraries must be position-independent, 
whereas static libraries aren't by default.

As such, there appear to be three potential solutions:

   * compile the static library as -fPIC (your patch)
   * let kaldi link to a shared clapack (which is -fPIC by default)
   * let 'kaldi' (and its dependent, vosk) be a static library instead
     of a shared library.  Is likely problematic due to 'python-vosk'
     though.

Both 'real' solutions have -fPIC (explicit or implied), so I don't think 
we have to worry about performance.  My default option for deciding 
between static and shared is 'shared' (makes 'clapack' graftable, and 
better interaction with "guix build --repair" and "guix gc --references").

Hence, my proposed (and untested) solution is to make 'kaldi' link to a 
shared clapack.

Greetings,
Maxime.
Nicolas Graves Sept. 24, 2022, 8:37 a.m. UTC | #3
>    * compile the static library as -fPIC (your patch)
>    * let kaldi link to a shared clapack (which is -fPIC by default)

> Hence, my proposed (and untested) solution is to make 'kaldi' link to a
> shared clapack.

Thanks Maxime for your quick answer. 

Just to be sure of what that would imply (using the second answer here:
https://stackoverflow.com/questions/2649735/how-to-link-static-library-into-dynamic-library-in-gcc):

1) We keep the version of clapack patched for -fPIC.
2) I need to make a package providing a shared version of clapack based
on this version of clapack compiled with -fPIC.

Also, my original patch is wrong, I'll send a corrected one once I
understand the process.
M Sept. 24, 2022, 9:46 a.m. UTC | #4
On 24-09-2022 10:37, Nicolas Graves wrote:
> 
>>     * compile the static library as -fPIC (your patch)
>>     * let kaldi link to a shared clapack (which is -fPIC by default)
> 
>> Hence, my proposed (and untested) solution is to make 'kaldi' link to a
>> shared clapack.
> 
> Thanks Maxime for your quick answer.
> 
> Just to be sure of what that would imply (using the second answer here:
> https://stackoverflow.com/questions/2649735/how-to-link-static-library-into-dynamic-library-in-gcc):
> 
> 1) We keep the version of clapack patched for -fPIC.
> 2) I need to make a package providing a shared version of clapack based
> on this version of clapack compiled with -fPIC.
> 
> Also, my original patch is wrong, I'll send a corrected one once I
> understand the process.

That should do it AFAIK.

However, going by 
https://cmake.org/cmake/help/latest/variable/BUILD_SHARED_LIBS.html#variable:BUILD_SHARED_LIBS 
, you can ask CMake to do these steps instead.

Also, going by the descriptio of 'clapack': ‘"The CLAPACK library was 
built using a Fortran to C conversion utility
called f2c.  The entire Fortran 77 LAPACK library is run through f2c to 
obtain C code, and then modified to improve readability.  CLAPACK's goal 
is to provide LAPACK for someone who does not have access to a Fortran 
compiler.’

... it sounds like clapack could be replaced with lapack without any 
problems (and even removed), and our 'lapack' package already makes 
shared libraries, which seems like a simpler course of action.

Greetings,
Maxime
Nicolas Graves Sept. 28, 2022, 12:19 p.m. UTC | #5
> ... it sounds like clapack could be replaced with lapack without any
> problems (and even removed), and our 'lapack' package already makes
> shared libraries, which seems like a simpler course of action.

You're absolutely right about this. I replaced clapack by lapack and
discarded the flag -lf2c during the build phase.

Everything works fine. I'm closing the issue.

The resulting packages are available in issue 58140.
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 72d5e9a83a..0c4b7ada03 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -968,6 +968,7 @@  (define-public clapack
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags '("-DCMAKE_C_FLAGS=-fcommon -O2")
+       #:make-flags '("-fPIC")
        #:phases
        (modify-phases %standard-phases
          ;; These tests use a lot of stack variables and segfault without