From 73f8a31fcaf8abab962e0f30407407b267222614 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Sat, 13 Aug 2022 16:40:58 -0700
Subject: [PATCH] gnu: Add python-suntime.
* gnu/packages/astronomy.scm (python-suntime): New variable.
---
gnu/packages/astronomy.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
@@ -1823,6 +1823,27 @@ (define-public python-sep
(modify-inputs (package-inputs libsep)
(prepend python-numpy)))))
+(define-public python-suntime
+ (package
+ (name "python-suntime")
+ (version "1.2.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "suntime" version))
+ (sha256
+ (base32
+ "0ja64w293wjx76q3z18ikx4rdihwkbj6pnjpbs82ycyyzhfnbpz4"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-dateutil))
+ (home-page "https://github.com/SatAgro/suntime")
+ (synopsis "Sunset and sunrise time calculation python library")
+ (description
+ "Python library doing sunrise and sunset time calculation.
+
+Takes a WGS84 (GPS) latitude/longitude as input as well as an UTC or local
+datetime object.")
+ (license license:lgpl3+)))
+
(define-public python-asdf
(package
(name "python-asdf")
--
2.35.1