diff mbox series

[bug#57809] gnome-boxes: Fix path for 'qemu-img'

Message ID 20220919213607.24888-1-kreyren@rixotstudio.cz
State Accepted
Headers show
Series [bug#57809] gnome-boxes: Fix path for 'qemu-img' | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Jacob Hrbek Sept. 19, 2022, 9:36 p.m. UTC
---
 gnu/packages/gnome.scm | 102 ++++++++++++++++++++++-------------------
 1 file changed, 55 insertions(+), 47 deletions(-)

+                   ;; For all others.
+                   license:lgpl2.0+))))

 (define-public geary
   (package
--
2.37.3

Comments

Liliana Marie Prikler Sept. 20, 2022, 5:18 a.m. UTC | #1
Am Montag, dem 19.09.2022 um 21:36 +0000 schrieb Jacob Hrbek:
> ---
>  gnu/packages/gnome.scm | 102 ++++++++++++++++++++++-----------------
> --
Too much noise.  Please separate cosmetic and non-cosmetic changes.

Thanks
Jacob Hrbek Sept. 20, 2022, 7:55 a.m. UTC | #2
>> [Krey format the code it looks like trash]

>> [Krey there is too much cosmetic noise it looks like trash]

...

https://issues.guix.gnu.org/57809#9 is the solution

https://issues.guix.gnu.org/57809#13 is the solution + `$ guix style gnome-boxes`

------- Original Message -------
On Tuesday, September 20th, 2022 at 7:18 AM, Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:


> Am Montag, dem 19.09.2022 um 21:36 +0000 schrieb Jacob Hrbek:
> 

> > ---
> > gnu/packages/gnome.scm | 102 ++++++++++++++++++++++-----------------
> > --
> 

> Too much noise. Please separate cosmetic and non-cosmetic changes.
> 

> Thanks
Liliana Marie Prikler Sept. 20, 2022, 5:12 p.m. UTC | #3
Am Dienstag, dem 20.09.2022 um 07:55 +0000 schrieb Jacob Hrbek:
> > > [Krey format the code it looks like trash]
> 
> > > [Krey there is too much cosmetic noise it looks like trash]
It is admittedly our fault that we're advertising tools which don't do
their job, but it's not our fault that neither you nor your text editor
know how to match up parentheses with indentation levels.
Ludovic Courtès Sept. 26, 2022, 9:07 p.m. UTC | #4
Hey Liliana,

Please let’s not try to find “whose fault it is”.  We’re all trying to
help.

In such a situation, my experience is that it is not only more pleasant
but also more efficient to apply the patch and those remaining tweaks by
yourself so the submitter can see what changes were made and learn from
it.

Thanks in advance,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d6d22f8eb1..65054fc4ac 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12115,67 +12115,75 @@  (define-public gnome-boxes
   (package
     (name "gnome-boxes")
     (version "42.3")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "mirror://gnome/sources/gnome-boxes/"
-                           (version-major version) "/"
-                           "gnome-boxes-" version ".tar.xz"))
-       (sha256
-        (base32 "1lv0bdh935qj6wkv3ixg2pcv8yrapj79z02gw4fal3rhz3xggvsn"))))
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/gnome-boxes/"
+                                  (version-major version)
+                                  "/"
+
             "gnome-boxes-"
+                                  version
+                                  ".tar.xz"))
+              (sha256
+               (base32
+                "1lv0bdh935qj6wkv3ixg2pcv8yrapj79z02gw4fal3rhz3xggvsn"))))
     (build-system meson-build-system)
     (arguments
      (list #:glib-or-gtk? #t
            #:configure-flags #~(list "-Drdp=false"
-                                     (string-append "-Dc_link_args=-Wl,-rpath="
-                                                    #$output
-                                                    "/lib/gnome-boxes"))
+                                     (string-append
+                                      "-Dc_link_args=-Wl,-rpath="
+                                      #$output "/lib/gnome-boxes"))
            #:phases #~(modify-phases %standard-phases
                         (add-after 'unpack 'disable-gtk-update-icon-cache
                           (lambda _
-                            (
setenv "DESTDIR" "/"))))))
-    (native-inputs
-     (list desktop-file-utils           ;for update-desktop-database
-           gettext-minimal
-           `(,glib "bin")               ;for glib-compile-resources
-           itstool
-           pkg-config
-           python
-           vala))
-    (inputs
-     (list glib-networking              ;for TLS support
-           gsettings-desktop-schemas
-           gtk+
-           gtk-vnc
-           gtksourceview
-           json-glib
-           libarchive
-           libgudev
-           libhandy
-           libosinfo
-           libsecret
-           libsoup-minimal-2
-           libusb
-           libvirt
-           libvirt-glib
-           libxml2
-           sparql-query
-           spice-gtk
-           tracker
-           vte
-           webkitgtk-with-libsoup2))    ;for webkit2gtk-4.0
+                            (setenv "DESTDIR" "/")))
+                        (add-before 'configure 'substitut
e-qemu-dependencies
+                          (lambda* (#:key inputs #:allow-other-keys)
+                            (substitute* "src/installed-media.vala"
+                              (("qemu-img")
+                               (search-input-file inputs "/bin/qemu-img"))))))))
+    (native-inputs (list desktop-file-utils ;for update-desktop-database
+                         gettext-minimal
+                         `(,glib "bin") ;for glib-compile-resources
+                         itstool
+                         pkg-config
+                         python
+                         vala))
+    (inputs (list glib-networking ;for TLS support
+                  gsettings-desktop-schemas
+                  gtk+
+                  gtk-vnc
+                  gtksourceview
+                  json-glib
+                  libarchive
+                  libgudev
+                  libhandy
+                  libosinfo
+                  libsecret
+
    libsoup-minimal-2
+                  libusb
+                  libvirt
+                  libvirt-glib
+                  libxml2
+                  qemu-minimal ;for qemu-img
+                  sparql-query
+                  spice-gtk
+                  tracker
+                  vte
+                  webkitgtk-with-libsoup2)) ;for webkit2gtk-4.0
     (home-page "https://wiki.gnome.org/Apps/Boxes")
     (synopsis "View, access, and manage remote and virtual systems")
-    (description "GNOME Boxes is a simple application to view, access, and
+    (description
+     "GNOME Boxes is a simple application to view, access, and
 manage remote and virtual systems.  Note that this application requires the
 @code{libvirt} and @code{virtlog} daemons to run.  Use the command
 @command{info '(guix) Virtualization Services'} to learn how to configure
 these services on the Guix System.")
     (license (list
-              ;; For data/icons/empty-boxes.png.
-
  license:cc-by2.0
-              ;; For all others.
-              license:lgpl2.0+))))
+                   ;; For data/icons/empty-boxes.png.
+                   license:cc-by2.0