diff mbox series

[bug#57675,v4,10/10] gnu: telegram-desktop: Update to 4.2.0.

Message ID y76zgevq4av.wl-hako@ultrarare.space
State Accepted
Headers show
Series gnu: telegram-desktop: Update to 4.2.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hilton Chain Sept. 19, 2022, 6:14 a.m. UTC
* gnu/packages/telegram.scm (cmake-helpers-for-telegram-desktop): Update to
b9f1b6.
(codegen-for-telegram-desktop): Update to 8815d7.
(lib-base-for-telegram-desktop): Update to cc5550.
(lib-crl-for-telegram-desktop): Update to 4e620b.
(lib-lottie-for-telegram-desktop): Update to 6ed1c2.
(lib-qr-for-telegram-desktop): Update to 501f4c.
(lib-rpl-for-telegram-desktop): Update to fd31f5.
(lib-spellcheck-for-telegram-desktop): Update to 0e386e.
(lib-storage-for-telegram-desktop): Update to 839609.
(lib-tl-for-telegram-desktop): Update to 36fb95.
(lib-ui-for-telegram-desktop): Update to f82162.
(lib-webrtc-for-telegram-desktop): Update to 9b1159.
(lib-webview-for-telegram-desktop): Update to 546df6.
(lib-rlottie-for-telegram-desktop,lib-waylandshells-for-telegram-desktop):
Remove variables.
(tgcalls-for-telegram-desktop): Update to 82c492.
(dispatch-for-telegram-desktop): New variable.
(rlottie-for-telegram-desktop): Update to 8c69fc.
[snippet]: Switch off werror.
[arguments]: Use inherited ones.
(libtgvoip-for-telegram-desktop): Update to 78a8e2.
Change to source.
(telegram-desktop): Update to 4.2.0.
[#:configure-flags]: Comment out with default vaules.
Use system rlottie
[native-inputs]: Add clang-toolchain.
Drop cmake-shared, extra-cmake-modules and qttools-5.
[inputs]: Add abseil-cpp-cxxstd17, kcoreaddons, libvpx, qt5compat, qtbase,
wayland and webkitgtk.
Drop catch2, fcitx-qt5, fcitx5-qt, gtk+, hime, kwayland, materialdecoration,
libdbusmenu-qt, libtgvoip-for-telegram-desktop, nimf, qtbase-5, qt5ct, libx11.
[propagated-inputs]: Drop dconf.
[snippet,#:phases,license]: Sync with source tree.
---
 gnu/packages/telegram.scm | 313 +++++++++++++++++---------------------
 1 file changed, 139 insertions(+), 174 deletions(-)

--
2.37.3

Comments

Liliana Marie Prikler Sept. 19, 2022, 5:11 p.m. UTC | #1
Am Montag, dem 19.09.2022 um 14:14 +0800 schrieb Hilton Chain:
> 
> * gnu/packages/telegram.scm (cmake-helpers-for-telegram-desktop):
> Update to
> b9f1b6.
> (codegen-for-telegram-desktop): Update to 8815d7.
> (lib-base-for-telegram-desktop): Update to cc5550.
> (lib-crl-for-telegram-desktop): Update to 4e620b.
> (lib-lottie-for-telegram-desktop): Update to 6ed1c2.
> (lib-qr-for-telegram-desktop): Update to 501f4c.
> (lib-rpl-for-telegram-desktop): Update to fd31f5.
> (lib-spellcheck-for-telegram-desktop): Update to 0e386e.
> (lib-storage-for-telegram-desktop): Update to 839609.
> (lib-tl-for-telegram-desktop): Update to 36fb95.
> (lib-ui-for-telegram-desktop): Update to f82162.
> (lib-webrtc-for-telegram-desktop): Update to 9b1159.
> (lib-webview-for-telegram-desktop): Update to 546df6.
> (lib-rlottie-for-telegram-desktop,lib-waylandshells-for-telegram-
> desktop):
> Remove variables.
> (tgcalls-for-telegram-desktop): Update to 82c492.
> (dispatch-for-telegram-desktop): New variable.
> (rlottie-for-telegram-desktop): Update to 8c69fc.
> [snippet]: Switch off werror.
> [arguments]: Use inherited ones.
> (libtgvoip-for-telegram-desktop): Update to 78a8e2.
> Change to source.
> (telegram-desktop): Update to 4.2.0.
> [#:configure-flags]: Comment out with default vaules.
You don't need to add those comments – in fact, I'd posit that the
package is more readable without them.
> Use system rlottie
> [native-inputs]: Add clang-toolchain.
> Drop cmake-shared, extra-cmake-modules and qttools-5.
> [inputs]: Add abseil-cpp-cxxstd17, kcoreaddons, libvpx, qt5compat,
> qtbase,
> wayland and webkitgtk.
> Drop catch2, fcitx-qt5, fcitx5-qt, gtk+, hime, kwayland,
> materialdecoration,
> libdbusmenu-qt, libtgvoip-for-telegram-desktop, nimf, qtbase-5,
> qt5ct, libx11.
Remember to keep the inputs sorted.  Also, are you sure you can drop
all of those?
> [propagated-inputs]: Drop dconf.
> [snippet,#:phases,license]: Sync with source tree.
diff mbox series

Patch

diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
index 7542f6cd17..7556513208 100644
--- a/gnu/packages/telegram.scm
+++ b/gnu/packages/telegram.scm
@@ -28,6 +28,7 @@  (define-module (gnu packages telegram)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages cpp)
   #:use-module (gnu packages digest)
+  #:use-module (gnu packages enchant)
   #:use-module (gnu packages fcitx)
   #:use-module (gnu packages fcitx5)
   #:use-module (gnu packages freedesktop)
@@ -43,6 +44,7 @@  (define-module (gnu packages telegram)
   #:use-module (gnu packages libevent)
   #:use-module (gnu packages libreoffice)
   #:use-module (gnu packages linux)
+  #:use-module (gnu packages llvm)
   #:use-module (gnu packages lxqt)
   #:use-module (gnu packages lua)
   #:use-module (gnu packages perl)
@@ -60,12 +62,14 @@  (define-module (gnu packages telegram)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages video)
   #:use-module (gnu packages web)
+  #:use-module (gnu packages webkit)
   #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xiph)
   #:use-module (gnu packages xorg)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix gexp)
+  #:use-module (guix utils)
   #:use-module (guix git-download)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system copy)
@@ -105,131 +109,131 @@  (define crc32c-for-telegram-desktop
 (define cmake-helpers-for-telegram-desktop
   (source-for-telegram-desktop
    #:url "https://github.com/desktop-app/cmake_helpers.git"
-   #:revision "0"
-   #:commit "4d44d822e01b3b5fbec3ce824e01f56aa35d7f72"
-   #:hash "0h6cjiqy014h2mz90h1z5a7plb3ihbnds4bja8994ybr1dy3m7m5"
+   #:revision "1"
+   #:commit "b9f1b6036329e44ec61f51f0b363fe2319158b84"
+   #:hash "0sgp1nlmcm2imgpssqxrwinafnmicmq0qikgdnhs1d44hrwxbws3"
    #:name "cmake-helpers"))

 (define codegen-for-telegram-desktop
   (source-for-telegram-desktop
    #:url "https://github.com/desktop-app/codegen.git"
-   #:revision "0"
-   #:commit "248614b49cd7d5aff69d75a737f2e35b79fbb119"
-   #:hash "00f7g2z6xmkbkrmi3q27hscjl44mg66wf9q0mz3rhy3jaa6cfdrk"
+   #:revision "1"
+   #:commit "8815d7aec9b901191d08445f29e2edd0aeba7b2c"
+   #:hash "1ly958mjk25kfcpa174kvg134p9r751ixi275afj5kr57by9mbq2"
    #:name "codegen"))

 (define lib-base-for-telegram-desktop
   (source-for-telegram-desktop
    #:url "https://github.com/desktop-app/lib_base.git"
-   #:revision "0"
-   #:commit "a23c05c44e4f01dc4428f4d75d4db98c59d313a6"
-   #:hash "0vh5zgxwalmbnvz8lzlnba87ch8vnpmcz6nvf56w09f3nlxvvq78"
+   #:revision "1"
+   #:commit "cc5550de2766657ced8d0bb4d2db3f050363d3d5"
+   #:hash "16x5qp5w51igk213rhl49x256vjvpkjkgi2ziwzxnsj0pzdd4y27"
    #:name "lib-base"))

 (define lib-crl-for-telegram-desktop
   (source-for-telegram-desktop
    #:url "https://github.com/desktop-app/lib_crl.git"
-   #:revision "0"
-   #:commit "3ccf2ed5095442e5874bba8852cb7dc4efeae29f"
-   #:hash "11my7q54m4lvvlgma6pbdyjxi1cv1adk1gph2j50mh18sqlm8myz"
+   #:revision "1"
+   #:commit "4e620bc383d032aadea8e6af02661f8c76695cec"
+   #:hash "17bngj247qwq0dg4h37xdi5v1mk22y4yp7sp6ph3irmnz4awah0x"
    #:name "lib-crl"))

 (define lib-lottie-for-telegram-desktop
   (source-for-telegram-desktop
    #:url "https://github.com/desktop-app/lib_lottie.git"
-   #:revision "0"
-   #:commit "0770df009db7928df1d0cad0900dc5110106d229"
-   #:hash "1gj56ymlbk5dnk82jw674808m511lv9dky8891a5wm4gp3pph5jb"
+   #:revision "1"
+   #:commit "6ed1c22ed60692d2f288c9222fafd7d5cd62f904"
+   #:hash "0l57ibfij9xm4ww4s9cc63q1x8xzpc6ablwaji1krrn3xxksqdd4"
    #:name "lib-lottie"))

 (define lib-qr-for-telegram-desktop
   (source-for-telegram-desktop
    #:url "https://github.com/desktop-app/lib_qr.git"
-   #:revision "0"
-   #:commit "2b08c71c6edcfc3e31f7d7f518cc963493b6e189"
-   #:hash "05hrkmwgrczyjv87r507i2r7m1zr6k2i43mq3my0s6j4szr1rjq0"
+   #:revision "1"
+   #:commit "501f4c3502fd872ab4d777df8911bdac32de7c48"
+   #:hash "0hmwqj7a9vcy8wq7pd1qprl68im3zl5f1wzcn2zzk2wvi0389k9f"
    #:name "lib-qr"))

-(define lib-rlottie-for-telegram-desktop
-  (source-for-telegram-desktop
-   #:url "https://github.com/desktop-app/lib_rlottie.git"
-   #:revision "0"
-   #:commit "0671bf70547381effcf442ec9618e04502a8adbc"
-   #:hash "05qnza7j15356s8jq16pkbyp4zr586lssmd86lz5jq23lcb3raxv"
-   #:name "lib-rlottie"))
-
 (define lib-rpl-for-telegram-desktop
   (source-for-telegram-desktop
    #:url "https://github.com/desktop-app/lib_rpl.git"
-   #:revision "0"
-   #:commit "df721be3fa14a27dfc230d2e3c42bb1a7c9d0617"
-   #:hash "15fnv3ssn7rn5d0j52gggdvyqc2wm464678dj7v2x9h8lka2jjxn"
+   #:revision "1"
+   #:commit "fd31f5bf382d2679eccdb1abaf8240a56c6a7abe"
+   #:hash "1fpq8nyh8wx6zkb3sjjrx9ydqzyhw4483bdk1i9blp0ijn9xxdxf"
    #:name "lib-rpl"))

 (define lib-spellcheck-for-telegram-desktop
   (source-for-telegram-desktop
    #:url "https://github.com/desktop-app/lib_spellcheck.git"
-   #:revision "0"
-   #:commit "68c9b788958904aea7de79f986a0f82ec8c5b094"
-   #:hash "0d8s4wwk6fxf536mhzq2vb9qw3j0m8nqia7ylvvpsbc4kh09dadn"
+   #:revision "1"
+   #:commit "0e386e22cb6ba8a114b569840a635e096dcb645e"
+   #:hash "06js7ccv6z3nbd4v2p4hp2prrlmz5ww46y3yb922pp7gm317dwyw"
    #:name "lib-spellcheck"))

 (define lib-storage-for-telegram-desktop
   (source-for-telegram-desktop
    #:url "https://github.com/desktop-app/lib_storage.git"
-   #:revision "0"
-   #:commit "403df6c4a29562bd417c92d410e49819f5a48cc1"
-   #:hash "1zxvzfrxbj4d395fzyb5pm9wn3n8jyimxx88cyqjcdd46sx4h7r5"
+   #:revision "1"
+   #:commit "839609369d04615475cb1518636de3619106a917"
+   #:hash "1l26h2fmqp9dcpr6pfvdd5sjb68j7yh0ms2lnr8na7jf5xqmkwwm"
    #:name "lib-storage"))

 (define lib-tl-for-telegram-desktop
   (source-for-telegram-desktop
    #:url "https://github.com/desktop-app/lib_tl.git"
-   #:revision "0"
-   #:commit "45faed44e7f4d11fec79b7a70e4a35dc91ef3fdb"
-   #:hash "0h43xvzklda02494d466jp52hl8c1kmav9f12dyld10dpf1w6c7m"
+   #:revision "1"
+   #:commit "36fb95c4de1339d2c8921ad6b2911858c3d0e0fa"
+   #:hash "03rngnssnqwr7ad05qn64mwgji5fb0r3fp5ybkf951p8phr1jvzk"
    #:name "lib-tl"))

 (define lib-ui-for-telegram-desktop
   (source-for-telegram-desktop
    #:url "https://github.com/desktop-app/lib_ui.git"
-   #:revision "0"
-   #:commit "1b590f9e16eb9571a039f072d6fea66c607e419f"
-   #:hash "0ighyhfp29h9h8c7vr70pnhcv2xnsr9ln084pssn8hb5z4pmb62f"
+   #:revision "1"
+   #:commit "f82162f05a72352bfee0fb79f9e50c350b3a98f3"
+   #:hash "1zv29i7hxv70dsq36zrvkvaraff5zcb7sccpncqfl51s59kfsnz5"
    #:name "lib-ui"))

-(define lib-waylandshells-for-telegram-desktop
-  (source-for-telegram-desktop
-   #:url "https://github.com/desktop-app/lib_waylandshells.git"
-   #:revision "0"
-   #:commit "59b0ee55a68976d27f1bf7cec0e11d5939e185e7"
-   #:hash "0l2xrpc5mvvdlsj333pmkgfvn9wi1ijfdaaz8skfnw9icw52faaf"
-   #:name "lib-waylandshells"))
-
 (define lib-webrtc-for-telegram-desktop
   (source-for-telegram-desktop
    #:url "https://github.com/desktop-app/lib_webrtc.git"
-   #:revision "0"
-   #:commit "ef49f953f12b112008a094a719f40939aaf39db4"
-   #:hash "15k4xs3462p3ddp5cn9im3nvdiaijmxir8wxsf5yrj70ghy26ibw"
+   #:revision "1"
+   #:commit "9b11599c3c56047cfa4c68b69f1fcc93b602c33a"
+   #:hash "0158jx8hj4fv6qpw5pgcr2mdlihj0dxs060dg3iy61zz6q68z5dq"
    #:name "lib-webrtc"))

 (define lib-webview-for-telegram-desktop
   (source-for-telegram-desktop
    #:url "https://github.com/desktop-app/lib_webview.git"
-   #:revision "0"
-   #:commit "e06427c624515485774e2e2181d4afeb05ad5a67"
-   #:hash "148z7xzfscynwwwqssdsd97npax6yn8zrd64xw8qzbwff2g2r7k4"
+   #:revision "1"
+   #:commit "546df65eb2424550ed84ce14fc9c5d1bb3586f35"
+   #:hash "0zzjwyw82bggncmmsw969lnjl04pklmqjqm77jjzadinivl52z0l"
    #:name "lib-webview"))

 (define tgcalls-for-telegram-desktop
   (source-for-telegram-desktop
    #:url "https://github.com/TelegramMessenger/tgcalls.git"
-   #:revision "0"
-   #:commit "81e97fa52e25b7775b62ce07bb653533d81e91b3"
-   #:hash "0fvad87hyxli83xn19mgf8jjrrh6y6iaig14pckpbkg33vf4wqkj"
+   #:revision "1"
+   #:commit "82c4921045c440b727c38e464f3a0539708423ff"
+   #:hash "1109r17abh66yz91b65fn2g4ryfybnsr5g6075sjhbah1gccv9mk"
    #:name "tgcalls"))

+(define dispatch-for-telegram-desktop
+  (source-for-telegram-desktop
+   #:url "https://github.com/apple/swift-corelibs-libdispatch.git"
+   #:revision "0"
+   #:commit "ecc678d79f38cf63d24b6d16e18f69a9117d8d73"
+   #:hash "0hy4q6x3bgphazmpl3v62995abc9fpi8y7yg9aiblzsqkxmgjmqn"
+   #:name "dispatch"))
+
+(define libtgvoip-for-telegram-desktop
+  (source-for-telegram-desktop
+   #:url "https://github.com/telegramdesktop/libtgvoip.git"
+   #:revision "0"
+   #:commit "78a8e22bedb0d06004da8bafeba88b7474cb89a4"
+   #:hash "1y1jvm4i0i4fkl6c0bgcv2cpzziyyn1pywxqz726q008hwki941h"
+   #:name "libtgvoip"))
+
 (define-public webrtc-for-telegram-desktop
   (let ((commit "621f3da55331733bf0d1b223786b96b68c03dca1")
         (revision "167"))
@@ -328,8 +332,8 @@  (define-public webrtc-for-telegram-desktop
          license:bsd-3))))))

 (define-public rlottie-for-telegram-desktop
-  (let ((commit "cbd43984ebdf783e94c8303c41385bf82aa36d5b")
-        (revision "671"))
+  (let ((commit "8c69fc20cf2e150db304311f1233a4b55a8892d7")
+        (revision "672"))
     (hidden-package
      (package
        (inherit rlottie)
@@ -345,102 +349,52 @@  (define-public rlottie-for-telegram-desktop
           (file-name
            (git-file-name "rlottie-for-telegram-desktop" version))
           (sha256
-           (base32 "1lxpbgbhps9rmck036mgmiknqrzpjxpas8n7qxykv6pwzn0c8n0c"))))
-       (arguments
-        `(#:configure-flags
-          (list
-           "-Dlog=true"
-           "-Ddumptree=true"
-           "-Dtest=true")
-          #:phases
-          (modify-phases %standard-phases
-            (add-after 'unpack 'patch-cxx-flags
-              (lambda _
-                (substitute* "meson.build"
-                  (("werror=true")
-                   "werror=false"))
-                #t)))))))))
-
-(define-public libtgvoip-for-telegram-desktop
-  (let ((commit "13a5fcb16b04472d808ce122abd695dbf5d206cd")
-        (revision "88"))
-    (hidden-package
-     (package
-       (inherit libtgvoip)
-       (version
-        (git-version "2.4.4" revision commit))
-       (source
-        (origin
-          (method git-fetch)
-          (uri
-           (git-reference
-            (url "https://github.com/telegramdesktop/libtgvoip.git")
-            (commit commit)))
-          (file-name
-           (git-file-name "libtgvoip-for-telegram-desktop" version))
-          (sha256
-           (base32 "12p6s7vxkf1gh1spdckkdxrx7bjzw881ds9bky7l5fw751cwb3xd"))))
-       (arguments
-        `(#:configure-flags
-          (list
-           "--disable-static"
-           "--disable-dsp"              ; FIXME
-           "--enable-audio-callback"
-           "--with-alsa"
-           "--with-pulse")
-          #:phases
-          (modify-phases %standard-phases
-            (add-after 'unpack 'patch-linkers
-              (lambda _
-                (substitute* "Makefile.am"
-                  (("\\$\\(CRYPTO_LIBS\\) \\$\\(OPUS_LIBS\\)")
-                   "$(CRYPTO_LIBS) $(OPUS_LIBS) $(ALSA_LIBS) $(PULSE_LIBS)"))
-                (substitute* "tgvoip.pc.in"
-                  (("libcrypto opus")
-                   "libcrypto opus alsa libpulse"))
-                #t)))))
-       (native-inputs
-        (list autoconf automake libtool pkg-config))))))
+           (base32 "14gwg3sn6xdx9ymnx5r0vfm4pk8dwk92s10a1wdvfbjpyrxll64i"))
+          (modules '((guix build utils)))
+          (snippet
+           #~(begin
+               (substitute* "meson.build"
+                 (("werror=true") "werror=false"))))))))))

 (define-public telegram-desktop
   (package
     (name "telegram-desktop")
-    (version "2.9.3")
+    (version "4.2.0")
     (source
      (origin
        (method git-fetch)
        (uri
         (git-reference
          (url "https://github.com/telegramdesktop/tdesktop.git")
-         (commit
-          (string-append "v" version))))
+         (commit (string-append "v" version))))
        (file-name
         (git-file-name name version))
        (sha256
-        (base32 "0dzf1y3xhqvizg29bd1kya48cjbkq073d2x10ynwcmmx396l4nd8"))
+        (base32 "16xhng5m3aw4j4ax74nydpxjnx5z3ga21vmrznlm4lbk9ivyn7vx"))
        (modules '((guix build utils)
                   (ice-9 ftw)
                   (srfi srfi-1)))
        (snippet
-        `(begin
-           (let ((keep
-                  '( ;; Not available in Guix.
-                    "SPMediaKeyTap" "statusnotifieritem" "tgcalls")))
-             (with-directory-excursion "Telegram/ThirdParty"
-               (for-each delete-file-recursively
-                         (lset-difference string=?
-                                          (scandir ".")
-                                          (cons* "." ".." keep)))))))))
+        #~(begin
+            (let ((keep
+                   '(;; Own fork, bundled build to avoid an addressing issue.
+                     "libtgvoip"
+                     ;; Not available in Guix.
+                     "dispatch" "tgcalls")))
+              (with-directory-excursion "Telegram/ThirdParty"
+                (for-each delete-file-recursively
+                          (lset-difference string=?
+                                           (scandir ".")
+                                           (cons* "." ".." keep)))))))))
     (build-system qt-build-system)
     (arguments
-     (list #:tests? #f                      ; No target
+     (list #:tests? #f                  ;No target
            #:imported-modules
            `(,@%qt-build-system-modules
              (guix build glib-or-gtk-build-system))
            #:modules
            '((guix build qt-build-system)
-             ((guix build glib-or-gtk-build-system)
-              #:prefix glib-or-gtk:)
+             ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
              (guix build utils)
              (ice-9 match))
            #:configure-flags
@@ -448,17 +402,31 @@  (define-public telegram-desktop
                ;; see also <https://core.telegram.org/api/obtaining_api_id>.
                "-DTDESKTOP_API_ID=611335"
                "-DTDESKTOP_API_HASH=d524b414d21f4d37f08684c1df41ac9c"
-               ;; Disable WebkitGTK support as it fails to link
-               "-DDESKTOP_APP_DISABLE_WEBKITGTK=ON"
-               ;; Use bundled fonts as fallback.
-               "-DDESKTOP_APP_USE_PACKAGED_FONTS=OFF")
+               ,(string-append "-DTDESKTOP_LAUTCHER_BASENAME=" #$name)
+               ;; NOTE: Options commented are default values.
+               ;; See also: comments in inputs.
+               ;; "-DDESKTOP_APP_LOTTIE_USE_CACHE=ON"
+               ;; "-DDESKTOP_APP_DISABLE_DBUS_INTEGRATION=OFF"
+               ;; "-DDESKTOP_APP_DISABLE_WAYLAND_INTEGRATION=OFF"
+               ;; "-DDESKTOP_APP_DISABLE_X11_INTEGRATION=OFF"
+               ;; "-DDESKTOP_APP_USE_ALLOCATION_TRACER=OFF"
+               ;; "-DDESKTOP_APP_USE_PACKAGED=ON"
+               ;; "-DDESKTOP_APP_USE_PACKAGED_FONTS=OFF"
+               ;; "-DDESKTOP_APP_DISABLE_SPELLCHECK=OFF"
+               ;; "-DDESKTOP_APP_USE_HUNSPELL_ONLY=OFF"
+               ;; "-DDESKTOP_APP_USE_ENCHANT=OFF"
+               ;; "-DDESKTOP_APP_NO_PDB=OFF"
+               ;; "-DDESKTOP_APP_DISABLE_JEMALLOC=OFF"
+               "-DDESKTOP_APP_DISABLE_CRASH_REPORTS=ON"
+               "-DDESKTOP_APP_DISABLE_AUTOUPDATE=ON"
+               "-DDESKTOP_APP_USE_PACKAGED_RLOTTIE=ON")
            #:phases
            #~(modify-phases %standard-phases
                (add-after 'unpack 'make-writable
                  (lambda _
                    (for-each make-file-writable (find-files "."))))
                (add-after 'make-writable 'copy-sources
-                 (lambda* (#:key inputs outputs #:allow-other-keys)
+                 (lambda _
                    (for-each
                     (match-lambda
                       ((dst src)
@@ -470,81 +438,78 @@  (define-public telegram-desktop
                       ("Telegram/lib_crl" #$lib-crl-for-telegram-desktop)
                       ("Telegram/lib_lottie" #$lib-lottie-for-telegram-desktop)
                       ("Telegram/lib_qr" #$lib-qr-for-telegram-desktop)
-                      ("Telegram/lib_rlottie" #$lib-rlottie-for-telegram-desktop)
                       ("Telegram/lib_rpl" #$lib-rpl-for-telegram-desktop)
                       ("Telegram/lib_spellcheck" #$lib-spellcheck-for-telegram-desktop)
                       ("Telegram/lib_storage" #$lib-storage-for-telegram-desktop)
                       ("Telegram/lib_tl" #$lib-tl-for-telegram-desktop)
                       ("Telegram/lib_ui" #$lib-ui-for-telegram-desktop)
-                      ("Telegram/lib_waylandshells" #$lib-waylandshells-for-telegram-desktop)
                       ("Telegram/lib_webrtc" #$lib-webrtc-for-telegram-desktop)
                       ("Telegram/lib_webview" #$lib-webview-for-telegram-desktop)
+                      ("Telegram/ThirdParty/dispatch" #$dispatch-for-telegram-desktop)
+                      ("Telegram/ThirdParty/libtgvoip" #$libtgvoip-for-telegram-desktop)
                       ("Telegram/ThirdParty/tgcalls" #$tgcalls-for-telegram-desktop)))))
-               (add-before 'configure 'patch-cxx-flags
-                 (lambda _
-                   (substitute* "cmake/options_linux.cmake" (("class-memaccess") "all"))))
                (add-after 'install 'glib-or-gtk-compile-schemas
                  (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
                (add-after 'glib-or-gtk-compile-schemas 'glib-or-gtk-wrap
                  (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
     (native-inputs
-     (list cmake-shared
-           extra-cmake-modules
-           `(,glib "bin")
+     (list `(,glib "bin")
            `(,gtk+ "bin")
+           clang-toolchain
            pkg-config
-           python-wrapper
-           qttools-5))
+           python-wrapper))
     (inputs
-     (list alsa-lib
+     (list abseil-cpp-cxxstd17
+           alsa-lib
            c++-gsl
-           catch2
-           libexpected
-           fcitx-qt5
-           fcitx5-qt
            ffmpeg
-           glib
-           glibmm-2.64
-           gtk+
-           hime
-           hunspell
            jemalloc
-           kwayland
-           libdbusmenu-qt
+           kcoreaddons
+           libexpected
            libjpeg-turbo
-           libtgvoip-for-telegram-desktop
-           lz4
-           materialdecoration
+           libvpx
            minizip
-           nimf
            openal
            openssl
            opus
            pulseaudio
            qrcodegen-cpp
-           qtbase-5
-           qtsvg-5
-           qt5ct
+           qt5compat
+           qtbase
            qtimageformats
-           qtwayland
+           qtsvg-5
            range-v3
            rlottie-for-telegram-desktop
            rnnoise
            webrtc-for-telegram-desktop
-           libx11
-           libxcb
-           xcb-util-keysyms
            xxhash
-           zlib))
-    (propagated-inputs (list dconf))
+           zlib
+           ;; DESKTOP_APP_DISABLE_DBUS_INTEGRATION
+           glibmm-2.64
+           ;; DESKTOP_APP_USE_ENCHANT
+           ;; enchant
+           ;; DESKTOP_APP_DISABLE_SPELLCHECK
+           hunspell
+           ;; DESKTOP_APP_LOTTIE_USE_CACHE
+           lz4
+           ;; DESKTOP_APP_DISABLE_WAYLAND_INTEGRATION
+           qtwayland wayland
+           ;; DESKTOP_APP_DISABLE_X11_INTEGRATION
+           libxcb xcb-util-keysyms
+           ;; Optional
+           webkitgtk))
     (synopsis "Telegram Desktop")
     (description "Telegram desktop is the official desktop version of the
 Telegram instant messenger.")
     (home-page "https://desktop.telegram.org/")
     (license
      (list
-      ;; ThirdParty
-      license:lgpl2.1+
+      ;; Telegram/ThirdParty/dispatch
+      license:asl2.0
+      ;; Telegram/ThirdParty/libtgvoip
+      license:unlicense
+      ;; Telegram/ThirdParty/tgcalls
+      license:lgpl3
       ;; Others
       license:gpl3+))))