@@ -2560,6 +2560,22 @@ (define-public go-golang-org-x-tools
(home-page "https://go.googlesource.com/tools/")
(license license:bsd-3))))
+(define-public gopls
+ (package
+ (inherit go-golang-org-x-tools)
+ (name "gopls")
+ (arguments
+ (list #:unpack-path "golang.org/x/tools"
+ #:import-path "golang.org/x/tools/gopls"
+ #:install-source? #f))
+ (inputs (list go-golang-org-x-sync))
+ (synopsis "Go language server implementation")
+ (description
+ "This package provides the @acronym{LSP, Language Server Protocol}
+server implementation for the Go programming language. It provides
+on-the-fly code linting, formatting, completion, and introspection for
+Go code in text editors supporting LSP.")))
+
(define-public go-golang-org-x-crypto
(let ((commit "2aa609cf4a9d7d1126360de73b55b6002f9e052a")
(revision "5"))