Message ID | 097e5d484b14e0777f26bfd5c34b76189b828b8c.1660115870.git.marcel@van-der-boom.nl |
---|---|
State | Accepted |
Headers | show |
Series | [bug#56884] Make x265 build on ppc64le | expand |
Context | Check | Description |
---|---|---|
cbaines/comparison | success | View comparision |
cbaines/git-branch | success | View Git branch |
cbaines/applying patch | success | View Laminar job |
cbaines/issue | success | View issue |
user guix usertag 56884 reviewed looks-good quit Hello Marcel, Marcel van der Boom <marcel@van-der-boom.nl> writes: > * gnu/packages/video.scm: disable ALTIVEC for target-ppc64le > > Build produces many errors. The altivec code needs adjusting each type of > POWER processor specifically. Thank you for the new version. This one looks good to me. I'm not a maintainer though, so we need to wait for one to chime in.
Hello, Thanks for reviewing Thiago. I fixed the indentation and edited the commit message before pushing. Mathieu
Hello Mathieu, Mathieu Othacehe <othacehe@gnu.org> writes: > Thanks for reviewing Thiago. I fixed the indentation and edited the > commit message before pushing. Thank you!
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm index 04049fd9c8..bf033c7d84 100644 --- a/gnu/packages/video.scm +++ b/gnu/packages/video.scm @@ -1252,6 +1252,10 @@ (define-public x265 ,@(if (target-aarch64?) '("-DENABLE_ASSEMBLY=OFF") '()) + ;; Altivec code produces many build errors + ,@(if (target-ppc64le?) + '("-DENABLE_ALTIVEC=OFF") + '()) "-DHIGH_BIT_DEPTH=ON" "-DEXPORT_C_API=OFF" "-DENABLE_CLI=OFF" @@ -1272,6 +1276,10 @@ (define-public x265 ,@(if (target-aarch64?) '("-DENABLE_ASSEMBLY=OFF") '()) + ;; Altivec code produces many build errors + ,@(if (target-ppc64le?) + '("-DENABLE_ALTIVEC=OFF") + '()) "-DHIGH_BIT_DEPTH=ON" "-DEXPORT_C_API=OFF" "-DENABLE_CLI=OFF"