Message ID | 20220809130706.7671-1-daniel.meissner-i4k@ruhr-uni-bochum.de |
---|---|
State | Accepted |
Headers | show |
Series | [bug#57074,v2] gnu: maxima: Fix to find info files. | expand |
Context | Check | Description |
---|---|---|
cbaines/comparison | success | View comparision |
cbaines/git-branch | success | View Git branch |
cbaines/applying patch | success | View Laminar job |
cbaines/issue | success | View issue |
On 09-08-2022 15:07, Daniel Meißner wrote: > The Maxima command ‘describe’ allows to pick the relevant portions from > Maxima’s Texinfo docs. However it does not support reading gzipped info > files. > > * gnu/packages/maths.scm (maxima)[arguments]<phases>: Delete > 'compress-documentation phase. > --- > > Thanks for the review, Maxime. Here's the updated patch. > > Best > Daniel > > gnu/packages/maths.scm | 6 +++++- > 1 file changed, 5 insertions(+), 1 deletion(-) > > diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm > index c10794a089..48c10906ed 100644 > --- a/gnu/packages/maths.scm > +++ b/gnu/packages/maths.scm > @@ -4420,7 +4420,11 @@ (define-public maxima > ;; components at runtime. > (wrap-program (string-append out "/bin/maxima") > `("PATH" prefix (,binutils)))) > - #t))))) > + #t)) > + ;; The Maxima command ‘describe’ allows to pick the relevant portions > + ;; from Maxima’s Texinfo docs. However it does not support reading > + ;; gzipped info files. > + (delete 'compress-documentation)))) > (home-page"https://maxima.sourceforge.io") > (synopsis "Numeric and symbolic expression manipulation") > (description "Maxima is a system for the manipulation of symbolic and To be clear, I did not verify the patch, but it looks fine to me. LGTM, Maxime.
Maxime Devos <maximedevos@telenet.be> writes: > On 09-08-2022 15:07, Daniel Meißner wrote: >> The Maxima command ‘describe’ allows to pick the relevant portions from >> Maxima’s Texinfo docs. However it does not support reading gzipped info >> files. >> >> * gnu/packages/maths.scm (maxima)[arguments]<phases>: Delete >> 'compress-documentation phase. >> --- >> >> Thanks for the review, Maxime. Here's the updated patch. >> Pushed, thank you!
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm index c10794a089..48c10906ed 100644 --- a/gnu/packages/maths.scm +++ b/gnu/packages/maths.scm @@ -4420,7 +4420,11 @@ (define-public maxima ;; components at runtime. (wrap-program (string-append out "/bin/maxima") `("PATH" prefix (,binutils)))) - #t))))) + #t)) + ;; The Maxima command ‘describe’ allows to pick the relevant portions + ;; from Maxima’s Texinfo docs. However it does not support reading + ;; gzipped info files. + (delete 'compress-documentation)))) (home-page "https://maxima.sourceforge.io") (synopsis "Numeric and symbolic expression manipulation") (description "Maxima is a system for the manipulation of symbolic and