diff mbox series

[bug#56984] gnu: ugrep: Use gexps and add zstd lib to inputs.

Message ID 20220805050959.344944-1-kiasoc5@disroot.org
State Accepted
Headers show
Series [bug#56984] gnu: ugrep: Use gexps and add zstd lib to inputs. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

kiasoc5 Aug. 5, 2022, 5:10 a.m. UTC
Last email had old version of patch, please use this one. Sorry paren
for using cc instead of reply-to.

* gnu/packages/search.scm (ugrep)[snippets]: Use gexps. Remove trailing #t.
[snippets]: Use gexps.
[arguments]: Likewise.
[inputs]: Add zstd lib.
---
 gnu/packages/search.scm | 33 +++++++++++++++++----------------
 1 file changed, 17 insertions(+), 16 deletions(-)

Comments

kiasoc5 Aug. 5, 2022, 5:14 a.m. UTC | #1
On Fri, Aug 05 2022, 01:10:00 AM -0400
kiasoc5 <kiasoc5@disroot.org> wrote:

> Last email had old version of patch, please use this one. Sorry paren
> for using cc instead of reply-to.

Also forgot to check my git-send email arguments. Sending to the
correct issue.

> * gnu/packages/search.scm (ugrep)[snippets]: Use gexps. Remove
> trailing #t. [snippets]: Use gexps.
> [arguments]: Likewise.
> [inputs]: Add zstd lib.
> ---
>  gnu/packages/search.scm | 33 +++++++++++++++++----------------
>  1 file changed, 17 insertions(+), 16 deletions(-)
> 
> diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
> index db5579a708..65a642c259 100644
> --- a/gnu/packages/search.scm
> +++ b/gnu/packages/search.scm
> @@ -32,6 +32,7 @@ (define-module (gnu packages search)
>    #:use-module (guix packages)
>    #:use-module (guix download)
>    #:use-module (guix git-download)
> +  #:use-module (guix gexp)
>    #:use-module (guix utils)
>    #:use-module (guix build-system gnu)
>    #:use-module (guix build-system perl)
> @@ -681,14 +682,12 @@ (define-public ugrep
>                (sha256
>                 (base32
> "03b3lahc3zzsznaqnrk47f1cnd5jwakvwrkz0r4m2crk09cpfv57")) (file-name
> (git-file-name name version))
> -              (modules '((guix build utils)))
> -              (snippet
> -               '(begin
> +              (snippet #~(begin
> +                  (use-modules (guix build utils))
>                    (delete-file-recursively "bin") ; pre-built
> executables (for-each delete-file (find-files "tests"
> "^archive\\..*")) (for-each delete-file (find-files "tests"
> "^.*\\.pdf$"))
> -                  (for-each delete-file (find-files "tests"
> "^.*\\.class$"))
> -                  #t))))
> +                  (for-each delete-file (find-files "tests"
> "^.*\\.class$")))))) (build-system gnu-build-system)
>      (inputs
>       (list bzip2
> @@ -696,18 +695,20 @@ (define-public ugrep
>             lz4
>             lzip ;; lzma
>             pcre2
> -           zlib))
> +           zlib
> +           `(,zstd "lib"))
>      (arguments
> -     `(#:tests? #f                  ; no way to rebuild the binary
> input files
> -       #:test-target "test"
> -       #:phases
> -       (modify-phases %standard-phases
> -         (add-before 'check 'check-setup
> -           (lambda _
> -             ;; Unpatch shebangs in tests.
> -             (substitute* '("tests/Hello.bat"
> -                            "tests/Hello.sh")
> -               (("#!/gnu/store/.*/bin/sh") "#!/bin/sh")))))))
> +     (list
> +      #:tests? #f                  ; no way to rebuild the binary
> input files
> +      #:test-target "test"
> +      #:phases
> +      #~(modify-phases %standard-phases
> +          (add-before 'check 'check-setup
> +            (lambda _
> +              ;; Unpatch shebangs in tests.
> +              (substitute* '("tests/Hello.bat"
> +                             "tests/Hello.sh")
> +                (("#!/gnu/store/.*/bin/sh") "#!/bin/sh")))))))
>      (home-page "https://github.com/Genivia/ugrep/")
>      (synopsis "Faster grep with an interactive query UI")
>      (description "Ugrep is a ultra fast searcher of file systems,
> text
Liliana Marie Prikler Aug. 5, 2022, 7:35 a.m. UTC | #2
Am Freitag, dem 05.08.2022 um 05:14 +0000 schrieb kiasoc5:

> Use gexps and add zstd lib to inputs.
Useful hint: If your patch title contains "and", it probably should be
a series of two or more patches.  😉️

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index db5579a708..65a642c259 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -32,6 +32,7 @@  (define-module (gnu packages search)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
+  #:use-module (guix gexp)
   #:use-module (guix utils)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system perl)
@@ -681,14 +682,12 @@  (define-public ugrep
               (sha256
                (base32 "03b3lahc3zzsznaqnrk47f1cnd5jwakvwrkz0r4m2crk09cpfv57"))
               (file-name (git-file-name name version))
-              (modules '((guix build utils)))
-              (snippet
-               '(begin
+              (snippet #~(begin
+                  (use-modules (guix build utils))
                   (delete-file-recursively "bin") ; pre-built executables
                   (for-each delete-file (find-files "tests" "^archive\\..*"))
                   (for-each delete-file (find-files "tests" "^.*\\.pdf$"))
-                  (for-each delete-file (find-files "tests" "^.*\\.class$"))
-                  #t))))
+                  (for-each delete-file (find-files "tests" "^.*\\.class$"))))))
     (build-system gnu-build-system)
     (inputs
      (list bzip2
@@ -696,18 +695,20 @@  (define-public ugrep
            lz4
            lzip ;; lzma
            pcre2
-           zlib))
+           zlib
+           `(,zstd "lib"))
     (arguments
-     `(#:tests? #f                  ; no way to rebuild the binary input files
-       #:test-target "test"
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'check-setup
-           (lambda _
-             ;; Unpatch shebangs in tests.
-             (substitute* '("tests/Hello.bat"
-                            "tests/Hello.sh")
-               (("#!/gnu/store/.*/bin/sh") "#!/bin/sh")))))))
+     (list
+      #:tests? #f                  ; no way to rebuild the binary input files
+      #:test-target "test"
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'check-setup
+            (lambda _
+              ;; Unpatch shebangs in tests.
+              (substitute* '("tests/Hello.bat"
+                             "tests/Hello.sh")
+                (("#!/gnu/store/.*/bin/sh") "#!/bin/sh")))))))
     (home-page "https://github.com/Genivia/ugrep/")
     (synopsis "Faster grep with an interactive query UI")
     (description "Ugrep is a ultra fast searcher of file systems, text