diff mbox series

[bug#56886,v2] gnu: queen-de: Fix build.

Message ID 20220804192349.5025-1-felgru@posteo.net
State Accepted
Headers show
Series [bug#56886,v2] gnu: queen-de: Fix build. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Felix Gruber Aug. 4, 2022, 7:23 p.m. UTC
* gnu/packages/games.scm (make-queen-package)[arguments]: Only install
  readme.txt if it exists. The queen-de package that we create with
  make-queen-package does not contain a readme file, while all the other
  versions of the queen package have a readme file.
---
 gnu/packages/games.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Liliana Marie Prikler Aug. 5, 2022, 6:15 a.m. UTC | #1
Am Donnerstag, dem 04.08.2022 um 19:23 +0000 schrieb Felix Gruber:
> * gnu/packages/games.scm (make-queen-package)[arguments]: Only
> install
>   readme.txt if it exists. The queen-de package that we create with
>   make-queen-package does not contain a readme file, while all the
> other
>   versions of the queen package have a readme file.
The explanation goes before the ChangeLog, also there ought to be a
link to this issue.  Other than that LGTM.
Liliana Marie Prikler Aug. 6, 2022, 2:55 p.m. UTC | #2
Am Donnerstag, dem 04.08.2022 um 19:23 +0000 schrieb Felix Gruber:
> * gnu/packages/games.scm (make-queen-package)[arguments]: Only
> install
>   readme.txt if it exists. The queen-de package that we create with
>   make-queen-package does not contain a readme file, while all the
> other
>   versions of the queen package have a readme file.
Pushed with a slight change to the ChangeLog.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 06084d1167..da722ade84 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9810,7 +9810,9 @@  Skorl.  Maybe it would be an idea to try and escape...")
            (let ((unzip (search-input-file %build-inputs "/bin/unzip")))
              (invoke unzip "-j" (assoc-ref %build-inputs "source")))
            (let ((doc (string-append share "/doc/" ,name "-" ,version)))
-             (install-file "readme.txt" doc))
+             (for-each (lambda (file)
+                         (when (file-exists? file) (install-file file doc)))
+                       '("readme.txt" "README" "README.md")))
            (install-file "queen.1c" data)
            (mkdir-p bin)
            (let ((bash (assoc-ref %build-inputs "bash")))