diff mbox series

[bug#56094,v3] gnu: wm: Switch sway from elogind to basu.

Message ID 20220622095249.15421-1-mail@muradm.net
State Accepted
Headers show
Series [bug#56094,v3] gnu: wm: Switch sway from elogind to basu. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

muradm June 22, 2022, 9:52 a.m. UTC
* gnu/packages/wm.scm (sway): Replace ‘elogind’ with ‘basu’.
[inputs]: Replace ‘elogind’ with ‘basu’.
[arguments]:
<#:configure-flags>: Request building against basu.
`elogind` still exists as transitive propagated input,
while `meson.build` auto detects by probing `systemd`,
`elogind` and `basu` in respective order.
---
 gnu/packages/wm.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

Comments

Liliana Marie Prikler June 22, 2022, 9:57 a.m. UTC | #1
Am Mittwoch, dem 22.06.2022 um 12:52 +0300 schrieb muradm:
> * gnu/packages/wm.scm (sway): Replace ‘elogind’ with ‘basu’.
> [inputs]: Replace ‘elogind’ with ‘basu’.
Collapse to (sway)[inputs].  No need to repeat yourself.
> [arguments]:
> <#:configure-flags>: Request building against basu.
Since we're at it, this should actually be "Add [the flag]".
> `elogind` still exists as transitive propagated input,
> while `meson.build` auto detects by probing `systemd`,
> `elogind` and `basu` in respective order.
In the source, not in the commit message :P
Can be shortened to "elogind is propagated by [input] and would
otherwise shadow basu".


Cheers
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index ecc79f73b9..7570e37239 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1572,7 +1572,8 @@  (define-public sway
         (base32 "0j4sdbsrlvky1agacc0pcz9bwmaxjmrapjnzscbd2i0cria2fc5j"))))
     (build-system meson-build-system)
     (arguments
-     `(#:phases
+     `(#:configure-flags '("-Dsd-bus-provider=basu")
+       #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'hardcode-paths
            (lambda* (#:key inputs #:allow-other-keys)
@@ -1587,8 +1588,8 @@  (define-public sway
                 (string-append "'" (assoc-ref inputs "scdoc")
                                "/bin/scdoc'")))
              #t)))))
-    (inputs (list cairo
-                  elogind
+    (inputs (list basu
+                  cairo
                   gdk-pixbuf
                   json-c
                   libevdev