diff mbox series

[bug#56094,v2] gnu: wm: Switch sway from elogind to basu.

Message ID 20220622092721.14170-2-mail@muradm.net
State Accepted
Headers show
Series [bug#56094,v2] gnu: wm: Switch sway from elogind to basu. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

muradm June 22, 2022, 9:27 a.m. UTC
* gnu/packages/wm.scm (basu): Switch sway from elogind to basu.
[inputs]: Replace elogind with basu for sd-bus library dependency.
[arguments]: Use G-expressions.
<#:configure-flags>: Request building against basu.
---
 gnu/packages/wm.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

Comments

Liliana Marie Prikler June 22, 2022, 9:31 a.m. UTC | #1
block 56094 by 56136
thanks

Am Mittwoch, dem 22.06.2022 um 12:27 +0300 schrieb muradm:
> * gnu/packages/wm.scm (basu): Switch sway from elogind to basu.
Should be sway.
> [inputs]: Replace elogind with basu for sd-bus library dependency.
This can be simplified to "Replace ‘elogind’ with ‘basu’."
> [arguments]: Use G-expressions.
Actually, you don't, and even if, that ought to be a separate commit.
> <#:configure-flags>: Request building against basu.
Is this necessary?  Doesn't sway have autodetection for basu?


Cheers
muradm June 22, 2022, 9:38 a.m. UTC | #2
Next one reflecting changes.

Yes, necessary to state basu explicitly, meson.build detects
like systemd -> elogind -> basu. While removed from sway
dependencies, elogind still comes from dependencies of
dependencies.

--
muradm

Liliana Marie Prikler <liliana.prikler@ist.tugraz.at> writes:

> block 56094 by 56136
> thanks
>
> Am Mittwoch, dem 22.06.2022 um 12:27 +0300 schrieb muradm:
>> * gnu/packages/wm.scm (basu): Switch sway from elogind to basu.
> Should be sway.
>> [inputs]: Replace elogind with basu for sd-bus library 
>> dependency.
> This can be simplified to "Replace ‘elogind’ with ‘basu’."
>> [arguments]: Use G-expressions.
> Actually, you don't, and even if, that ought to be a separate 
> commit.
>> <#:configure-flags>: Request building against basu.
> Is this necessary?  Doesn't sway have autodetection for basu?
>
>
> Cheers
Liliana Marie Prikler June 22, 2022, 9:47 a.m. UTC | #3
Am Mittwoch, dem 22.06.2022 um 12:38 +0300 schrieb muradm:
> Next one reflecting changes.
> 
> Yes, necessary to state basu explicitly, meson.build detects
> like systemd -> elogind -> basu. While removed from sway
> dependencies, elogind still comes from dependencies of
> dependencies.
We call that a transitive propagated input.  You should probably add a
comment that elogind "still exists" and justify your defensive
programming in there.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index ecc79f73b9..7570e37239 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1572,7 +1572,8 @@  (define-public sway
         (base32 "0j4sdbsrlvky1agacc0pcz9bwmaxjmrapjnzscbd2i0cria2fc5j"))))
     (build-system meson-build-system)
     (arguments
-     `(#:phases
+     `(#:configure-flags '("-Dsd-bus-provider=basu")
+       #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'hardcode-paths
            (lambda* (#:key inputs #:allow-other-keys)
@@ -1587,8 +1588,8 @@  (define-public sway
                 (string-append "'" (assoc-ref inputs "scdoc")
                                "/bin/scdoc'")))
              #t)))))
-    (inputs (list cairo
-                  elogind
+    (inputs (list basu
+                  cairo
                   gdk-pixbuf
                   json-c
                   libevdev