diff mbox series

[bug#56094] gnu: Remove unnecessary sway dependency on elogind.

Message ID 20220619143905.29089-1-mail@muradm.net
State Accepted
Headers show
Series [bug#56094] gnu: Remove unnecessary sway dependency on elogind. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

muradm June 19, 2022, 2:39 p.m. UTC
* gnu/packages/wm.scm (sway): Cleanup dependencies.
---
 gnu/packages/wm.scm | 1 -
 1 file changed, 1 deletion(-)

Comments

Liliana Marie Prikler June 20, 2022, 9:36 a.m. UTC | #1
Hi,

note that "unnecessary" is quite judgmental.  Why is it unnecessary?
By default, guix tends to include "optional" inputs such as elogind.

Am Sonntag, dem 19.06.2022 um 17:39 +0300 schrieb muradm:
> * gnu/packages/wm.scm (sway): Cleanup dependencies.
The ChangeLog should explicitly say what is done, i.e. (sway)[inputs]:
Remove elogind.


What exactly is the goal here?  As far as I'm aware sway works either
with *logind or seatd or by having itself be setuid.  If the aim is to
support seatd-based services, I think having a sway-with-seatd variant
would be better.

WDYT?
muradm June 20, 2022, 10:51 a.m. UTC | #2
Hi,

elogind/systemd was used via wlroots actually.
wlroots dropped elogind/system in favour of libseat.
libseat can talk to either systemd, elogind or seatd.
this is already reflected in wlroots package.

setuid thing you point is reflected as warning in meson.build.
there is no functionality behind it as far as I know.
and in 1.7 meson does not look at them directly, but via wlroots.
basically informative from sway point of view.

the only thing left behind is swaybar which relays on
either systemd, elogind or basu for system tray functionality.
this could be used as argument for keeping elogind
as dependency.

you may look at #49969 which added the other day
seatd-service-type and greetd stuff.

--
muradm

Liliana Marie Prikler <liliana.prikler@ist.tugraz.at> writes:

> Hi,
>
> note that "unnecessary" is quite judgmental.  Why is it 
> unnecessary?
> By default, guix tends to include "optional" inputs such as 
> elogind.
>
> Am Sonntag, dem 19.06.2022 um 17:39 +0300 schrieb muradm:
>> * gnu/packages/wm.scm (sway): Cleanup dependencies.
> The ChangeLog should explicitly say what is done, i.e. 
> (sway)[inputs]:
> Remove elogind.
>
>
> What exactly is the goal here?  As far as I'm aware sway works 
> either
> with *logind or seatd or by having itself be setuid.  If the aim 
> is to
> support seatd-based services, I think having a sway-with-seatd 
> variant
> would be better.
>
> WDYT?
Liliana Marie Prikler June 21, 2022, 7:12 p.m. UTC | #3
Am Montag, dem 20.06.2022 um 13:51 +0300 schrieb muradm:
> the only thing left behind is swaybar which relays on
> either systemd, elogind or basu for system tray functionality.
> this could be used as argument for keeping elogind
> as dependency.
I think the way forward would be to package basu and replace elogind
with it, rather than drop it and breaking swaybar.  WDYT?
muradm June 22, 2022, 9:27 a.m. UTC | #4
Should be applied after #56136.
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index d816bad871..875f73bfe2 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1588,7 +1588,6 @@  (define-public sway
                                "/bin/scdoc'")))
              #t)))))
     (inputs (list cairo
-                  elogind
                   gdk-pixbuf
                   json-c
                   libevdev