diff mbox series

[bug#53007] gnu: networking: Add arp-scan

Message ID 20220620214129.11815-1-manolis837@gmail.com
State Accepted
Headers show
Series [bug#53007] gnu: networking: Add arp-scan | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Manolis Ragkousis June 20, 2022, 9:41 p.m. UTC
From: Manolis Ragkousis <manolis837@gmail.com>

* gnu/packages/networking.scm (arp-scan): New variable.
---
 gnu/packages/networking.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Christopher Baines June 21, 2022, 11:41 a.m. UTC | #1
manolis837@gmail.com writes:

> From: Manolis Ragkousis <manolis837@gmail.com>
>
> * gnu/packages/networking.scm (arp-scan): New variable.
> ---
>  gnu/packages/networking.scm | 29 +++++++++++++++++++++++++++++
>  1 file changed, 29 insertions(+)

I moved this new package off the bottom of the file, and pushed this as
0fe0c739f53bbb635eb5c4a3b172f4be45293c82.

Thanks,

Chris
\( June 25, 2022, 10:37 a.m. UTC | #2
LGTM. I was going to raise the point that 1.9.7 was in 2019, and the
latest commit at the time of writing was made on 2022-06-16, but it
looks like there's not been too many commits between 7f88dc0 "Increment
version to 1.9.7 in preparation for next release." and 840373f "Updated
changelog and IEEE IAB and OUI files."

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 065a190321..cb384f23bb 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -50,6 +50,7 @@ 
 ;;; Copyright © 2022 Simon South <simon@simonsouth.net>
 ;;; Copyright © 2022 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2022 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4259,3 +4260,31 @@  (define-public putty
 implementations.")
     (home-page "https://www.chiark.greenend.org.uk/~sgtatham/putty/")
     (license license:expat)))
+
+(define-public arp-scan
+  (package
+    (name "arp-scan")
+    (version "1.9.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/royhills/arp-scan/")
+         (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1mf7a4f9vzvnkiavc87aqyciswggsb4fpy7j05jxnvjyyxv3l7gp"))))
+    (build-system gnu-build-system)
+    (inputs
+     (list libpcap))
+    (native-inputs
+     (list autoconf automake libtool pkg-config))
+    (propagated-inputs
+     (list perl-libwww))
+    (home-page "https://github.com/royhills/arp-scan")
+    (synopsis "Discover and fingerprint IP hosts on the local network
+ using ARP")
+    (description "Arp-scan is a tool that uses ARP to discover and fingerprint IP hosts
+on the local network.")
+    (license license:gpl3+)))