diff mbox series

[bug#56057,bug,#56057,v2,14/21] gnu: Add rust-open-3.

Message ID 20220619172711.3413-15-antlers@luris.net
State New
Headers show
Series [bug#56057,bug,#56057,v2,01/21] gnu: Add rust-addr2line-0.17. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

antlers June 19, 2022, 5:27 p.m. UTC
* gnu/packages/crates-io.scm (rust-open-3): New variable.
(rust-open-2): Inherit from rust-open-3.
---
:100644 100644 9a44c3a846 83be540cf7 M	gnu/packages/crates-io.scm
 gnu/packages/crates-io.scm | 34 ++++++++++++++++++++++++++--------
 1 file changed, 26 insertions(+), 8 deletions(-)

Comments

EHarding830 June 19, 2022, 5:49 p.m. UTC | #1
Note to Self (Whoopsies #2 & 3): Thought I dropped this patch (otherwise looks like I sent the right patchset..? Bad smell.), and should still double check that I didn't remove any #:skip-build flags.

----------------------------------------

Jun 19, 2022 10:27:57 AM antlers <autumnalantlers@gmail.com>:

> * gnu/packages/crates-io.scm (rust-open-3): New variable.
> (rust-open-2): Inherit from rust-open-3.
> ---
> :100644 100644 9a44c3a846 83be540cf7 M  gnu/packages/crates-io.scm
> gnu/packages/crates-io.scm | 34 ++++++++++++++++++++++++++--------
> 1 file changed, 26 insertions(+), 8 deletions(-)
> 
> diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
> index 9a44c3a846..83be540cf7 100644
> --- a/gnu/packages/crates-io.scm
> +++ b/gnu/packages/crates-io.scm
> @@ -39686,29 +39686,47 @@ (define-public rust-opaque-debug-0.2
>          (base32
>           "02942l2gc7w5r4js7i9063x99szic5mzzk1055j83v4diqpbpxck"))))))
> 
> +(define-public rust-open-3
> +  (package
> +    (name "rust-open")
> +    (version "3.0.1")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (crate-uri "open" version))
> +              (file-name (string-append name "-" version ".tar.gz"))
> +              (sha256
> +               (base32
> +                "1zhhz4a9ag0418cmj0ky11xidpcavv2crhsl76m66qxz2s1wq2rn"))))
> +    (build-system cargo-build-system)
> +    (arguments
> +     `(#:skip-build? #t
> +       #:cargo-inputs
> +       (("rust-pathdiff" ,rust-pathdiff-0.2))))
> +    (home-page "https://github.com/Byron/open-rs")
> +    (synopsis "Open a path or URL using the program configured on the system")
> +    (description
> +     "Use this library to open a path or URL using the program configured on
> +the system.")
> +    (license license:expat)))
> +
> (define-public rust-open-2
>    (package
> +    (inherit rust-open-3)
>      (name "rust-open")
>      (version "2.0.2")
>      (source
>       (origin
> +       (inherit (package-source rust-open-3))
>         (method url-fetch)
>         (uri (crate-uri "open" version))
>         (file-name (string-append name "-" version ".tar.gz"))
>         (sha256
>          (base32 "1dq9c6dgq7iv5kvqfk8gvkfq34j5pdinfcs1hbdd4x6i62vf8vhp"))))
> -    (build-system cargo-build-system)
>      (arguments
>       `(#:skip-build? #t
>         #:cargo-inputs
>         (("rust-pathdiff" ,rust-pathdiff-0.2)
> -        ("rust-winapi" ,rust-winapi-0.3))))
> -    (home-page "https://github.com/Byron/open-rs")
> -    (synopsis "Open a path or URL using the program configured on the system")
> -    (description
> -     "Use this library to open a path or URL using the program configured on
> -the system.")
> -    (license license:expat)))
> +        ("rust-winapi" ,rust-winapi-0.3))))))
> 
> (define-public rust-open-1
>    (package
> -- 
> 2.36.0
antlers June 20, 2022, 5:22 a.m. UTC | #2
> Thought I dropped this patch (otherwise looks like I sent the right patchset [...])
That would have been rust-clap, not rust-open.

On Sun, Jun 19, 2022 at 10:49 AM EHarding830 <eharding830@gmail.com> wrote:
>
> Note to Self (Whoopsies #2 & 3): Thought I dropped this patch (otherwise looks like I sent the right patchset..? Bad smell.), and should still double check that I didn't remove any #:skip-build flags.
>
> ----------------------------------------
>
> Jun 19, 2022 10:27:57 AM antlers <autumnalantlers@gmail.com>:
>
> > * gnu/packages/crates-io.scm (rust-open-3): New variable.
> > (rust-open-2): Inherit from rust-open-3.
> > ---
> > :100644 100644 9a44c3a846 83be540cf7 M  gnu/packages/crates-io.scm
> > gnu/packages/crates-io.scm | 34 ++++++++++++++++++++++++++--------
> > 1 file changed, 26 insertions(+), 8 deletions(-)
> >
> > diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
> > index 9a44c3a846..83be540cf7 100644
> > --- a/gnu/packages/crates-io.scm
> > +++ b/gnu/packages/crates-io.scm
> > @@ -39686,29 +39686,47 @@ (define-public rust-opaque-debug-0.2
> >          (base32
> >           "02942l2gc7w5r4js7i9063x99szic5mzzk1055j83v4diqpbpxck"))))))
> >
> > +(define-public rust-open-3
> > +  (package
> > +    (name "rust-open")
> > +    (version "3.0.1")
> > +    (source (origin
> > +              (method url-fetch)
> > +              (uri (crate-uri "open" version))
> > +              (file-name (string-append name "-" version ".tar.gz"))
> > +              (sha256
> > +               (base32
> > +                "1zhhz4a9ag0418cmj0ky11xidpcavv2crhsl76m66qxz2s1wq2rn"))))
> > +    (build-system cargo-build-system)
> > +    (arguments
> > +     `(#:skip-build? #t
> > +       #:cargo-inputs
> > +       (("rust-pathdiff" ,rust-pathdiff-0.2))))
> > +    (home-page "https://github.com/Byron/open-rs")
> > +    (synopsis "Open a path or URL using the program configured on the system")
> > +    (description
> > +     "Use this library to open a path or URL using the program configured on
> > +the system.")
> > +    (license license:expat)))
> > +
> > (define-public rust-open-2
> >    (package
> > +    (inherit rust-open-3)
> >      (name "rust-open")
> >      (version "2.0.2")
> >      (source
> >       (origin
> > +       (inherit (package-source rust-open-3))
> >         (method url-fetch)
> >         (uri (crate-uri "open" version))
> >         (file-name (string-append name "-" version ".tar.gz"))
> >         (sha256
> >          (base32 "1dq9c6dgq7iv5kvqfk8gvkfq34j5pdinfcs1hbdd4x6i62vf8vhp"))))
> > -    (build-system cargo-build-system)
> >      (arguments
> >       `(#:skip-build? #t
> >         #:cargo-inputs
> >         (("rust-pathdiff" ,rust-pathdiff-0.2)
> > -        ("rust-winapi" ,rust-winapi-0.3))))
> > -    (home-page "https://github.com/Byron/open-rs")
> > -    (synopsis "Open a path or URL using the program configured on the system")
> > -    (description
> > -     "Use this library to open a path or URL using the program configured on
> > -the system.")
> > -    (license license:expat)))
> > +        ("rust-winapi" ,rust-winapi-0.3))))))
> >
> > (define-public rust-open-1
> >    (package
> > --
> > 2.36.0
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 9a44c3a846..83be540cf7 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -39686,29 +39686,47 @@  (define-public rust-opaque-debug-0.2
         (base32
          "02942l2gc7w5r4js7i9063x99szic5mzzk1055j83v4diqpbpxck"))))))
 
+(define-public rust-open-3
+  (package
+    (name "rust-open")
+    (version "3.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "open" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1zhhz4a9ag0418cmj0ky11xidpcavv2crhsl76m66qxz2s1wq2rn"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-pathdiff" ,rust-pathdiff-0.2))))
+    (home-page "https://github.com/Byron/open-rs")
+    (synopsis "Open a path or URL using the program configured on the system")
+    (description
+     "Use this library to open a path or URL using the program configured on
+the system.")
+    (license license:expat)))
+
 (define-public rust-open-2
   (package
+    (inherit rust-open-3)
     (name "rust-open")
     (version "2.0.2")
     (source
      (origin
+       (inherit (package-source rust-open-3))
        (method url-fetch)
        (uri (crate-uri "open" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "1dq9c6dgq7iv5kvqfk8gvkfq34j5pdinfcs1hbdd4x6i62vf8vhp"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
        #:cargo-inputs
        (("rust-pathdiff" ,rust-pathdiff-0.2)
-        ("rust-winapi" ,rust-winapi-0.3))))
-    (home-page "https://github.com/Byron/open-rs")
-    (synopsis "Open a path or URL using the program configured on the system")
-    (description
-     "Use this library to open a path or URL using the program configured on
-the system.")
-    (license license:expat)))
+        ("rust-winapi" ,rust-winapi-0.3))))))
 
 (define-public rust-open-1
   (package