diff mbox series

[bug#49969,v10,1/7] gnu: crates-io: Add rust-enquote 1.1.0 and rust-pam-sys 0.5.6.

Message ID 20220613084604.2575-2-mail@muradm.net
State Accepted
Headers show
Series Re: [bug#49969] [PATCH v9 4/7] gnu: base: Add greetd-service-type. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

muradm June 13, 2022, 8:45 a.m. UTC
* gnu/packages/crates-io.scm (rust-enquote-1): New variable
* gnu/packages/crates-io.scm (rust-pam-sys-0.5): New variable
---
 gnu/packages/crates-io.scm | 40 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)

Comments

M June 13, 2022, 1:20 p.m. UTC | #1
* gnu/packages/crates-io.scm (rust-enquote-1): New variable
* gnu/packages/crates-io.scm (rust-pam-sys-0.5): New variable

Only a single independent change per patch.

muradm schreef op ma 13-06-2022 om 11:45 [+0300]:
> +    (native-inputs `(("linux-pam" ,linux-pam)))

Most likely not a native input but a non-native input that needs to be
cross-compiled when rust-pam-sys is cross-compiled.

> +    (synopsis
> +     "Rust FFI wrappers for the Linux Pluggable Authentication Modules (PAM)")
> +    (description
> +     "Rust FFI wrappers for the Linux Pluggable Authentication Modules (PAM)")

Description is missing, this just repeats the synopsis.

Greetings,
Maxime.
muradm June 15, 2022, 6:54 a.m. UTC | #2
Hi, is there anything else needed to be updated for merging?

Thanks in advance,
muradm

muradm <mail@muradm.net> writes:

> Fixing as suggested:
> * splitting rust packages to commit per package
> * linux-pam should be in 'inputs
> * varying description
>
> Thanks in advance,
> muradm
>
> muradm (8):
>   gnu: crates-io: Add rust-enquote 1.1.0.
>   gnu: crates-io: Add rust-pam-sys 0.5.6.
>   gnu: admin: Add greetd 0.8.0.
>   gnu: admin: Add greetd-pam-mount.
>   gnu: base: Add greetd-service-type.
>   gnu: admin: Add libseat 0.8.0 and move seatd.
>   gnu: desktop: Add seatd-service-type.
>   gnu: tests: Add seatd/greetd based minimal desktop system 
>   tests.
>
>  doc/guix.texi                | 183 ++++++++++++++++++++++++++++
>  gnu/packages/admin.scm       | 162 +++++++++++++++++++++++++
>  gnu/packages/crates-io.scm   |  40 +++++++
>  gnu/packages/freedesktop.scm |  29 -----
>  gnu/packages/wm.scm          |   4 +-
>  gnu/services/base.scm        | 223 
>  ++++++++++++++++++++++++++++++++++-
>  gnu/services/desktop.scm     |  62 +++++++++-
>  gnu/services/pam-mount.scm   |   2 +-
>  gnu/tests/desktop.scm        | 212 
>  ++++++++++++++++++++++++++++++++-
>  9 files changed, 883 insertions(+), 34 deletions(-)
Lars-Dominik Braun June 15, 2022, 8:28 a.m. UTC | #3
Hi,

> Hi, is there anything else needed to be updated for merging?
any chance of getting that system test working? It currently backtraces for me:

---snip---
Backtrace:
           4 (primitive-load "/gnu/store/wwbnxhlshbw39amrwcwbq4i8rkw?")
In ice-9/eval.scm:
   191:35  3 (_ #f)
   196:35  2 (_ #f)
    263:9  1 (_ #(#(#<directory (guile-user) 7ffff1fd3c80>) #f))
    155:9  0 (_ _)

ice-9/eval.scm:155:9: In procedure struct-vtable: Wrong type argument in position 1 (expecting struct): #f
---snap---

Lars
muradm June 16, 2022, 4:19 p.m. UTC | #4
Hi, is there anything else needed to be updated for merging?

Thanks in advance,
Muradm

muradm <mail@muradm.net> writes:

> system test now ends as required
>
> muradm (8):
>   gnu: crates-io: Add rust-enquote 1.1.0.
>   gnu: crates-io: Add rust-pam-sys 0.5.6.
>   gnu: admin: Add greetd 0.8.0.
>   gnu: admin: Add greetd-pam-mount.
>   gnu: base: Add greetd-service-type.
>   gnu: admin: Add libseat 0.8.0 and move seatd.
>   gnu: desktop: Add seatd-service-type.
>   gnu: tests: Add seatd/greetd based minimal desktop system 
>   tests.
>
>  doc/guix.texi                | 183 ++++++++++++++++++++++++++++
>  gnu/packages/admin.scm       | 162 +++++++++++++++++++++++++
>  gnu/packages/crates-io.scm   |  40 +++++++
>  gnu/packages/freedesktop.scm |  29 -----
>  gnu/packages/wm.scm          |   4 +-
>  gnu/services/base.scm        | 223 
>  ++++++++++++++++++++++++++++++++++-
>  gnu/services/desktop.scm     |  62 +++++++++-
>  gnu/services/pam-mount.scm   |   2 +-
>  gnu/tests/desktop.scm        | 212 
>  ++++++++++++++++++++++++++++++++-
>  9 files changed, 883 insertions(+), 34 deletions(-)
Lars-Dominik Braun June 17, 2022, 8:47 a.m. UTC | #5
Hi,

> Hi, is there anything else needed to be updated for merging?
looks good to me. Merged.

d6dda325c10a4aa8605fefa3906066ce792c2e81 gnu: desktop: Add seatd-service-type.
167b8f29b3679a23bb20f5ed4181738c389d9d89 gnu: admin: Add libseat 0.8.0 and move seatd.
530e0f02606a0e04818bdd792bb5239f7ee9e637 gnu: base: Add greetd-service-type.
32ca068cb9f98698bd1c29b980ecd4ae36caf795 gnu: admin: Add greetd-pam-mount.
c08d56a161d1308e7c021acec3a57c3f559137de gnu: admin: Add greetd 0.8.0.
7943f9f170f099b3cae78cc897d4ac68649d03ee gnu: crates-io: Add rust-pam-sys 0.5.6.
7f7a075c3debc92168db7dbdf9a2a1ef3156b0ea gnu: crates-io: Add rust-enquote 1.1.0.

Cheers,
Lars
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 86313f5e4f..9374601bb4 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -19,6 +19,7 @@ 
 ;;; Copyright © 2021 Antero Mejr <antero@kodmin.com>
 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 muradm <mail@muradm.net>
 ;;; Copyright © 2021, 2022 Petr Hodina <phodina@protonmail.com>
 ;;; Copyright © 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2021 Jacob Hrbek <kreyren@rixotstudio.cz>
@@ -73053,3 +73054,42 @@  (define-public rust-shell2batch-0.4
 and automatically convert it to a windows batch file, this library provides a
 way to convert simple shell commands to windows batch commands.")
     (license license:asl2.0)))
+
+(define-public rust-enquote-1
+  (package
+    (name "rust-enquote")
+    (version "1.1.0")
+    (home-page "https://github.com/reujab/enquote")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "enquote" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0clrjghlfkkb7sndabs5wch0fz2nif6nj4b117s8kqxx3nqnrhq6"))))
+    (build-system cargo-build-system)
+    (synopsis "Rust library that quotes, unquotes, and unescapes strings")
+    (description "A Rust library quotes, unquotes, and unescapes strings")
+    (license license:unlicense)))
+
+(define-public rust-pam-sys-0.5
+  (package
+    (name "rust-pam-sys")
+    (version "0.5.6")
+    (home-page "https://github.com/1wilkens/pam-sys")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "pam-sys" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0d14501d5vybjnzxfjf96321xa5wa36x1xvf02h02zq938qmhj6d"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-libc" ,rust-libc-0.2))))
+    (native-inputs `(("linux-pam" ,linux-pam)))
+    (synopsis
+     "Rust FFI wrappers for the Linux Pluggable Authentication Modules (PAM)")
+    (description
+     "Rust FFI wrappers for the Linux Pluggable Authentication Modules (PAM)")
+    (license (list license:expat license:asl2.0))))