diff mbox series

[bug#55976] gnu: valgrind/interactive: Update to 3.19.0.

Message ID 59a90121e4006f727752b7fee50ec9365be47134.1655220225.git.code@greghogan.com
State New
Headers show
Series [bug#55976] gnu: valgrind/interactive: Update to 3.19.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan June 14, 2022, 3:38 p.m. UTC
* gnu/packages/valgrind.scm (valgrind/interactive): Update to 3.19.0.
[home-page]: Update permanent redirect.
* gnu/packages/valgrind.scm (valgrind-3.18): Delete.
---
This patch bumps the version of the non-hidden valgrind while removing
the pinned-version package. Looking through the commit history, I do see
a reason for having both a valgrind/interactive and valgrind-3.18.

$ ./pre-inst-env guix refresh -l valgrind
No dependents other than itself: valgrind@3.19.0

 gnu/packages/valgrind.scm | 20 +++-----------------
 1 file changed, 3 insertions(+), 17 deletions(-)

Comments

Tobias Geerinckx-Rice June 14, 2022, 9:19 p.m. UTC | #1
Hi Greg,

Greg Hogan 写道:
> * gnu/packages/valgrind.scm (valgrind/interactive): Update to 
> 3.19.0.
> [home-page]: Update permanent redirect.
> * gnu/packages/valgrind.scm (valgrind-3.18): Delete.
> ---
> This patch bumps the version of the non-hidden valgrind while 
> removing
> the pinned-version package.

Unless I'm mistaken these 2 tasks are independent, and should 
hence be split across 2 patches.

>                             Looking through the commit history, 
>                             I do see
> a reason for having both a valgrind/interactive and 
> valgrind-3.18.

I thought this was a typo for ‘don't’ at first, but I really can't 
tell.

I don't see a reason to keep both now, but then I don't see one 
when 50f7402c was committed either.  Do you remember, Ludo'?

Kind regards,

T G-R
Greg Hogan June 15, 2022, 1:55 p.m. UTC | #2
On Tue, Jun 14, 2022 at 5:29 PM Tobias Geerinckx-Rice <me@tobias.gr> wrote:
>
> Hi Greg,
>
> Greg Hogan 写道:
> > * gnu/packages/valgrind.scm (valgrind/interactive): Update to
> > 3.19.0.
> > [home-page]: Update permanent redirect.
> > * gnu/packages/valgrind.scm (valgrind-3.18): Delete.
> > ---
> > This patch bumps the version of the non-hidden valgrind while
> > removing
> > the pinned-version package.
>
> Unless I'm mistaken these 2 tasks are independent, and should
> hence be split across 2 patches.

I will split the commit and send a v2 patchset upon confirmation of
the valgrind-3.18 removal..

> >                             Looking through the commit history,
> >                             I do see
> > a reason for having both a valgrind/interactive and
> > valgrind-3.18.
>
> I thought this was a typo for ‘don't’ at first, but I really can't
> tell.

You are correct, this should have said "don't see a reason".

> I don't see a reason to keep both now, but then I don't see one
> when 50f7402c was committed either.  Do you remember, Ludo'?
>
> Kind regards,
>
> T G-R

Thanks for the review!

Greg
Greg Hogan Nov. 7, 2022, 6:36 p.m. UTC | #3
24 October 2022: valgrind-3.20.0 is available.

On Wed, Jun 15, 2022 at 9:55 AM Greg Hogan <code@greghogan.com> wrote:
>
> On Tue, Jun 14, 2022 at 5:29 PM Tobias Geerinckx-Rice <me@tobias.gr> wrote:
> >
> > Hi Greg,
> >
> > Greg Hogan 写道:
> > > * gnu/packages/valgrind.scm (valgrind/interactive): Update to
> > > 3.19.0.
> > > [home-page]: Update permanent redirect.
> > > * gnu/packages/valgrind.scm (valgrind-3.18): Delete.
> > > ---
> > > This patch bumps the version of the non-hidden valgrind while
> > > removing
> > > the pinned-version package.
> >
> > Unless I'm mistaken these 2 tasks are independent, and should
> > hence be split across 2 patches.
>
> I will split the commit and send a v2 patchset upon confirmation of
> the valgrind-3.18 removal..
>
> > >                             Looking through the commit history,
> > >                             I do see
> > > a reason for having both a valgrind/interactive and
> > > valgrind-3.18.
> >
> > I thought this was a typo for ‘don't’ at first, but I really can't
> > tell.
>
> You are correct, this should have said "don't see a reason".
>
> > I don't see a reason to keep both now, but then I don't see one
> > when 50f7402c was committed either.  Do you remember, Ludo'?
> >
> > Kind regards,
> >
> > T G-R
>
> Thanks for the review!
>
> Greg
diff mbox series

Patch

diff --git a/gnu/packages/valgrind.scm b/gnu/packages/valgrind.scm
index 63524d59e9..8e9a4c39f4 100644
--- a/gnu/packages/valgrind.scm
+++ b/gnu/packages/valgrind.scm
@@ -79,7 +79,7 @@  (define-public valgrind
                #t))))))
     (native-inputs
      (list perl))
-    (home-page "https://www.valgrind.org/")
+    (home-page "https://valgrind.org/")
     (synopsis "Debugging and profiling tool suite")
     (description
      "Valgrind is an instrumentation framework for building dynamic analysis
@@ -96,7 +96,7 @@  (define-public valgrind
 (define-public valgrind/interactive
   (package/inherit
    valgrind
-   (version "3.17.0")
+   (version "3.19.0")
    (source (origin
              (method url-fetch)
              (uri (list (string-append "https://sourceware.org/pub/valgrind"
@@ -105,7 +105,7 @@  (define-public valgrind/interactive
                                        "/valgrind-" version ".tar.bz2")))
              (sha256
               (base32
-               "18l5jbk301j3462gipqn9bkfx44mdmwn0pwr73r40gl1irkfqfmd"))
+               "00lgfgb38xbrilkw6xvqk284dcnnnhbcq03kpvvkyj0sdx438pnx"))
              (patches (search-patches
                        "valgrind-enable-arm.patch"
                        "valgrind-fix-default-debuginfo-path.patch"))))
@@ -148,17 +148,3 @@  (define-public valgrind/interactive
                       (string-length "/usr/lib/debug")
                       1))))))))))
    (properties '())))
-
-(define-public valgrind-3.18
-  (package
-    (inherit valgrind/interactive)
-    (version "3.18.1")
-    (source (origin
-              (inherit (package-source valgrind/interactive))
-              (uri (list (string-append "https://sourceware.org/pub/valgrind"
-                                        "/valgrind-" version ".tar.bz2")
-                         (string-append "ftp://sourceware.org/pub/valgrind"
-                                        "/valgrind-" version ".tar.bz2")))
-              (sha256
-               (base32
-                "1xgph509i6adv9w2glviw3xrmlz0dssg8992hbvxsbkp7ahrm180"))))))