[bug#55617,0/2] gnu: rsync: Update to 3.2.4.
Commit Message
On Wed, May 25, 2022 at 10:42 AM Maxime Devos <maximedevos@telenet.be> wrote:
>
> Greg Hogan schreef op di 24-05-2022 om 15:52 [-0400]:
> > + (modify-phases %standard-phases
> > + (add-before 'configure 'patch-build-flags
> > + ;; Fix for change to warnings in GCC 10+ causing
> > + ;; "error: argument 1 null where non-null expected [-
> > Werror=nonnull]"
> > + (lambda _
> > + (substitute* "meson.build" (("-Werror=format=2")
> > "")))))))
>
> This warning can easily indicate a real bug, has it been reported
> upstream?
It was reported upstream in 2017 but after the latest release. I have
removed that substitute from the attached, updated patchset since I
had overlooked that this change is not needed when building against
the latest commit.
> Greetings,
> Maxime.
Comments
Hi,
Greg Hogan <code@greghogan.com> skribis:
> From ecaee327cfb0edcb663bb00d32a04a0da2d78ceb Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Tue, 3 May 2022 17:55:02 +0000
> Subject: [PATCH 1/2] gnu: rsync: Update to 3.2.4.
>
> * gnu/packages/rsync.scm (rsync): Update to 3.2.4.
[...]
> From 208b49b03614d6412447e01b06ca8026de6dd668 Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Tue, 3 May 2022 17:54:16 +0000
> Subject: [PATCH 2/2] gnu: casync: Update to 99559cd1.
>
> * gnu/packages/sync.scm (casync): Update to 99559cd1.
> [source]: Remove patch.
> [arguments]: Fix installation.
> [native-inputs]: Add python.
> [inputs]: Add eudev.
> * gnu/packages/patches/casync-renameat2-declaration.patch: Delete file.
> * gnu/local.mk: Remove it.
Applied, thanks!
Ludo’.
Hi,
Greg Hogan <code@greghogan.com> skribis:
> From ecaee327cfb0edcb663bb00d32a04a0da2d78ceb Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Tue, 3 May 2022 17:55:02 +0000
> Subject: [PATCH 1/2] gnu: rsync: Update to 3.2.4.
>
> * gnu/packages/rsync.scm (rsync): Update to 3.2.4.
[...]
> From 208b49b03614d6412447e01b06ca8026de6dd668 Mon Sep 17 00:00:00 2001
> From: Greg Hogan <code@greghogan.com>
> Date: Tue, 3 May 2022 17:54:16 +0000
> Subject: [PATCH 2/2] gnu: casync: Update to 99559cd1.
>
> * gnu/packages/sync.scm (casync): Update to 99559cd1.
> [source]: Remove patch.
> [arguments]: Fix installation.
> [native-inputs]: Add python.
> [inputs]: Add eudev.
> * gnu/packages/patches/casync-renameat2-declaration.patch: Delete file.
> * gnu/local.mk: Remove it.
Applied, thanks!
Ludo’.
From 208b49b03614d6412447e01b06ca8026de6dd668 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Tue, 3 May 2022 17:54:16 +0000
Subject: [PATCH 2/2] gnu: casync: Update to 99559cd1.
* gnu/packages/sync.scm (casync): Update to 99559cd1.
[source]: Remove patch.
[arguments]: Fix installation.
[native-inputs]: Add python.
[inputs]: Add eudev.
* gnu/packages/patches/casync-renameat2-declaration.patch: Delete file.
* gnu/local.mk: Remove it.
---
gnu/local.mk | 1 -
.../casync-renameat2-declaration.patch | 27 --------
gnu/packages/sync.scm | 67 ++++++++++---------
3 files changed, 37 insertions(+), 58 deletions(-)
delete mode 100644 gnu/packages/patches/casync-renameat2-declaration.patch
@@ -926,7 +926,6 @@ dist_patch_DATA = \
%D%/packages/patches/calibre-no-updates-dialog.patch \
%D%/packages/patches/calibre-remove-test-sqlite.patch \
%D%/packages/patches/calibre-remove-test-unrar.patch \
- %D%/packages/patches/casync-renameat2-declaration.patch \
%D%/packages/patches/catdoc-CVE-2017-11110.patch \
%D%/packages/patches/circos-remove-findbin.patch \
%D%/packages/patches/cdparanoia-fpic.patch \
deleted file mode 100644
@@ -1,27 +0,0 @@
-Fix build failure on glibc 2.28 where 'renameat2' would end up being
-declared twice: <https://github.com/systemd/casync/issues/166>.
-
-From 625244ca47e8ee1375d2d0092271bfd13b0913ea Mon Sep 17 00:00:00 2001
-From: Daniel Mack <daniel@zonque.org>
-Date: Tue, 13 Nov 2018 17:52:48 +0100
-Subject: [PATCH] meson.build: pass -D_GNU_SOURCE when checking for functions
-
-As described in #166, -D_GNU_SOURCE needs to be passed to the meson function
-availability checker. h/t to @tomeon for providing a link to the solution as
-well.
----
- meson.build | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/meson.build b/meson.build
-index f42ed16..c0f741e 100644
---- a/meson.build
-+++ b/meson.build
-@@ -78,6 +78,6 @@ foreach ident : [
- ['copy_file_range', '''#include <sys/syscall.h>
- #include <unistd.h>'''],
- ]
-- have = cc.has_function(ident[0], prefix : ident[1])
-+ have = cc.has_function(ident[0], args : '-D_GNU_SOURCE', prefix : ident[1])
- conf.set10('HAVE_' + ident[0].to_upper(), have)
- endforeach
@@ -451,35 +451,42 @@ (define-public usync
(license license:expat))))
(define-public casync
- (package
- (name "casync")
- (version "2")
- (home-page "https://github.com/systemd/casync/")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit (string-append "v" version))))
- (sha256
- (base32
- "0znkp3fcksrykcsv06y2mjvf2lbwmin25snmvfa8i5qfm3f4rm88"))
- (file-name (string-append name "-" version "-checkout"))
- (patches (search-patches "casync-renameat2-declaration.patch"))))
- (build-system meson-build-system)
- (native-inputs
- (list pkg-config python-sphinx rsync)) ;for tests
- (inputs
- (list xz ;for liblzma
- `(,zstd "lib")
- curl
- acl
- libselinux
- fuse
- openssl
- zlib))
- (synopsis "File synchronization and backup system")
- (description
- "casync is a @dfn{content-addressable data synchronizer} that can be used
+ (let ((commit "99559cd1d8cea69b30022261b5ed0b8021415654")
+ (revision "0"))
+ (package
+ (name "casync")
+ (version (git-version "2" revision commit))
+ (home-page "https://github.com/systemd/casync/")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (sha256
+ (base32
+ "139g82rkwv1kzss6crfmw3p01xnyjzz66b1ckprpbfncxb24047w"))
+ (file-name (string-append name "-" version "-checkout"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:configure-flags
+ (let ((out (assoc-ref %outputs "out")))
+ (list (string-append "-Dudevrulesdir="
+ out "/lib/udev/rules.d")))))
+ (native-inputs
+ (list pkg-config python python-sphinx rsync)) ;for tests
+ (inputs
+ (list xz ;for liblzma
+ `(,zstd "lib")
+ curl
+ acl
+ libselinux
+ eudev
+ fuse
+ openssl
+ zlib))
+ (synopsis "File synchronization and backup system")
+ (description
+ "casync is a @dfn{content-addressable data synchronizer} that can be used
as the basis of a backup system. It is:
@itemize
@@ -490,7 +497,7 @@ (define-public casync
over the Internet in an HTTP and CDN friendly way;
@item An efficient backup system.
@end itemize\n")
- (license license:lgpl2.1+)))
+ (license license:lgpl2.1+))))
(define-public rclone
(package
--
2.36.1