diff mbox series

[bug#55679,1/2] gnu: Add r-googlevis.

Message ID 20220527164013.4195-1-madalinionel.patrascu@mdc-berlin.de
State Accepted
Headers show
Series [bug#55679,1/2] gnu: Add r-googlevis. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu May 27, 2022, 4:40 p.m. UTC
* gnu/packages/cran.scm (r-googlevis): New variable.
---
 gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)


base-commit: 0e953f3332cc862b08ecb2342bdac9976dd6d08c

Comments

Ricardo Wurmus May 28, 2022, 10:44 p.m. UTC | #1
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

> * gnu/packages/cran.scm (r-googlevis): New variable.

I applied this and the patch for r-scmap after minor formatting
changes.  Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0fdcfb3cb9..ae90e5f162 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -402,6 +402,33 @@  (define-public r-googledrive
     (description "This package lets you manage Google Drive files from R.")
     (license license:expat)))
 
+(define-public r-googlevis
+  (package
+    (name "r-googlevis")
+    (version "0.7.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "googleVis" version))
+        (sha256
+          (base32 "1s82xcs6zrlmnhay764bspzwvabfyi35nq6fwdrrk3v79q13c5jz"))))
+    (properties `((upstream-name . "googleVis")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-jsonlite))
+    (native-inputs (list r-knitr))
+    (home-page "https://mages.github.io/googleVis/")
+    (synopsis "R interface to Google Charts")
+    (description
+      "The @code{googleVis} package provides an interface between R and the
+Google Charts API.  Google Charts offer interactive charts which can be embedded
+into web pages.  The functions of the @code{googleVis} package allow the user to
+visualise data stored in @code{R} data frames with Google Charts without
+uploading the data to Google.  The output of a @code{googleVis} function is
+@code{HTML} code that contains the data and references to JavaScript functions
+hosted by Google.  @code{googleVis} makes use of the internal @code{R}
+@code{HTTP server} to display the output locally.")
+    (license license:gpl2+)))
+
 (define-public r-guix-install
   (package
     (name "r-guix-install")