diff mbox series

[bug#55379,04/14] gnu: Add r-unpivotr.

Message ID 1f41a6214bca3a6d4ce93866e9c4467319309084.1651893551.git.kyle@posteo.net
State New
Headers show
Series [bug#55379,01/14] gnu: Add r-gpg. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

kyle May 12, 2022, 2:10 a.m. UTC
From: Kyle Andrews <kyle@posteo.net>

---
 gnu/packages/cran.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

M May 14, 2022, 10:53 a.m. UTC | #1
kyle schreef op do 12-05-2022 om 02:10 [+0000]:
> +   (license license:expat)))


The license text appears to be missing, even though the Expat license
says:

  [...] subject to the following conditions:

  The above copyright notice and this permission notice shall be
  included in all copies or substantial portions of the Software.

So as-is, I don't think we can include r-unpivotr in Guix.  Would
probably be easily resolved with a PR or issue at
<https://github.com/nacnudus/unpivotr>.

Greetings,
Maxime.
kyle May 18, 2022, 1:09 a.m. UTC | #2
Maxime Devos <maximedevos@telenet.be> writes:

> [[PGP Signed Part:Undecided]]
> kyle schreef op do 12-05-2022 om 02:10 [+0000]:
>> +   (license license:expat)))
>
>
> The license text appears to be missing, even though the Expat license
> says:
>
>   [...] subject to the following conditions:
>
>   The above copyright notice and this permission notice shall be
>   included in all copies or substantial portions of the Software.
>
> So as-is, I don't think we can include r-unpivotr in Guix.  Would
> probably be easily resolved with a PR or issue at
> <https://github.com/nacnudus/unpivotr>.
>
> Greetings,
> Maxime.
>
> [[End of PGP Signed Part]]

I did just that and the package author merged my pull request with the
MIT license text.

Cheers,
Kyle
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9578263789..213f810d04 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33303,6 +33303,41 @@  (define-public r-tidyxl
 <http://rapidxml.sourceforge.net>.  Does not support '.xlsb' or '.xls'.")
     (license license:gpl3)))
 
+(define-public r-unpivotr
+  (package
+   (name "r-unpivotr")
+   (version "0.6.2")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (cran-uri "unpivotr" version))
+     (sha256
+      (base32 "1paqx2jn8gh4nd4zm8iwxpf38znzwwqli62ww7f3k5vwkf34r078"))))
+   (properties `((upstream-name . "unpivotr")))
+   (build-system r-build-system)
+   (propagated-inputs
+    (list r-cellranger
+          r-dplyr
+          r-forcats
+          r-magrittr
+          r-pillar
+          r-purrr
+          r-rlang
+          r-tibble
+          r-tidyr
+          r-tidyselect
+          r-xml2))
+   (native-inputs (list r-knitr))
+   (home-page "https://github.com/nacnudus/unpivotr")
+   (synopsis "Unpivot Complex and Irregular Data Layouts")
+   (description
+    "Tools for converting data from complex or irregular layouts to a columnar
+structure.  For example, tables with multilevel column or row headers, or
+spreadsheets.  Header and data cells are selected by their contents and
+position, as well as formatting and comments where available, and are associated
+with one other by their proximity in given directions.  Functions for data
+frames and HTML tables are provided.")
+   (license license:expat)))
 (define r-gpg
   (package
    (name "r-gpg")