diff mbox series

[bug#55295] gnu: gcolor3: Fix build with libportal-0.5

Message ID 3x0UR1PjJhbOj9nmgJBzCZ3h6GpydLeDXehH_EPG3Hbw-icJk3bFHpgv9spXH1Q4DNlH2ngTU0_EJaCb9wmBsZnMPUJDdM6_2f9mKiCrrQ0=@proton.me
State Accepted
Headers show
Series [bug#55295] gnu: gcolor3: Fix build with libportal-0.5 | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sughosha May 8, 2022, 9:41 p.m. UTC
Sorry, one small correction to the above (a comment was containing misleading version number)..

---
gnu/packages/gnome.scm | 4 +-
.../gcolor3-update-libportal-usage.patch | 55 +++++++++++++++++++
2 files changed, 58 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/gcolor3-update-libportal-usage.patch

+ ],
+ install: true,
+--
+GitLab
+
--2.36.0
------- Original Message -------
Sughosha <Sughosha@proton.me> schrieb am Sonntag, 8. Mai 2022 um 23:21:

> ---
> gnu/packages/gnome.scm | 4 +-
> .../gcolor3-update-libportal-usage.patch | 55 +++++++++++++++++++
> 2 files changed, 58 insertions(+), 1 deletion(-)
> create mode 100644 gnu/packages/patches/gcolor3-update-libportal-usage.patch
>
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index dae6692109..53eec9336d 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -10321,7 +10321,9 @@ (define-public gcolor3
> (commit (string-append "v" version))))
> (file-name (git-file-name name version))
> (sha256
> - (base32 "1igqmach1vhcrvbpw346pmkbb5kabbb806ssswrvkp569n700wmc"))))
> + (base32 "1igqmach1vhcrvbpw346pmkbb5kabbb806ssswrvkp569n700wmc"))
> + ;; XXX: Remove when upgrading to 42.0
> + (patches (search-patches "gcolor3-update-libportal-usage.patch"))))
> (build-system meson-build-system)
> (arguments
> `(#:glib-or-gtk? #t))
> diff --git a/gnu/packages/patches/gcolor3-update-libportal-usage.patch b/gnu/packages/patches/gcolor3-update-libportal-usage.patch
> new file mode 100644
> index 0000000000..0d19b124fd
> --- /dev/null
> +++ b/gnu/packages/patches/gcolor3-update-libportal-usage.patch
> @@ -0,0 +1,55 @@
> +Fix gcolor3 to work with libportal-0.5
> +
> +This patch is extracted from upstream, see here
> +https://gitlab.gnome.org/World/gcolor3/-/commit/1750369a3fd922aa9db6916207dc460c6f885e14
> +
> +From 1750369a3fd922aa9db6916207dc460c6f885e14 Mon Sep 17 00:00:00 2001
> +From: Michal Vasilek <michal@vasilek.cz>
> +Date: Mon, 27 Dec 2021 13:47:14 +0100
> +Subject: [PATCH] Update to libportal 0.5
> +
> +---
> + meson.build | 2 ++
> + src/gcolor3-color-selection.c | 2 +-
> + src/meson.build | 1 +
> + 3 files changed, 4 insertions(+), 1 deletion(-)
> +
> +diff --git a/meson.build b/meson.build
> +index 6453679..7d6dc50 100644
> +--- a/meson.build
> ++++ b/meson.build
> +@@ -7,9 +7,11 @@ dep_gtk = dependency('gtk+-3.0', version: '>= 3.20.0', required: true)
> + dep_libportal = dependency(
> + 'libportal',
> + required: true,
> ++ version: '>= 0.5',
> + fallback: ['libportal', 'libportal_dep'],
> + default_options: ['gtk_doc=false'],
> + )
> ++dep_libportal_gtk3 = dependency('libportal-gtk3', version: '>= 0.5', required: true)
> + cc = meson.get_compiler('c')
> + dep_lm = cc.find_library('m', required: true)
> +
> +diff --git a/src/gcolor3-color-selection.c b/src/gcolor3-color-selection.c
> +index 7413850..5df9d54 100644
> +--- a/src/gcolor3-color-selection.c
> ++++ b/src/gcolor3-color-selection.c
> +@@ -41,7 +41,7 @@
> + #include <gtk/gtk.h>
> + #include <glib/gi18n.h>
> + #include <libportal/portal.h>
> +-#include <libportal/portal-gtk3.h>
> ++#include <libportal-gtk3/portal-gtk3.h>
> +
> + #ifdef ENABLE_NLS
> + #define P_(String) g_dgettext(GETTEXT_PACKAGE "-properties",String)
> +diff --git a/src/meson.build b/src/meson.build
> +index 3998f68..d488e51 100644
> +--- a/src/meson.build
> ++++ b/src/meson.build
> +@@ -42,6 +42,7 @@ executable(
> + dependencies: [
> + dep_gtk,
> + dep_libportal,
> ++ dep_libportal_gtk3,
> + dep_lm
> + ],
> + install: true,
> +--
> +GitLab
> +
> --
> 2.36.0

Comments

Ludovic Courtès May 16, 2022, 1:51 p.m. UTC | #1
Hi,

Sughosha <Sughosha@proton.me> skribis:

> Sorry, one small correction to the above (a comment was containing misleading version number)..
>
> ---
>  gnu/packages/gnome.scm                        |  4 +-
>  .../gcolor3-update-libportal-usage.patch      | 55 +++++++++++++++++++
>  2 files changed, 58 insertions(+), 1 deletion(-)
>  create mode 100644 gnu/packages/patches/gcolor3-update-libportal-usage.patch

I added the new file to ‘gnu/local.mk’, including a conventional commit
log, and pushed as commit 5ba12f0176300d154b086485ecf363f10f283a9f.

Please take a look at
<https://guix.gnu.org/manual/devel/en/html_node/Submitting-Patches.html>
if unsure about the project conventions.  I’d also encourage you to send
patches with ‘git send-email’—pasting them in your mail client might
mangle them.

Thank you and thanks Daniel for taking a look!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index dae6692109..53eec9336d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10321,7 +10321,9 @@  (define-public gcolor3
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1igqmach1vhcrvbpw346pmkbb5kabbb806ssswrvkp569n700wmc"))))
+ (base32 "1igqmach1vhcrvbpw346pmkbb5kabbb806ssswrvkp569n700wmc"))
+ ;; XXX: Remove when upgrading
+ (patches (search-patches "gcolor3-update-libportal-usage.patch"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t))
diff --git a/gnu/packages/patches/gcolor3-update-libportal-usage.patch b/gnu/packages/patches/gcolor3-update-libportal-usage.patch
new file mode 100644
index 0000000000..0d19b124fd
--- /dev/null
+++ b/gnu/packages/patches/gcolor3-update-libportal-usage.patch
@@ -0,0 +1,55 @@ 
+Fix gcolor3 to work with libportal-0.5
+
+This patch is extracted from upstream, see here
+https://gitlab.gnome.org/World/gcolor3/-/commit/1750369a3fd922aa9db6916207dc460c6f885e14
+
+From 1750369a3fd922aa9db6916207dc460c6f885e14 Mon Sep 17 00:00:00 2001
+From: Michal Vasilek <michal@vasilek.cz>
+Date: Mon, 27 Dec 2021 13:47:14 +0100
+Subject: [PATCH] Update to libportal 0.5
+
+---
+ meson.build | 2 ++
+ src/gcolor3-color-selection.c | 2 +-
+ src/meson.build | 1 +
+ 3 files changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 6453679..7d6dc50 100644
+--- a/meson.build
++++ b/meson.build
+@@ -7,9 +7,11 @@ dep_gtk = dependency('gtk+-3.0', version: '>= 3.20.0', required: true)
+ dep_libportal = dependency(
+ 'libportal',
+ required: true,
++ version: '>= 0.5',
+ fallback: ['libportal', 'libportal_dep'],
+ default_options: ['gtk_doc=false'],
+ )
++dep_libportal_gtk3 = dependency('libportal-gtk3', version: '>= 0.5', required: true)
+ cc = meson.get_compiler('c')
+ dep_lm = cc.find_library('m', required: true)
+
+diff --git a/src/gcolor3-color-selection.c b/src/gcolor3-color-selection.c
+index 7413850..5df9d54 100644
+--- a/src/gcolor3-color-selection.c
++++ b/src/gcolor3-color-selection.c
+@@ -41,7 +41,7 @@
+ #include <gtk/gtk.h>
+ #include <glib/gi18n.h>
+ #include <libportal/portal.h>
+-#include <libportal/portal-gtk3.h>
++#include <libportal-gtk3/portal-gtk3.h>
+
+ #ifdef ENABLE_NLS
+ #define P_(String) g_dgettext(GETTEXT_PACKAGE "-properties",String)
+diff --git a/src/meson.build b/src/meson.build
+index 3998f68..d488e51 100644
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -42,6 +42,7 @@ executable(
+ dependencies: [
+ dep_gtk,
+ dep_libportal,
++ dep_libportal_gtk3,
+ dep_lm